Jump to content
Cassio

Instalação do OS X 10.8 Mountain Lion GM

Recommended Posts

O processo de instalação do 10.8 é o mesmo que o do 10.7 http://Olarila.com/forum/viewtopic.php?f=3&t=108


Monte o InstallESD.dmg que se encontra na pasta Contents/SharedSupport do Install OS X Mountain Lion.app


Monte o BaseSystem.dmg que está (oculto) em Mac OS X Install ESD

open /Volumes/Mac\ OS\ X\ Install\ ESD/BaseSystem.dmg

 

Usando o Utilitário de Disco restaure a partição Mac OS X Base System para uma partição vazia no formato Mac OS Expandido (Reg. Cronológico)


Remova o link Packages da pasta System/Installation da nova partição

rm /Volumes/Mac\ OS\ X\ Base\ System\ 1/System/Installation/Packages

 

Copie a pasta Packages de Mac OS X Install ESD para a pasta System/Installation da nova partição

cp -R /Volumes/Mac\ OS\ X\ Install\ ESD/Packages /Volumes/Mac\ OS\ X\ Base\ System\ 1/System/Installation

 

Copie o arquivo (oculto) mach_kernel de Mac OS X Install ESD para a raiz da nova partição

cp /Volumes/Mac\ OS\ X\ Install\ ESD/mach_kernel /Volumes/Mac\ OS\ X\ Base\ System\ 1

 

Instale o Chameleon na nova partição http://Olarila.com/forum/viewtopic.php?f=9&t=70


Copie o Extensions.mkext para a pasta Extra da nova partição http://Olarila.com/forum/download/file.php?id=1187


Copie um smbios.plist completo (com SMboardproduct) para a pasta Extra. Se ainda não tiver, use o Chameleon Wizard para criar um compatível com o seu hardware http://Olarila.com/forum/viewtopic.php?f=9&t=398


Se precisar, copie um dsdt.aml ajustado para a pasta Extra. Se ainda não tiver, leia http://Olarila.com/forum/viewtopic.php?f=7&t=646


Opcional: OSInstall framework & mpkg modificados para instalar em partição MBR

http://www.mediafire.com/?4u74as83z74p3dp

tar zxvf ~/Downloads/MountainLion_GM_MBR_Patch.tar.gz -C /Volumes/Mac\ OS\ X\ Base\ System\ 1

 

Faça boot da nova partição e instale o sistema em outra partição vazia.


Instale as kexts necessárias para o seu hardware no novo sistema. As kexts do 10.6 e 10.7 funcionam no 10.8.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Obrigado pelo tutorial - vou em breve testar num dos meus hackintoshes.

É incrível como a Apple não tenta fazer a vida mais complicada à instalação nos hackintoshes - será que é não é possível? :roll:

"MacMiniPro" - Core i3 2100 3.1Ghz // 8GB DDR3 // 500GB Seagate Momentus XT HDD // Nvidia 8600GT QE/CI // 10.8.3 ML

Toshiba Portegé R830 - Core i3 2330M 2.2Ghz // 8GB DDR3 // 750GB Seagate Momentus XT // Intel HD3000 QE/CI // 10.8.3 ML

Link to comment
Share on other sites

Aí pessoal, esse tutorial funciona pra mim como uma luva.

Muito simples de acompanhar e de fácil compreensão.


Recomendo muito.

Quem teve experiência com o Lion vai achar esse aí sopa no mel. ;)


Cheers,

bb.

[MOBO] GA-EP45-UD3L [CPU] C2Q | Q6600 [RAM] 4Gb Kingston [GFX] GeForce 9800GT [DISPLAY] BX2350 (Mac Compatible) [OPTICAL] TSSTcorp CDDVDW SH-S223C/BEBE [M&K] Magic Mouse + Aluminum Wireless [AUDIO] ALC888 [MOBILE] iPhone 4 32 Gb [OS] Snow Leopard - 10.7.4 + Chameleon 2 RC5 Snow/Lion + fakesmc 2.5

Link to comment
Share on other sites

Tentei intalar aqui mas sempre da reboot. Tenho instalado 10.7.3 funcionando perfeito pelo mesmo metodo, ao invés do usb tenho uma partição com o lion, tentei tb esse metodo no ML e não funcionou.


Segui todo procedimento e coloquei a minha pasta Extra e dsdt do Lion, tentei tb sem dsdt e com nullcpu e da na mesma.



Se tiverem uma luz agradeço



Abç

mobo: DX58SO

cpu: i7 950

gpu: Sapphire 5770 Vapor -x

mem: 6GB 1333mhz

VIDEO


HCLhttp://wiki.osx86project.org/wiki/index.php/HCL_10.7.3#Intel

Link to comment
Share on other sites

 


Valeu Cassio !!!


Consegui instalar usando o arch=i386, mas o sistema so boota com o argumento, existe mais alguma coisa a se fazer ou por enquanto so vai funcionar em 32bit msm ???


Preciso fazer testes ainda, mas som e ethernet estao funfando de boa.

mobo: DX58SO

cpu: i7 950

gpu: Sapphire 5770 Vapor -x

mem: 6GB 1333mhz

VIDEO


HCLhttp://wiki.osx86project.org/wiki/index.php/HCL_10.7.3#Intel

Link to comment
Share on other sites

Teria que ver o que têm em comum esses casos em que só inicia em i386. Talvez alguma config no BIOS que precise mudar em relação aos "optimized defaults"?

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Falaew Pessoal...


acabei de instalar o mountain lion ak[i no meu computador, uma gigabyte ga g31m-es2l + C2D 3,21 + nvidia 8400gs ddr3 da EVGA...

Foi de primeira... segui o tuto e foi batata... a unica coisa q me incomoda e o boot com os argumentos (arch=i386 npci=0x2000) mesmo na pasta extra feita pelo chameleon ainda insiste em reboot ou pci configuration begin... alguma ideia?


Obrigado pela ajuda e postarei fotos em breve... so pra ressaltar, minha placa grafica esta funcionando sem mesmo precisar colocar nenhuma kext, so coloquei a de rede e esta perfeito mesmo sem aceleracao grafica mas vejo videos do youtoba e tudo mais!!


Vlws!!!

Gigabyte GA B75M-D2V / Core i5 - 3330 ivy bridge 3.0Ghz / EVGA GTX750 ti FTW 2gb / 8Gb DDR3 Markvision / 500Gb Hdd Seagate - SSD kingstone 60gb / USB Mouse & Keyboard
Link to comment
Share on other sites

Então Arthur...


acabou q o sistema está entrando normal agora sem precisar fazer nenhuma modificação... eu q estava dando bobeira pq fazia o boot por outro hd onde tem o snow com o chimera como bootloader e naum o do mountain lion como deveria...


O sistema é muito mais leve q o snow e só precisei instalar a kext de rede (atherosL1cEthernet.kext) e de resto foi reconhecido de cara... até o vídeo!

EVGA geforce 8400gs 512Mb ddr3!!


screenshot20120229at223.png

Gigabyte GA B75M-D2V / Core i5 - 3330 ivy bridge 3.0Ghz / EVGA GTX750 ti FTW 2gb / 8Gb DDR3 Markvision / 500Gb Hdd Seagate - SSD kingstone 60gb / USB Mouse & Keyboard
Link to comment
Share on other sites

Sim... já ia me esquecendo!!


como minha instalação foi "perfeita" só faltando a kext de rede me surge duas perguntas...


- se eu colocar minha kext de rede(AtherosL1cEthernet.kext) na pasta extensions na partição da instalação o sistema já é instalado com a rede??!

- Consigo passar essa partição de instalação para um dvd de modo q ela faça boot para uma instalação futura?? como seria esse procedimento? criar uma nova imagem pelo disk utility e passar todos os arquivos, inclusive os ocultos, para dentro dessa nova imagem e queima-la em um dvd será q seria lida no boot ou teria q reinstalar o chameleon antes de queimar a imagem para q ela dê o boot direto do dvd q criei??!


Obrigado!! :ugeek:

Gigabyte GA B75M-D2V / Core i5 - 3330 ivy bridge 3.0Ghz / EVGA GTX750 ti FTW 2gb / 8Gb DDR3 Markvision / 500Gb Hdd Seagate - SSD kingstone 60gb / USB Mouse & Keyboard
Link to comment
Share on other sites

- se eu colocar minha kext de rede(AtherosL1cEthernet.kext) na pasta extensions na partição da instalação o sistema já é instalado com a rede??!

Não, vai ter que instalar a kext de novo.

 

- Consigo passar essa partição de instalação para um dvd de modo q ela faça boot para uma instalação futura?? como seria esse procedimento? criar uma nova imagem pelo disk utility e passar todos os arquivos, inclusive os ocultos, para dentro dessa nova imagem e queima-la em um dvd será q seria lida no boot ou teria q reinstalar o chameleon antes de queimar a imagem para q ela dê o boot direto do dvd q criei??!

Mesmo procedimento que o Lion http://Olarila.com/forum/viewtopic.php?f=3&t=728


Só não pode ser o Chameleon oficial (pelo menos até a versão atual), tem que ser uma versão modificada para ML como esta http://Olarila.com/forum/download/file.php?id=1436

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Sim, sim to ligado...


seguí os passos mas o passo 9 onde vc diz pra criar o ISO inicializavel eu naum entendí bem... digitei no terminal a linha de comando e tenho essa imagem... como proceder agora?

Gigabyte GA B75M-D2V / Core i5 - 3330 ivy bridge 3.0Ghz / EVGA GTX750 ti FTW 2gb / 8Gb DDR3 Markvision / 500Gb Hdd Seagate - SSD kingstone 60gb / USB Mouse & Keyboard
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
  • Create New...
The popup will be closed in 15 seconds...