Jump to content
Guest Icaro82

Can Sidecar works in a Legacy system?

Recommended Posts

Guest Icaro82

Hi everyone,

I've been reading and testing for months  and Sidecar still doesn’t work in my hackintosh.

My hardware:
CPU: Xeon x5675 (Legacy / Westmere) - BAD because it’s old and it has no iGPU.
Ati RX 590 - GOOD because it’s full compatible with OSX.
Fenvi T919 - GOOD because it’s full compatible with OSX.

Device: iPad Pro 3rd Gen
System: Catalina 10.15.3
Bootloader: OpenCore

Tests and what I have been learned:

SMBIOS iMacPro 1.1 or MacPro 7.1
It works very well with the dGPU but it depends on the T2 chip for Sidecar works. As a result I get a black screen on the iPad.

SMBIOS from previous iMacs
H264 and HEVC solved with shikigva=128 but DRM content not working (this is not important for me right now). Sidecar shows me Timed Out error.

SMBIOS iMacPro 6.1
I used a patched version of Sidecar for unsupported systems but it didn't work. I think because I upgrated Catalina to the latest version.

I would greatly appreciate any help or advice. For me it’s very important to have Sidecar working because I ‘m a graphic designer and this is a very useful functionality for my daily work.

Thank you all!!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...