Jump to content
HackAlexS

HDMI and Displayport works until I remove NVidia

Recommended Posts

Hello

I have a Dell Inspirton 10th Gen 7591 Inspiron laptop.

I've managed to get HDMI (full UHD) and 2 x Displayport (HD only) to work with the internal display (although the displayport monitor mirror each other). The Intel UHD 630 is the primary monitor with full acceleration.

So now I'm disabling the Nvidia card which works with an ACPI patch (attached in link), however I lose all my external monitors.

What am I doing wrong?

config.plist and ACPI patch here on wetranfer (I can't seem to free up attachment space):
https://we.tl/t-IJqJTueH97

BEFORE PATCH:

spacer.png

spacer.png

 

AFTER PATCH (No display):

spacer.png

 

spacer.png

 

Thanks!

Link to comment
Share on other sites

Unfortunately I am no longer allowed to upload attachments because my allocation is full, nor can I delete attachments to free up space.

I notice the image sizes are being reduced in these forums with no way to enlarge so here they are in full resolution:


https://ibb.co/CBqStTs


https://ibb.co/SKRZL0T
 

https://ibb.co/cJmXPwT
 

https://ibb.co/fkvK2qt

Also if webmaster is watching, we are only allowed to post every 25-30 minutes.

Link to comment
Share on other sites

  • Administrators
4 minutes ago, HackAlexS said:

Unfortunately

in some cases hdmi output work on dgpu, check it

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

  • Administrators
3 hours ago, HackAlexS said:

Confirmed. 3 displays:

use hackintool for connectors patch

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

40 minutes ago, MaLd0n said:

use hackintool for connectors patch

I've already shown four screenshots of Hackintool (two without nvidia disabled, two after with nvidia disabled). Can't get anywhere. Are you able to see my attachments? I had to post hi-res links in the second post.

One thing I've done is made sure the connector is HDMI for the external monitor but still does not make a difference:
framebuffer-con1-type: 00080000 

To repeat everything works great until NVidia is disabled. Further info in the screenshots.

 

Thx.

Edited by HackAlexS
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...