Jump to content
Sign in to follow this  
intommy

Toshiba Tecra Z40-C-11E - almost perfect hack

Recommended Posts

Posted (edited)

Toshiba Tecra Z40-C-11E - Catalina 10.15.2


Intel Core i5 6200U Skylake, Intel HD Graphics 520, 8GB DDR 3 (2x4), 240GB SSD Patriot, 14" Full HD LED IPS matte, Backlit keyboard


working:

almost everything


not-working

Wi-Fi and BT (intel card need be replaced - DW1820A, #08PKF4, 106B:0023), atm testing https://osxlatitude.com/forums/topic/11322-broadcom-bcm4350-cards-under-high-sierramojavecatalina/)BROADCOM BCM4350 - Dell DW1820A (have this model - 1028:0023 (part # CN-08PKF4))


Clean instalation followed this guide - https://Olarila.com/forum/viewtopic.php?f=50&t=8685


Post install:

- disablehibernate.command

- master-disable.command,

- Clover v2.5k r5102 EFI parms:

Clover for UEFI booting only

Install Clover in the ESP

UEFI drivers (recommended drivers and APFSDriverLoader in File System Drivers

- Download and copy correct EFI folders from Olarila (Skylake nb files)

- reinstall Clover again

- reboot

- put DSDT.aml, thanks Mald0n, inside Clover/Acpi/patched (my DSDT created without this w-fi card inside, dont need a make new one?)

- reboot


- clover injection for wifi (followed this guide: https://osxlatitude.com/forums/topic/11322-broadcom-bcm4350-cards-under-high-sierramojavecatalina/?do=findComment&comment=89830 )

so far so good.. :P



Problems:

- some key for laptop control i want replace to another keys (remap)... like contrast down on F12 and up on pause key (via Fn key), sound off on Fn ESC but volume up/down on Fn+2 and +3, ..)

Edited by Guest

Share this post


Link to post
Share on other sites

[ref]intommy[/ref], extract one send_me

Share this post


Link to post
Share on other sites

[ref]intommy[/ref], Extract tables with F4 key in Clover boot screen, files generated in Clover/Acpi/origin, post here

Share this post


Link to post
Share on other sites

boot, replacing ADST.aml in /patched with new one. Boot, enable WIFI/BT in Bios, boot

verbose, apple logo (like 30-40 sec) then start, password, again like 20 sec nothing, system desktop show, all is laggy and slow reaction time, wifi not works.

System stop responding. Turn off with 4sec holding power button. Second boot ->> KP


3th boot seems ok about speed, again little laggy after password. Wifi not working, BT not show


Inside info - system Preferences: PCI is now WIFI show, but wrote about driver no installed. Same in Wifi section - no utility installed.

(System seems respond ok atm..)

wifi-Screenshot-2020-01-08-at-05-42-17.png

wifi-2-Screenshot-2020-01-08-at-05-46-01.png


when i close LID, display do off, power led still up (not blinkin like in sleep) and after lid open display still black, not goin back to system (this start with insert wifi card inside nb i think, i can only power off and boot again - KP after boot, then boot normally). Same thing when system just do off diplay.. cant wake-up it.


From Hackintool:


Screenshot-2020-01-08-at-07-20-30.png


https://filebin.net/focmml2fkiqteb6d


----------------------


EDIT after some hours:


system seems stable, testing while playing Heartstone and browsing web, listening music or a watchin videos. But every second/third boot is KP now. even if WIFI is disabled in bios. i today test Clover injection and after this clean install again :P (i love installations) :P


-------------------------

EDIT 2:


when i use old DSDT.aml which Mald0n made year ago for my Toshiba, sleep works well :), but now is change in laptop like new Bios and now new wifi.


EDIT 3:


my both DSDT


https://filebin.net/arlg3yjs570yqskh

Share this post


Link to post
Share on other sites

STEP ONE - CHECK!!!! :D:D:D


WiFi works now. (but atm only 2,4 GHz), BT not appear actually (step by step)


I use my old DSDT (this one without sleep and boot trouble, no idea atm what is wrong with new one), maybe I try ask Mald0n for next new one


I follow Clover injection guide - https://osxlatitude.com/forums/topic/11322-broadcom-bcm4350-cards-under-high-sierramojavecatalina/?do=findComment&comment=89830. (at the end this post)


via clover I added new device and use boot argument. brcmfx-country=#a


boot argument brcmfx-country=XX (where XX is the target value, eg: US, FR, #a, etc.) to the Boot section of your Clover config

I save my config like config wiki and on clover start a choose this one, turning on wifi in bios, boot and voila...



Screenshot-2020-01-09-at-18-16-55.png


With country code #a and #CZ works but still only 2,4ghz. Atm i mising somethin.. workin on it.

Here they wrote about pin masking, maybe i try this also? - https://osxlatitude.com/forums/topic/12169-bcm4350-cards-registry-of-cardslaptops-interop/page/3/?tab=comments#comment-97045



Edit 1:

after some time, system seems stable, wifi works also after wake up from sleep.

still here some KP after boot / reboot or start system, mostly second/third boot works ok.. no idea why


Edit 2:

testing PIN masking 2 front and 3 front 2 back, BT start workin (unstable sometimes) lost wifi.

Share this post


Link to post
Share on other sites

Ok, some news about my laptop..

my wifi Dell DW1820A is  model 1028:0023 (part # CN-08PKF4), 

still only 2,4GHz wifi, no BT.

with Pin masking got BT works, but only see devices arround after connect got disconect and stop BT. Also with pin masking NO WIFI.

I follow this post. 

With DW1820A just disabled Wifi in BIOS thru install and after injection (i use clover injection) enable back. Same with system update. for update from 10.15.2 to 10.15.3 via Apple system update i must disable wifi and after update complete enable again.

System is rly stable "with only" 2,4GHz

Actually i order new one card with different CN (i hope) :) and we see... Btw also still thinkin about DW1560, but not sure, this prize is like 4x more than DW1820A... :)

  • Like 1

Share this post


Link to post
Share on other sites

Test install Mojave and same method - same result like Catalina. So.. Cold case now till new card arrived here :)

  • Like 1

Share this post


Link to post
Share on other sites

New card here :) from ebay :) and its works 2,4/5 and BT :)

Sni-mek-obrazovky-2020-02-14-v-18-24-54. Sni-mek-obrazovky-2020-02-14-v-18-25-21. Sni-mek-obrazovky-2020-02-14-v-18-16-25. Sni-mek-obrazovky-2020-02-14-v-18-16-57.

 

Sni-mek-obrazovky-2020-02-14-v-18-33-07.

 

Card Apple A1465 A1466 653-0023 BroadCom BCM94360CS2 Wireless WIFI Bluetooth Card

https://www.ebay.com/itm/Apple-A1465-A1466-653-0023-BroadCom-BCM94360CS2-Wireless-WIFI-Bluetooth-Card/114085278416?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649

and adapter  BCM94360CS2 BCM943224PCIEBT2 12+6 Pin WIFI wireless card module to NGFF M.2 YG

https://www.ebay.com/itm/BCM94360CS2-BCM943224PCIEBT2-12-6-Pin-WIFI-wireless-card-module-to-NGFF-M-2-YG/323962752807?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649

happy now :) fast delivery in Europe and good prize

still testing, also need test in my second laptop.

 

 

Edited by intommy
  • Like 1

Share this post


Link to post
Share on other sites

Hey how did you manage to fix sleep i got black screen on wake but it goes to sleep fine using opencore btw and i have same cpu 

Share this post


Link to post
Share on other sites

i have clover. And in last month i like tested mojave and catalina (reinstalled maybe 4-5 times) many times, and here no problem with sleeping. sometimes only long time till laptop off when i do off. But after i close lid or use power button or menu/sleep, everything is ok for me. Mald0n prepare my DSDT and seems all fine (only touchpad dont work correctly - workin aka mouse - 2 button, but works)

Share this post


Link to post
Share on other sites

 

while boot clover, for notebook choose config2.plist

 

Edited by intommy

Share this post


Link to post
Share on other sites

After some time of use, the laptop works very well on OSX Catalina. Wifi / BT without any problem, handoff, airdrop, iMessage and also FaceTime work very well.

What I have been still is a touchpad, which I failed to install, working in the mode of mouse and single click and double clicks.

I haven't been able to make AirPlay work yet, my iPhone laptop can't be found, probably I miss something in the graphics card setup?

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

got this problem while boot today. Cant boot in OSX anymore atm:

 

IMG-0603.jpg

 

//i am out of home actually, dont have access to second mac or usb boot stick/drive, thanks for dual boot with windows :)

Edited by intommy

Share this post


Link to post
Share on other sites
Posted (edited)

I can't find any error with my hack.. so.. sometimes is quick way reinstall than lookin for error (even don't have any data, or many software installed)

anyway

during installation Olarila Image Catalina 10.15.3, before installing Clover (boot from USB) I have the option of mirroring the screen in the menu. However, once I install Clover and use my DSDT and my config with the serial number I have used and worked, this offer will disappear. Do I believe it's just a question of setting up intel graphics? Unfortunately I don't know where to look anymore ...

Incidentally, the previous error occurred after about 30 hours of use by the system shutdown - sleep - start / wake. During netflix playback, the system self-signed out several times after about 15 minutes. I wanted to look at the Saver settings, the panel did not open and an error message appeared. After restarting the system, it did not boot.
So I finally reinstalled everything and copied the EFI back up. Everything is in order (for now). I'll see, I'll test.
However, I would like to solve the Mirroring Screen if possible. (as I wrote at the beginning, when booting from the installation USB flash drive, I choose config2.plist, the mirror button is here...

any ideas? Where I can look for this?

Edited by intommy

Share this post


Link to post
Share on other sites

use a hackintool

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...