Jump to content
DanJacques

[pós-instalação] Acer F5-573-51LJ - EFI e kexts necessárias para o Catalina

Recommended Posts

Olá, bom dia/boa tarde/boa noite :P

Tudo tranquilo?


Pessoal, após ser tentado algumas vezes a testar o Hackintosh nos PCs que tive no passado, esse início de dezembro foi a época em que eu, efetivamente, resolvi pôr em prática os planos. Aproveitei a Black Friday pra comprar mais RAM e um SSD M.2 de 256GB para, enfim, tentar me aventurar no Hackintosh.


Pois bem. Meu notebook é um Acer Aspire F5-573-51LJ, com a seguinte configuração:

Processador: Core i5 7200U

Chipset: Boa pergunta rs. Deve ser um série 200 mobile para Kaby Lake

GPU: Intel UHD 620

RAM: 16GB DDR4

SSD: Lexar 256GB M.2 (comando SATA, pq eu não tinha certeza se o notebook suportava NVME)

Wireless: Atheros 9565

Audio: Realtek 255

Bluetooth: Atheros


Consegui instalar o Catalina sem problemas usando a imagem daqui do fórum, presente nesse tópico: https://Olarila.com/forum/viewtopic.php?f=51&t=13514


No entanto, não consegui fazer o Wifi funcionar usando o "Atheros Installer for 10.14 and 10.15" presente na pasta "Files" da imagem do Catalina. Pelo que eu consegui entender (lembrem-se: é a minha primeira aventura nessa área, então se eu estiver "noobando" demais, sejam bonzinhos haha), ele faz a instalação da Kext e altera algo no config.plist, mas como eu ainda não estou com o Clover corretamente configurado no SSD (ainda booto pelo pendrive), ele não inicia os módulos.


Aí chegamos no segundo ponto: ao colocar a EFI daqui: https://Olarila.com/forum/viewtopic.php?f=28&t=8222 (baixei a para Notebooks SKYLAKE+) o sistema parou antes da bootlogo, no meio da inicialização. Um vídeo contendo as últimas mensagens mostradas na tela, bem como o drama que eu estava fazendo, pode ser visualizado aqui: https://photos.app.goo.gl/aGXQmuHtNQziyXtz8


Sendo assim, peço ajuda para tentar corrigir o que eu estiver fazendo errado. Gostaria pelo menos de ter Wifi funcional e boot certinho via PC (sem pendrive), porque o resto (GPU, áudio, brilho) a gente corre atrás depois.


Agradeço desde já. E me proponho a, dando tudo certo, ir transformando esse tópico em uma fonte de informações sobre o note, para ajudar outros usuários com o mesmo modelo.

Link to comment
Share on other sites

  • Administrators

[ref]DanJacques[/ref],

1- Tem de usar a pasta correta

https://Olarila.com/forum/viewtopic.php?f=28&t=8222


2- Ativar o vídeo

https://Olarila.com/forum/viewtopic.php?f=28&t=10814


3- Extrair um send_me para o fine tune

RunMe.app

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

[ref]DanJacques[/ref],

1- Tem de usar a pasta correta

https://Olarila.com/forum/viewtopic.php?f=28&t=8222


2- Ativar o vídeo

https://Olarila.com/forum/viewtopic.php?f=28&t=10814


3- Extrair um send_me para o fine tune

RunMe.app

Muito obrigado!


A parte do vídeo eu realmente não tinha feito. Assim que eu reiniciar já faço, assim como o send_me..


Com relação a pasta, acredito que seja a correta. Consegui resolver de um jeito completamente bem gambiarra (mas funcionou, sabe se lá como):

Peguei a pasta Skylake+ Notebooks (da mesma página que você passou), e substituí o config.plist pelo usado em um tutorial do Acer 573G (que é bem parecido com ele), e o sistema bootou normalmente :mrgreen:


A pasta ficou assim: CLOVER.ZIP

A fonte do config.plist é essa: Acer Aspire F5-573G


Consegui também ativar o áudio, usando o AppleALC disponível aqui: https://github.com/acidanthera/AppleALC/releases


Nesse momento a prioridade tá sendo ativar a wifi mesmo. Tentei usar o instalador ali de cima, tentei usar as kexts disponíveis em alguns tópicos, mas nada funcionou. Qual o procedimento que o pessoal tá usando pra ligar a Atheros 9565 no Catalina?


Added in 56 minutes 56 seconds:

Vídeo ativado, Send_me gerado: http://s000.tinyupload.com/index.php?file_id=32750439273226386099

Link to comment
Share on other sites

  • Administrators

[ref]DanJacques[/ref], DSDT.aml.zip

esse config não está legal

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

[ref]DanJacques[/ref], DSDT.aml.zip

esse config não está legal

Bom saber. Vou tentar do jeito difícil, mas efetivo, da tentativa e erro.


Vou tentar ir vendo quais as diferenças do config.plist daqui do site e daquele que conseguiu bootar (que é baseado no Mojave), até achar qual configuração diferente foi responsável pelo sistema bootar. Enquanto não conheço as opções, vou testando rs


De todo modo, com essas pistas, achas que algo está atrapalhando a questão da wifi?

Link to comment
Share on other sites

  • Administrators

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

On 12/14/2019 at 5:16 PM, DanJacques said:

Muito obrigado!

 

A parte do vídeo eu realmente não tinha feito. Assim que eu reiniciar já faço, assim como o send_me..

 

Com relação a pasta, acredito que seja a correta. Consegui resolver de um jeito completamente bem gambiarra (mas funcionou, sabe se lá como):

Peguei a pasta Skylake+ Notebooks (da mesma página que você passou), e substituí o config.plist pelo usado em um tutorial do Acer 573G (que é bem parecido com ele), e o sistema bootou normalmente :mrgreen:

 

A pasta ficou assim: CLOVER.ZIP

A fonte do config.plist é essa: Acer Aspire F5-573G

 

Consegui também ativar o áudio, usando o AppleALC disponível aqui: https://github.com/acidanthera/AppleALC/releases

 

Nesse momento a prioridade tá sendo ativar a wifi mesmo. Tentei usar o instalador ali de cima, tentei usar as kexts disponíveis em alguns tópicos, mas nada funcionou. Qual o procedimento que o pessoal tá usando pra ligar a Atheros 9565 no Catalina?

 

Added in 56 minutes 56 seconds:

Vídeo ativado, Send_me gerado: http://s000.tinyupload.com/index.php?file_id=32750439273226386099

E aí, cara? Tenho um notebook igual ao seu. Estou usando o macOS Mojave. 
Tá usando o macOS Catalina ainda? Conseguiu instalar tudo?
Tô querendo atualizar.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...