Jump to content
MaLd0n

Olarila HackBook Lenovo ThinkPad E470 / Mojave / Catalina / Full DSDT Patches

Recommended Posts

-Donations with PayPal
https://tinyurl.com/r2bvzm7

-Donations with Bitcoin
33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

-Donations with PicPay 
@danielnmaldonado

-Donation with Mercado Livre 
https://tinyurl.com/y9evkj5u

 

B6aKgNy.jpg

 

-Update bios/uefi to last version ;)

 

-Tutorial-

 

--Clover Folder--

Just paste EFI folder inside EFI partition

https://www.olarila.com/files/Clover.Folder/EFI Lenovo Thinkpad E470.zip

 

UXpCqRE.png

 

-DSDT Patches

-FIX ERRORS AND WARNINGS
-REMOVE UNUSED SCOPES / DEVICES
-HIGH PRECISION EVENT TIMER
-DMAC
-SATA SERIE 11
-REMOVE LINES, PROBLEMATIC and UNUSED
-SLPB
-DARWIN / WINDOWS 2015
-XHCI
-PLUGIN TYPE
-HDAS to HDEF
-HDEF
-REAL TIME CLOCK
-ARTC
-IRQs
-SBUS
-BUS1
-MCHC
-ALS0
-SHUTDOWN
-FWHD
-USBX
-PMCR
-PPMC
-XSPI
-GMM
-IMEI
-EC
-PRWs
-_DSMs
-PNLF
-BRIGHTNESS KEYS
-ARPT
-GFX0
-DTGP
-ACQUIRE MUT0 0XFFFF
-OPERATION REGION GPIO
-MUTEX MUT0 0x00
-EXTERNAL REFERENCES
-UNKNOWNOBJ
-FULL RENAMED DEVICES
 

--IGPU Patch--

<key>PciRoot(0x0)/Pci(0x2,0x0)</key>
		<dict>
			<key>AAPL,GfxYTile</key>
			<data>
			AQAAAA==
			</data>
			<key>AAPL,ig-platform-id</key>
			<data>
			AAAWWQ==
			</data>
			<key>device-id</key>
			<data>
			FlkAAA==
			</data>
			<key>disable-external-gpu</key>
			<data>
			AQAAAA==
			</data>
			<key>enable-hdmi20</key>
			<data>
			AQAAAA==
			</data>
			<key>framebuffer-con1-alldata</key>
			<data>
			AQUJAAAIAACHAQAAAgQKAAAEAACHAQAA
			</data>
			<key>framebuffer-con1-enable</key>
			<data>
			AQAAAA==
			</data>
			<key>framebuffer-patch-enable</key>
			<data>
			AQAAAA==
			</data>
			<key>framebuffer-stolenmem</key>
			<data>
			AAAwAQ==
			</data>
		</dict>
 

-ScreenShotseUjrWOK.png

NCGrCkD.png

ABMGXob.png

mSnu0Gx.png

2PYxUBc.png

ZLw8B83.png

c9krby6.png

Xq6nDKt.png

uae3dOj.png

hdTBIyx.png

Ske6MQD.png

uUynuEY.png

0612dZM.png

ezP6wBG.png

iXBy9wJ.png

Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!

 

We're all here to have fun and learn from each other!

Share this post


Link to post
Share on other sites

Será que essa pasta funciona com o E480? Estou com um, mas não estou conseguindo configurar.

 

não, outro bios/uefi, etc


vc pode remover o dsdt e testar somente a efi

Share this post


Link to post
Share on other sites

não, outro bios/uefi, etc


vc pode remover o dsdt e testar somente a efi

 

Funcionou! Vídeo, está ok. Está sem dsdt, mas já postei o runme no post de patching!

Ficou com esses bugs - >

1. Bateria não aparece, nem %.

2. Touchpad não funciona, nem mesmo como mouse simples (trackpoint funciona, mas ô troçozin ruim de usar).

3. Keybind só funciona F2 e F3

4. Mesmo clicando em desligar ou desligando pelo terminal, ele apenas reinicia, por algum motivo. Até mesmo pelo clover, ele só está desligando de verdade forçadamente pelo botão.

E por algum estranho motivo, o PRTSCRN do teclado Lenovo para o trackpoint, possivelmente deve para o touchpad também, mas ele já não está funcionando, então né.

Me tira uma dúvida, a memória da Intel UHD 620 é 1536, 2048 ou 3072? Já vi o modelo desses 3, se não me engano meu 330s tinha 2048 com o Catalina.

o RUNME aqui também - > https://drive.google.com/file/d/1fwA9llkiB3kQA7r1R9n6DwGt2JAUdK9X/view?usp=sharing

Nway, obrigado!

Share this post


Link to post
Share on other sites
DSDT.aml.zip

Obrigado, Maldon! Já coloquei na pasta patched. Reiniciei, mas continua do mesmo jeito. Precisa compilar alguma coisa?

Share this post


Link to post
Share on other sites

Obrigado, Maldon! Já coloquei na pasta patched. Reiniciei, mas continua do mesmo jeito. Precisa compilar alguma coisa?

veja useful links na minha assinatura, muitos patches pro notebook é pessoal

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...