Jump to content
Sign in to follow this  
tete

Elitebook 840 G5

Recommended Posts

Hi there! I have an Elitebook 840 G5, i8350u, with touchscreen, IR cam, 16gb, 256gb SSD, smart card reader, touchpad..

I have made a successful installation of 15.1 Catalina BUT, I can't manage to work with the Smartcard reader built in (for ID cards etc) and the camera (photo Booth) but most importantly, I can't make touchpad work :(((


Any tips?

Share this post


Link to post
Share on other sites

[ref]tete[/ref], post full dump for start fine tune

--Run_Me

RunMe.app

 

Right away Sir,

If I manage to make this work thanks to you guys, I will donate for sure!. I didn't want to make you guys lose time with my problems, but I am literally 2 full days trying to make this work :(


I forgot to mention, I have wifi andbluetooth because I have bought Broadcom 94360CS2 (I think this is the right name).


I will edit my post with those files, to avoid double posting.


Thank you in advance admin!

Share this post


Link to post
Share on other sites

I managed to finish the dump! It was the name of the folder that was send?me instead of send_me!

https://ufile.io/he1rtsv2


It was too big to attach it!


Regards sir.


Ficarei muito agradecido se me conseguires resolver o problema! Usei por base o config do good old Rehab..


Cumprimentos

Share this post


Link to post
Share on other sites

[ref]tete[/ref], u use a full ssdt, renames, etc, is impossible a good fine tune with it : ;)

Share this post


Link to post
Share on other sites

[ref]tete[/ref], u use a full ssdt, renames, etc, is impossible a good fine tune with it : ;)

 

It was the only way I managed to make it work as is now (sound, brightness etc..). Any advice on how to fix this?


Obrigado!


Added in 2 minutes 15 seconds:

I tried to follow ur guide here, with the files provided here, but I didn't even work the sound, nor brightness... I had to go to rehabs topics to have this semi working build..


Added in 49 seconds:

I guess I will have to abort on this mission to have an Hackintosh, as I am losing my mind already :|

Share this post


Link to post
Share on other sites

[ref]tete[/ref], if u use Olarila folder, u need extract one full dump for dsdt patch

Share this post


Link to post
Share on other sites

https://ufile.io/gn9ulyeo


I have used the corresponding Olarila folder, just added some kexts.

As is now, I have bugs on the graphics (didn't have with the other EFI), no brightness control (I had on the other efi), and still, no smart card, webcam (it is recognized but its black), I also lost battery indicator (it was working on the other efi), touchpad is still not working...


Please see if you can fix it :(

Regards mate


Added in 29 seconds:

I had to use the Olarila SSDT

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...