Jump to content

Olarila HackBook Lenovo IdeaPad S145 7th and 8th Gen / Mojave / Catalina / Big Sur Full DSDT Patches / Clover and OpenCore


Recommended Posts

[ref]user748832[/ref], Can you do this test?


1. Find your GPI0 device and disable it by Return (Zero) statement

 

Scope (_SB.PCI0.GPI0)
     {
         Method (_STA, 0, NotSerialized)  // _STA: Status
         {
             Return (Zero)
         }
     }

 

Leave the _CRS and FMCN/SSCN method as is. That is, polling mode.


Reboot with officially released and voodooI2CELAN.


Upload new sendme files after reboot.

Link to post
Share on other sites
  • Replies 1.5k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Donation with Paypal https://tinyurl.com/r7fchn9 Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 Donation with ETH 0x255EdE75081D2731FcD6F7BE171dfC7f5ce9DF05 Donation with LTC MTmk

a verdade é uma. essas telas do s145 são ruins demais. estou com um da 10th Gen, é a mesma coisa. horrível.

-- Update - New folder for Big Sur Beta 5+ -- -Fix Trackpad "RiP" after wake -New minimal USB Injector -Last BIOS/UEFI version -New DSDT full patched from last BIOS/UEFI version

[ref]user748832[/ref], Can you do this test?


1. Find your GPI0 device and disable it by Return (Zero) statement

 

Scope (_SB.PCI0.GPI0)
     {
         Method (_STA, 0, NotSerialized)  // _STA: Status
         {
             Return (Zero)
         }
     }

 

Leave the _CRS and FMCN/SSCN method as is. That is, polling mode.


Reboot with officially released and voodooI2CELAN.


Upload new sendme files after reboot.

 


Done ( using the officially released kexts - may 2019 - taken from here: https://github.com/alexandred/VoodooI2C/releases )

Send me PersonakdiMarco.station.zip

Link to post
Share on other sites

Hello [ref]MaLd0n[/ref],

Sorry if I'm double posting this message, I just can´t see the original message after posting it.

So, I bought a 1TB external HD (usb3) and when I connect it the wifi stops working properly, it slows down and/or loses packages. The minute I disconnect it everything works fine again. I tried changing ports but still doesn't work.

I´ve got some usb flash drives and they don't interfere with the usb wifi , so I don't know if it happens only when I connect a usb 3 device. What should I do to go further and try to solve the problem, any clues?

This problem does not prevent me from working but I guess it happened/is happening to other people as well.


Thanks again for your support.


Regards.

Link to post
Share on other sites

Hi [ref]MaLd0n[/ref],

After updating VirtualSMC.kext (saw in Hackintool app that there was an updated versions of it) , the battery status disappeared and Hardware monitor shows only the internal disk temperatures, do I have to repatch after updating some kext?

Thanks


**** update II **


just found out that your version has a Plugin folder with all the satellites in it !!!


**********


*****update I***

installed VirtualSMC satellites and it worked.

├── drivers

│ └──{UEFI or BIOS}

│ └── VirtualSmc.efi

└── kexts

└── Other

├── SMCBatteryManager.kext

├── SMCLightSensor.kext

├── SMCProcessor.kext

└── SMCSuperIO.kext


I just wonder why with your original EFI I didn't need to install these satellites


*******

Link to post
Share on other sites

[ref]user748832[/ref], test if these set works (better) with the last working DSDT.

Archive.zip


A new send me is appreciated.


I also suggest you to investigate if there are bios updates available for your laptop. In my observation, bios updates improves trackpad experience for some users.

 

[ref]onemanosx[/ref], this version is working same as before.


1) I have to use "-v darkwake=0" so I can boot without a panic.


2) By removing "VoodooPS2Controller.kext" (which contains only VoodooPS2Keyboard.kext) I can boot without boot args


3) Apart of this, the touchpad is OK (smooth and multitouch)


4) In kernel log, I continue to see an enormous number of messages like this: (about 100 per second)

 

2019-11-01 17:59:51.777246+0100 0x29e2c    Default     0x0                  0      0    kernel: (kernel) VoodooI2CELANTouchpadDriver::ELAN0629 Invalid report (255)

 

( that's why I'd like to check the source code to remove above trace statement... )


Attaching a new send_me and plus panic log.


Thanks. :bye

 

panic(cpu 2 caller 0xffffff8010662e0a): Kernel trap at 0xffffff7f93939977, type 14=page fault, registers:
CR0: 0x000000008001003b, CR2: 0x0000000000000000, CR3: 0x000000002552c000, CR4: 0x00000000003626e0
RAX: 0xffffff80346927d8, RBX: 0xffffff80338d5090, RCX: 0xffffff8034692780, RDX: 0xffffff8034f32900
RSP: 0xffffff812c933e90, RBP: 0xffffff812c933e90, RSI: 0x0000000000000000, RDI: 0x0000000000000000
R8:  0xffffff8010ea4490, R9:  0x0000000000000001, R10: 0x00000000000000b4, R11: 0x0000000000000000
R12: 0xffffff80346927d0, R13: 0xffffff8034f32900, R14: 0xffffff8034f32900, R15: 0xffffff8034692780
RFL: 0x0000000000010246, RIP: 0xffffff7f93939977, CS:  0x0000000000000008, SS:  0x0000000000000000
Fault CR2: 0x0000000000000000, Error code: 0x0000000000000000, Fault CPU: 0x2, PL: 0, VF: 1

Backtrace (CPU 2), Frame : Return Address
0xffffff812c9338f0 : 0xffffff8010539a3b
0xffffff812c933940 : 0xffffff8010670fe5
0xffffff812c933980 : 0xffffff8010662a5e
0xffffff812c9339d0 : 0xffffff80104e0a40
0xffffff812c9339f0 : 0xffffff8010539127
0xffffff812c933af0 : 0xffffff801053950b
0xffffff812c933b40 : 0xffffff8010cd17f9
0xffffff812c933bb0 : 0xffffff8010662e0a
0xffffff812c933d30 : 0xffffff8010662b08 
0xffffff812c933d80 : 0xffffff80104e0a40
0xffffff812c933da0 : 0xffffff7f93939977
0xffffff812c933e90 : 0xffffff8010c16405
0xffffff812c933ef0 : 0xffffff8010c1916b
0xffffff812c933f50 : 0xffffff8010c1b9cd
0xffffff812c933fa0 : 0xffffff80104e013e
     Kernel Extensions in backtrace:
        as.acidanthera.voodoo.driver.PS2Controller(2.0.4)[E2927F57-AEFE-372E-ACAD-19C77D1D69E9]@0xffffff7f93937000->0xffffff7f93946fff
           dependency: com.apple.iokit.IOACPIFamily(1.4)[4A40B298-87E0-373E-84A9-9A2227924F8F]@0xffffff7f91290000

BSD process name corresponding to current thread: kernel_task

Mac OS version:
Not yet set

Kernel version:
Darwin Kernel Version 19.0.0: Thu Oct 17 16:17:15 PDT 2019; root:xnu-6153.41.3~29/RELEASE_X86_64
Kernel UUID: 7503CD47-851F-321E-8747-50DB4299165F
Kernel slide:     0x0000000010200000
Kernel text base: 0xffffff8010400000
__HIB  text base: 0xffffff8010300000
System model name: MacBookPro15,2 (Mac-827FB448E656EC26)
System shutdown begun: NO
Panic diags file unavailable, panic occurred prior to initialization

System uptime in nanoseconds: 1119201729
last loaded kext at 913624248: >!AFileSystemDriver	3.0.1 (addr 0xffffff7f90e95000, size 16384)
loaded kexts:
me.kishorprins.VoodooI2CELAN	1
org.hwsensors.driver.LPCSensors	1800
com.alexandred.VoodooI2C	2.2
org.coolstar.VoodooGPIO	1.1
org.hwsensors.driver.ACPISensors	1800
org.rehabman.driver.!ASmartBatteryManager	1.90.1
as.acidanthera.voodoo.driver.PS2!C	2.0.4
org.hwsensors.driver.SMMSensors	1800
org.hwsensors.driver.CPUSensors	1800
as.vit9696.!AALC	1.4.2
com.alexandred.VoodooI2CServices	1
as.vit9696.WhateverGreen	1.3.4
xyz.racermaster.NoTouchID	1.0.2
fish.goldfish64.SystemProfilerMemoryFixup	1.0.0
as.vit9696.Lilu	1.3.9
org.netkas.driver.FakeSMC	1800
>!AFileSystemDriver	3.0.1
>!AVirtIO	1.0
@filesystems.hfs.kext	522.0.9
@!AFSCompression.!AFSCompressionTypeDataless	1.0.0d1
@BootCache	40
@!AFSCompression.!AFSCompressionTypeZlib	1.0.0
@private.KextAudit	1.0
>!AAHCIPort	341.0.2
>!AHPET	1.8
>!AACPIButtons	6.1
>!AACPIEC	6.1
>!ARTC	2.0
>!ASMBIOS	2.1
>!AAPIC	1.7
$!AImage4	1
@nke.applicationfirewall	303
$TMSafetyNet	8
@!ASystemPolicy	2.0.0
|EndpointSecurity	1
|IOSerial!F	11
|IOSurface	269.6
@filesystems.hfs.encodings.kext	1
|IOAHCI!F	290.0.1
>usb.!UHostPacketFilter	1.0
|IOUSB!F	900.4.2
>!AEFINVRAM	2.1
>!ASMCRTC	1.0
>usb.!UXHCIPCI	1.2
>usb.!UXHCI	1.2
>!A!ILpssGspi	3.0.60
>!AEFIRuntime	2.1
|IOSMBus!F	1.1
|IOHID!F	2.0.0
$quarantine	4
$sandbox	300.0
@kext.!AMatch	1.0.0d1
>DiskImages	493.0.0
>!AFDEKeyStore	28.30
>!AEffaceable!S	1.0
>!AKeyStore	2
>!UTDM	489.41.1
|IOSCSIBlockCommandsDevice	422.0.2
>!ACredentialManager	1.0
>KernelRelayHost	1
>!ASEPManager	1.0.1
>IOSlaveProcessor	1
|IOUSBMass!SDriver	157.40.7
|IOSCSIArchitectureModel!F	422.0.2
|IO!S!F	2.1
|IOUSBHost!F	1.2
>!UHostMergeProperties	1.2
>usb.!UCommon	1.0
>!ABusPower!C	1.0
|CoreAnalytics!F	1
>!AMobileFileIntegrity	1.0.5
@kext.CoreTrust	1
|IOTimeSync!F	810.1
|IONetworking!F	3.4
|IOReport!F	47
>!AACPIPlatform	6.1
>!ASMC	3.1.9
>watchdog	1
|IOPCI!F	2.9
|IOACPI!F	1.4
@kec.pthread	1
@kec.corecrypto	1.0
@kec.Libm	1

Send me PersonakdiMarco.station.zip

Link to post
Share on other sites

Try using a different build/version

 


Yeahhh right I should have thought it before! :o

Version 1.8.34 ( VoodooPS2Controller_2018-0506.kext ) is working fine!!! :crazy:


While v2.0.4 (the latest) and v1.9.2 appear incompatible with your patched kext.


I think you can update the VoodooI2C repo with the information that ELAN0629 is supported by your patch, in polling mode.


Thank you onemanosx! :guitar

Link to post
Share on other sites

 

If your specific model of Ideapad S145 has really an Ethernet port, and you have the Kext loaded for that, I think it is not normal. In my case, my S145 model is without Ethernet so I have your same view.

 

 

And I'm using this one, working fine on Catalina by using the driver on github (WIFI-Dlink Catalina-Panel-V2) by chris1111


https://www.sitecom.com/it/wireless-network-usb-micro-adapter-n300-x3/wla-3000/p/297

Link to post
Share on other sites

Hi ,

I know this might be off topic, but has anyone applied the security update for Mojave on this specific machine ? is it safe to upgrade ?


Thanks and regards

 


Why not? I just upgraded from 10.15.0 to 10.15.1... no issues.


If you keep all your kexts in CLOVER/kexts/Other directory instead of /S/L/E/ you're safe. Just make sure to have a second way to boot from an external key, just in case...

Link to post
Share on other sites

[ref]MaLd0n[/ref],


for WIFI, I see that Dell DW1560 is really expensive (it is based on Broadcom BCM94352Z).


Is there some other compatible WIFI card which can fit with our M.2 NGFF connector?


I found this one, about 10EUR, but I'm not sure: "Etase DW1820A BCM94350ZAE 802.11Ac BT4.1 Adattatore WiFi 867 Mbps BCM94350 M.2 NGFF DW1820 Scheda WiFi Migliore di BCM94352Z"

Link to post
Share on other sites

Hello [ref]MaLd0n[/ref],

There is a new BIOS update for this machine , is it safe to update or will I need a new patch ?


Thanks

 

There are no fixes, but only a lot of patches for Security Vulnerabilities (CVE-...). I don't think it's very interesting for an hackintosher.. ;-)


-----------------------

SEnhancement to address CVE-2019-6171.

Enhancement to address CVE-2019-0123; Enhancement to address CVE-2019-0117; Enhancement to address CVE-2019-0185; Enhancement to address CVE-2019-11135; Enhancement to address CVE-2019-0154.

Enhancement to address CVE-2019-0131; Enhancement to address CVE-2019-0165; Enhancement to address CVE-2019-0166; Enhancement to address CVE-2019-0168; Enhancement to address CVE-2019-0169; Enhancement to address CVE-2019-11086; Enhancement to address CVE-2019-11087; Enhancement to address CVE-2019-11088; Enhancement to address CVE-2019-11090; Enhancement to address CVE-2019-11097; Enhancement to address CVE-2019-11100; Enhancement to address CVE-2019-11101; Enhancement to address CVE-2019-11102; Enhancement to address CVE-2019-11103; Enhancement to address CVE-2019-11104; Enhancement to address CVE-2019-11105; Enhancement to address CVE-2019-11106; Enhancement to address CVE-2019-11107; Enhancement to address CVE-2019-11108; Enhancement to address CVE-2019-11109; Enhancement to address CVE-2019-11110; Enhancement to address CVE-2019-11131; Enhancement to address CVE-2019-11132; Enhancement to address CVE-2019-11147.

-----------------------

Link to post
Share on other sites
  • MaLd0n changed the title to Olarila HackBook Lenovo IdeaPad S145 7th and 8th Gen / Mojave / Catalina / Big Sur Full DSDT Patches / Clover and OpenCore

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

:cap-Please Disable Your ADBlocker-:cap