Jump to content

Olarila HackBook Lenovo IdeaPad S145 7th and 8th Gen / Mojave / Catalina / Big Sur Full DSDT Patches / Clover and OpenCore


Recommended Posts

Estou pesquisando a coisa do bootcamp. Aqui, como relatado antes, ele da erro assim que eu tento seguir com o bootcamp assistant. Pelo que pesquisei, pode ser pelo fato de eu não ter espaço livre no HD principal. Pra criar uma partição bootcamp e, aparentemente, não é possível fazer isso em um segundo HD. @PANTERA NEBULOSA, vc tem alguma informação sobre isso? Qual foi seu processo. 
 

Sobre a lentid√£o do mouse e teclado durante o boot inicial. Eu notei isso no meu uso do Catalina, mas achei que tinha a ver com os programas que tenho iniciando junto com o sistema (s√£o v√°rios). Algum link pra eu aprender mais sobre essa troca de SMBIOS?

Valeu pessoal.

 

EDIT: Aparentemente é isso mesmo  o Bootcamp assistant não sabe lidar com dois discos e da erro logo de cara. Vou reinstalar o Windows aqui e tentar bootar via opencore sem os drivers da Lenovo instalado pra ver se funciona  vai que né!!! 
 

EDIT 2: Reinstalei o Windows  tentei o que disse que ia tentar e, como antes, não funcionou. A plaquinha de Wi-Fi nativa é identificado quando dói boot pelo EFI do Windows, mas não quando entro pelo OpenCore  o @MaLd0n já tinha me explicando que não funciona, mas valeu o teste. Enfim, sem bootcamp, por aqui, continuo trocando a ordem de boot via bios  

 

Edited by Thiago Henrique Santos
  • Like 1
Link to post
Share on other sites
  • Replies 1.5k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Donation with Paypal https://tinyurl.com/r7fchn9 Donation with Stripe https://tinyurl.com/2ssnydn6 Donation with BuyMeaCoffee https://tinyurl.com/bvsbpf6e Donation with BTC 33HeGCuCSh4t

a verdade é uma. essas telas do s145 são ruins demais. estou com um da 10th Gen, é a mesma coisa. horrível.

-- Update - New folder for Big Sur Beta 5+ -- -Fix Trackpad "RiP" after wake -New minimal USB Injector -Last BIOS/UEFI version -New DSDT full patched from last BIOS/UEFI version

10 hours ago, Thiago Henrique Santos said:

Estou pesquisando a coisa do bootcamp. Aqui, como relatado antes, ele da erro assim que eu tento seguir com o bootcamp assistant. Pelo que pesquisei, pode ser pelo fato de eu não ter espaço livre no HD principal. Pra criar uma partição bootcamp e, aparentemente, não é possível fazer isso em um segundo HD. @PANTERA NEBULOSA, vc tem alguma informação sobre isso? Qual foi seu processo. 
 

Sobre a lentid√£o do mouse e teclado durante o boot inicial. Eu notei isso no meu uso do Catalina, mas achei que tinha a ver com os programas que tenho iniciando junto com o sistema (s√£o v√°rios). Algum link pra eu aprender mais sobre essa troca de SMBIOS?

Valeu pessoal.

 

EDIT: Aparentemente é isso mesmo  o Bootcamp assistant não sabe lidar com dois discos e da erro logo de cara. Vou reinstalar o Windows aqui e tentar bootar via opencore sem os drivers da Lenovo instalado pra ver se funciona  vai que né!!! 
 

EDIT 2: Reinstalei o Windows  tentei o que disse que ia tentar e, como antes, não funcionou. A plaquinha de Wi-Fi nativa é identificado quando dói boot pelo EFI do Windows, mas não quando entro pelo OpenCore  o @MaLd0n já tinha me explicando que não funciona, mas valeu o teste. Enfim, sem bootcamp, por aqui, continuo trocando a ordem de boot via bios  

 

As altera√ß√Ķes que fiz no meu S145 foram: trocar o Intel Optane por um NVME 250 GB XPG Gammix S11 Pro, Adicionar 8 Gb de mem√≥ria, e trocar a placa wi-fi da intel por uma DW1820a. O HD s√≥ uso para arquivos brutos/backup.

Em relação ao boot camp não obtive erro, apenas abrir o assistente boot camp e o Mac criou a partição boot camp automaticamente no SSD NVME. Depois eu só dei boot num pend  drive com o instalador do windows e o instalei na partição boot camp que foi criado pelo macOS Big Sur public beta.

18 hours ago, PANTERA NEBULOSA said:

tinha testado outras SMBIOS, porém o problema de trackpad e teclado lentos na inicialização continuavam.

depois segui a sua recomendação macbookpro15,1 e o sistema carregou mais rádio e não tive problema de lentidão no trackpad e teclado.

estou agora tentando criar um patch pelo Hackintool para tentar corrigir o HDMI

@MaLd0n poderia me ajudar a criar esse patch para ativar o HDMI quando utilizado o SMBIOS macbookpro15,1?

j√° testei varias op√ß√Ķes no Hackintool, mas como n√£o sou t√£o expert no assunto n√£o obtive √™xito.

Obrigado :)

Link to post
Share on other sites
  • Administrators
On 8/15/2020 at 8:10 PM, PANTERA NEBULOSA said:

poderia me ajudar a criar esse patch para ativar o HDMI quando utilizado o SMBIOS macbookpro15,1?

tem de ver as "portas" que esse smbios oferece e alterar no patch

4 hours ago, Thiago Henrique Santos said:

Vou ter que formatar tudo aqui e estava considerando ir pro Public Beta do Big Sur. Alguma coisa que eu deveria considerar antes de seguir em frente?

aguardar o clover pro bigsur :cap

  • Like 1
  • Haha 1
Link to post
Share on other sites

Eu ainda não entendi o pq esse povo tem falado do Open Core... ficam falando que é mais rapido... eu testei aqui ele e sinceramente foi beeeeem mais lento... vendo videos a unica coisa e que parece q ele consegue bootar em fast mode... ou seja... ignorando o post da bios... mas po... ignora ai e no carregamento em si é mais lento hahahaha

Prefiro ainda o bom e velho Clover¬†ūüėć

 

Agora eu descobri uma coisa show vindo de um tutorial do Open Core... como criar o Data Provider do CPUFriend e configurar como ele vai ser em relação a ser mais agressivo nos clocks e como ele faz os ramps também pra puxar mais pra bateria ou performance... se alguem quiser dar uma olhada o link é esse: https://dortania.github.io/OpenCore-Post-Install/universal/pm.html#performance-bias

 

Eu aqui estou usando 0x80 para a primeira parte do gerenciamento, ou seja, um pouco mais agressivo que o MacBook Pro... e a segunda parte uso os ramps do Air pra deixar um pouco pra economia... o desempenho ficou muito bom, agora preciso testar a bateria. AH! E baixei o clock minimo também de 1.3ghz pra 1ghz

  • Like 1
Link to post
Share on other sites
1 hour ago, MaLd0n said:

tem de ver as "portas" que esse smbios oferece e alterar no patch

aguardar o clover pro bigsur :cap

 
 

Boa... Olha, na real baixei a imagem do Big Sur pelo Windows que instalei temporário aqui (estou trocando pra uma SSD mais rápida), mas depois de gravar ele no pendrive usando o Etcher ele não aparece como opção de boot. Tentei em outro pendrive e nada. Não sei se o problema é no meu Etcher ou no meu Windows... Achei estranho.

Fora que demora uma eternidade pra gravar a imagem no pendrive. Seja como for, se tudo mais der errado volto pro Catalina mesmo e aguardo. 

Edited by Thiago Henrique Santos
  • Like 1
Link to post
Share on other sites
1 hour ago, LeBaldi said:

Eu ainda não entendi o pq esse povo tem falado do Open Core... ficam falando que é mais rapido... eu testei aqui ele e sinceramente foi beeeeem mais lento... vendo videos a unica coisa e que parece q ele consegue bootar em fast mode... ou seja... ignorando o post da bios... mas po... ignora ai e no carregamento em si é mais lento hahahaha

Prefiro ainda o bom e velho Clover¬†ūüėć

 

Agora eu descobri uma coisa show vindo de um tutorial do Open Core... como criar o Data Provider do CPUFriend e configurar como ele vai ser em relação a ser mais agressivo nos clocks e como ele faz os ramps também pra puxar mais pra bateria ou performance... se alguem quiser dar uma olhada o link é esse: https://dortania.github.io/OpenCore-Post-Install/universal/pm.html#performance-bias

 

Eu aqui estou usando 0x80 para a primeira parte do gerenciamento, ou seja, um pouco mais agressivo que o MacBook Pro... e a segunda parte uso os ramps do Air pra deixar um pouco pra economia... o desempenho ficou muito bom, agora preciso testar a bateria. AH! E baixei o clock minimo também de 1.3ghz pra 1ghz

Fiquei interessado. Não sei nem por onde começar depois de ler a página que vc indicou. Ainda sou novo na cona de hackintosh e tentando aprender. Mais uma coisa pra ficar de olho. 

Link to post
Share on other sites
1 hour ago, Thiago Henrique Santos said:

Boa... Olha, na real baixei a imagem do Big Sur pelo Windows que instalei temporário aqui (estou trocando pra uma SSD mais rápida), mas depois de gravar ele no pendrive usando o Etcher ele não aparece como opção de boot. Tentei em outro pendrive e nada. Não sei se o problema é no meu Etcher ou no meu Windows... Achei estranho.

Fora que demora uma eternidade pra gravar a imagem no pendrive. Seja como for, se tudo mais der errado volto pro Catalina mesmo e aguardo. 

vc extraiu a imagem que vc baixou pelo windows?

tem que extrair!

Link to post
Share on other sites


 

2 hours ago, PANTERA NEBULOSA said:

kkkkkkkk

n√£o se preocupe, pois eu ja fiz o mesmo :)

Agora foi. Dei boot e estou fazendo o processo de instalação pela segunda vez. Da primeira, por alguma razão, a formatação do HD não apagou a partição UFI do Windows e quando o instalador reiniciou pela segunda vez entrou num loop louco que caía pra bios. 
 

Agora aparentemente não sobrou mais nada do Windows. Aguardando os eternos minutos que leva para terminar de instalar. 
 

Valeu @PANTERA NEBULOSA, tu salvou o dia hoje. 

EDIT: Na real n√£o foi. Ao final da instala√ß√£o do Big Sur ou a coisa toda entra em loop e fica voltando para a tela de boot do OpenCore, ou trava no meio de alguma coisa. Na real, a instala√ß√£o nem termina j√° que no menu do OpenCore s√≥ aparecem as op√ß√Ķes Install MacOs ou MacOs Installer. Estou baixando a imagem do Catalina de novo e retornando pra ele com o rabo entre as pernas hehe. Eu sei que voc√™s me ajudariam com isso, mas honestamente, j√° me convenci em esperar a vers√£o final kkkk.

Edited by Thiago Henrique Santos
Link to post
Share on other sites
2 hours ago, Thiago Henrique Santos said:

Fiquei interessado. Não sei nem por onde começar depois de ler a página que vc indicou. Ainda sou novo na cona de hackintosh e tentando aprender. Mais uma coisa pra ficar de olho. 

Literalmente só seguir a primeira parte da página pois a segunda já é pros processadores velhos hehehe... no geral vc personaliza como o processador vai reagir nos processos, se ele vai ser bem agressivo ao subir os clocks ou se ele fica um pouco mais de tempo em um clock antes de ir pro próximo... e tbm muda quando ele faz isso... tipo... a um grosso e errado modo... se ele espera dar 60% de uso da CPU pra ele subir o clock... ou se já sobe com 30%... por exemplo... algo bem irreal na realidade mas funciona mais ou menos assim hahahhaa

Dai vc seguindo ali, baixa o CPUFriend... roda o comando q vem no zip... e entra com os valores... ao final ele faz uma kext q é o Data Provider do CPUFriend... basta copiar essa kext junto do CPUFriend em si e colar lá na pastinha do Clover em Kext>other... e rebutar... quando iniciar ele já vai fazer a sobreposição dos valores padrão do sistema para o q vc configurou... é bem legal mas nem sempre o valor de melhor performance é o que traz melhor performance mesmo... pois infelizmente entra o thrtottle por temperatura... então vc tem q chegar ai numa config mediana onde vc consegue usar o máximo de clock... o mais rapido possivel... pelo maior tempo sem ter redução por temperatura :)

Eu aqui com ele junto do VoltageShift consegui uma ótima performance, cinebench mesmo eu passei a versão i7 hahahaha... 1560pts... e no uso mais de boa na internet e talz... tem dado por volta de 4~4h30min de uso de bateria... o q ta ok pelo q temos... antes sem nada não chegava nem em 3h hahahaha

  • Like 1
Link to post
Share on other sites
  • Administrators

-- Update - New folder for Big Sur Beta 5+ --

-Fix Trackpad "RiP" after wake

-New minimal USB Injector

-Last BIOS/UEFI version

-New DSDT full patched from last BIOS/UEFI version

-Fix HEVC

-Fix Lid sleep and sleep in menu(fail some times in previous file)

-Download-

EFI Lenovo S145 8th BigSur Beta 5+.zip

WYCvbE4.png

Is1RGcb.png

S71TxZo.png

 

  • Like 2
  • Thanks 1
Link to post
Share on other sites
On 8/19/2020 at 5:34 PM, LeBaldi said:

Literalmente só seguir a primeira parte da página pois a segunda já é pros processadores velhos hehehe... no geral vc personaliza como o processador vai reagir nos processos, se ele vai ser bem agressivo ao subir os clocks ou se ele fica um pouco mais de tempo em um clock antes de ir pro próximo... e tbm muda quando ele faz isso... tipo... a um grosso e errado modo... se ele espera dar 60% de uso da CPU pra ele subir o clock... ou se já sobe com 30%... por exemplo... algo bem irreal na realidade mas funciona mais ou menos assim hahahhaa

Dai vc seguindo ali, baixa o CPUFriend... roda o comando q vem no zip... e entra com os valores... ao final ele faz uma kext q é o Data Provider do CPUFriend... basta copiar essa kext junto do CPUFriend em si e colar lá na pastinha do Clover em Kext>other... e rebutar... quando iniciar ele já vai fazer a sobreposição dos valores padrão do sistema para o q vc configurou... é bem legal mas nem sempre o valor de melhor performance é o que traz melhor performance mesmo... pois infelizmente entra o thrtottle por temperatura... então vc tem q chegar ai numa config mediana onde vc consegue usar o máximo de clock... o mais rapido possivel... pelo maior tempo sem ter redução por temperatura :)

Eu aqui com ele junto do VoltageShift consegui uma ótima performance, cinebench mesmo eu passei a versão i7 hahahaha... 1560pts... e no uso mais de boa na internet e talz... tem dado por volta de 4~4h30min de uso de bateria... o q ta ok pelo q temos... antes sem nada não chegava nem em 3h hahahaha

 
 
 
 
 
 

Oi @LeBaldi, to seguindo o guia que vc indicou. To com uma d√ļvida. No ponto em que a gente tem que escolher os EPP range, ele pede isso em tr√™s etapas. Voc√™ consegue me dizer o que cada etapa significa ou eu devo s√≥ repetir o que quero em todas elas? O guia n√£o deixa isso muito claro.

 

Obrigado.

Link to post
Share on other sites
2 hours ago, Thiago Henrique Santos said:

Oi @LeBaldi, to seguindo o guia que vc indicou. To com uma d√ļvida. No ponto em que a gente tem que escolher os EPP range, ele pede isso em tr√™s etapas. Voc√™ consegue me dizer o que cada etapa significa ou eu devo s√≥ repetir o que quero em todas elas? O guia n√£o deixa isso muito claro.

 

Obrigado.

Então a primeira parte seria de fato o quão rapido ele sobe o clock para o uso do Turbo... ou seja... um valor mais para Power Saving que é o C0 ele vai tentar segurar o clock o mais baixo possivel, pra evitar o uso de muita voltagem e economizar energia, esse seria o extremo indicado pra quem usa o note estritamente fora da tomada e precisa de cada gotinha da bateria... e conforme vai subindo vc tem a parte mais agressiva de performance até com qualquer solicitação ele já tocar no máximo de clock possivel

√Č ai que entra o problema e tem que testar cada caso, pois teoricamente a melhor performance seria de fato o mais agressivo certo? S√≥ que como estamos com um note e o problema sempre √© a refrigera√ß√£o, fazendo isso vc esquenta d+ o processador e toda hora ele vai fazer throttling pra deixar dentro da temperatura aceit√°vel, ent√£o no final vc acaba tendo uma performance bem inferior pois na maior parte do tempo o clock fica muito mais baixo por conta da temperatura sacou? O ideal no finalvc chega nos valores de Balance performance e Balance power saving, pois nele vc segura o clock mais alto possivel sem ter problema com a temperatura... e dai √© teste mesmo ;)

Já a proxima parte seria no geral qual condição normalmente o notebook vai preferir ficar... é meio estranho falar isso mas é mais ou menos o que acontece, se ele tende a preferir ficar na bateria ou se tende a ter performance... nesse eu não testei muito mas quase sempre é melhor ficar no meio termo também, ou seja o que ele recomenda, 05 para um padrão macbook pro ou 07 pro Air. Eu atualmente to usando 05 mesmo... mas tbm usei 07 e não senti diferença, mas talvez um teste mais aprofundado valha a pena

Dai fez isso ele gera o kext pra vc por l√° no Clover com o kext do CPUFriend... coloca e reinicia e testa ;)

Lembrando q esses valores que vc coloca lá são em hexa (só o ultimo acho q não é)... então se precisar ter algo em numeros em si basta usar um conversor de hex para decimal pra vc saber se o valor ta mais ou menos no meio ou tendendo mais pra algum extremo: https://www.binaryhexconverter.com/hex-to-decimal-converter

Link to post
Share on other sites
1 minute ago, LeBaldi said:

Então a primeira parte seria de fato o quão rapido ele sobe o clock para o uso do Turbo... ou seja... um valor mais para Power Saving que é o C0 ele vai tentar segurar o clock o mais baixo possivel, pra evitar o uso de muita voltagem e economizar energia, esse seria o extremo indicado pra quem usa o note estritamente fora da tomada e precisa de cada gotinha da bateria... e conforme vai subindo vc tem a parte mais agressiva de performance até com qualquer solicitação ele já tocar no máximo de clock possivel

√Č ai que entra o problema e tem que testar cada caso, pois teoricamente a melhor performance seria de fato o mais agressivo certo? S√≥ que como estamos com um note e o problema sempre √© a refrigera√ß√£o, fazendo isso vc esquenta d+ o processador e toda hora ele vai fazer throttling pra deixar dentro da temperatura aceit√°vel, ent√£o no final vc acaba tendo uma performance bem inferior pois na maior parte do tempo o clock fica muito mais baixo por conta da temperatura sacou? O ideal no finalvc chega nos valores de Balance performance e Balance power saving, pois nele vc segura o clock mais alto possivel sem ter problema com a temperatura... e dai √© teste mesmo ;)

Já a proxima parte seria no geral qual condição normalmente o notebook vai preferir ficar... é meio estranho falar isso mas é mais ou menos o que acontece, se ele tende a preferir ficar na bateria ou se tende a ter performance... nesse eu não testei muito mas quase sempre é melhor ficar no meio termo também, ou seja o que ele recomenda, 05 para um padrão macbook pro ou 07 pro Air. Eu atualmente to usando 05 mesmo... mas tbm usei 07 e não senti diferença, mas talvez um teste mais aprofundado valha a pena

Dai fez isso ele gera o kext pra vc por l√° no Clover com o kext do CPUFriend... coloca e reinicia e testa ;)

Lembrando q esses valores que vc coloca lá são em hexa (só o ultimo acho q não é)... então se precisar ter algo em numeros em si basta usar um conversor de hex para decimal pra vc saber se o valor ta mais ou menos no meio ou tendendo mais pra algum extremo: https://www.binaryhexconverter.com/hex-to-decimal-converter

Legal. Obrigado. Vou fazer uns testes aqui e reporto nos próximos dias. 

  • Like 1
Link to post
Share on other sites
6 hours ago, Thiago Henrique Santos said:

Legal. Obrigado. Vou fazer uns testes aqui e reporto nos próximos dias. 

segui exatamente conforme o tutorial do link abaixo:

https://github.com/stevezhengshiqi/one-key-cpufriend

conforme instruido no tutorial, copiei e colei o comando abaixo e setei para a maxima performance. também coloquei a CPU na frequência maxima 3900 mhz.

as kexts ser√£o geradas na √°rea de trabalho, as quais devem ser inseridas na pasta OC/Kexts. Depois tem que incluir as configura√ß√Ķes abaixo na config.plist:

<dict>
    <key>BundlePath</key>
    <string>CPUFriend.kext</string>
    <key>Comment</key>
    <string>Power management data injector</string>
    <key>Enabled</key>
    <true/>
    <key>ExecutablePath</key>
    <string>Contents/MacOS/CPUFriend</string>
    <key>MaxKernel</key>
    <string></string>
    <key>MinKernel</key>
    <string></string>
    <key>PlistPath</key>
    <string>Contents/Info.plist</string>
</dict>
<dict>
    <key>BundlePath</key>
    <string>CPUFriendDataProvider.kext</string>
    <key>Comment</key>
    <string>Power management data</string>
    <key>Enabled</key>
    <true/>
    <key>ExecutablePath</key>
    <string></string>
    <key>MaxKernel</key>
    <string></string>
    <key>MinKernel</key>
    <string></string>
    <key>PlistPath</key>
    <string>Contents/Info.plist</string>
</dict>

Notei que a performance ficou melhor de que já era. 

frequência fixada em maxima 3,9 Ghz e mínima 3,5 Ghz

Intel Power Gadget.zip

 

 

Edited by PANTERA NEBULOSA
  • Like 1
Link to post
Share on other sites
20 hours ago, PANTERA NEBULOSA said:

segui exatamente conforme o tutorial do link abaixo:

https://github.com/stevezhengshiqi/one-key-cpufriend

conforme instruido no tutorial, copiei e colei o comando abaixo e setei para a maxima performance. também coloquei a CPU na frequência maxima 3900 mhz.

as kexts ser√£o geradas na √°rea de trabalho, as quais devem ser inseridas na pasta OC/Kexts. Depois tem que incluir as configura√ß√Ķes abaixo na config.plist:

<dict>
    <key>BundlePath</key>
    <string>CPUFriend.kext</string>
    <key>Comment</key>
    <string>Power management data injector</string>
    <key>Enabled</key>
    <true/>
    <key>ExecutablePath</key>
    <string>Contents/MacOS/CPUFriend</string>
    <key>MaxKernel</key>
    <string></string>
    <key>MinKernel</key>
    <string></string>
    <key>PlistPath</key>
    <string>Contents/Info.plist</string>
</dict>
<dict>
    <key>BundlePath</key>
    <string>CPUFriendDataProvider.kext</string>
    <key>Comment</key>
    <string>Power management data</string>
    <key>Enabled</key>
    <true/>
    <key>ExecutablePath</key>
    <string></string>
    <key>MaxKernel</key>
    <string></string>
    <key>MinKernel</key>
    <string></string>
    <key>PlistPath</key>
    <string>Contents/Info.plist</string>
</dict>

Notei que a performance ficou melhor de que já era. 

frequência fixada em maxima 3,9 Ghz e mínima 3,5 Ghz

Intel Power Gadget.zip 59.32 kB · 0 downloads

 

 

 
 
 
 
 

Ainda n√£o tive tempo de ler o link ou fazer o procedimento, mas irei na pr√≥xima semana. Seu processador √© qual? N√£o tenho reclama√ß√Ķes com rela√ß√£o ao desempenho¬†na verdade, mas √© sempre interessante extrair o m√°ximo que d√° do computador. Eu uso ele basicamente exclusivamente na tomada, ent√£o autonomia de bateria n√£o √© algo que me preocupa.

 

Valeu @PANTERA NEBULOSA

Edited by Thiago Henrique Santos
Link to post
Share on other sites
6 hours ago, Thiago Henrique Santos said:

Ainda n√£o tive tempo de ler o link ou fazer o procedimento, mas irei na pr√≥xima semana. Seu processador √© qual? N√£o tenho reclama√ß√Ķes com rela√ß√£o ao desempenho¬†na verdade, mas √© sempre interessante extrair o m√°ximo que d√° do computador. Eu uso ele basicamente exclusivamente na tomada, ent√£o autonomia de bateria n√£o √© algo que me preocupa.

 

Valeu @PANTERA NEBULOSA

O meu processador é o i5-8265u.

a temperatura do meu processador  chegava a bater 65 graus em uso pesado, mesmo sem usar este esquema de travar a CPU no clock máximo. 

Então resolvi resolvi trocar a pasta térmica por uma da PCyes (OCX), foi então que descobri que a pasta térmica que a Lenovo coloca é péssima e só cobria a parte da CPU. na parte da GPU integrada nem pasta térmica tinha. Acabou o problema com temperatura, mesmo com a frequência travada no máximo (45graus)

Link to post
Share on other sites
37 minutes ago, PANTERA NEBULOSA said:

O meu processador é o i5-8265u.

a temperatura do meu processador  chegava a bater 65 graus em uso pesado, mesmo sem usar este esquema de travar a CPU no clock máximo. 

Então resolvi resolvi trocar a pasta térmica por uma da PCyes (OCX), foi então que descobri que a pasta térmica que a Lenovo coloca é péssima e só cobria a parte da CPU. na parte da GPU integrada nem pasta térmica tinha. Acabou o problema com temperatura, mesmo com a frequência travada no máximo (45graus)

Então, acabei arrumando tempo pra fazer o processo hoje. Deu certo. Fiz alguns testes com valores diferentes. Não acompanhei a temperatura em nenhum, mas não ouvi a ventoinha em velocidade máxima nenhuma vez (farei novos testes sobre isso na sequência). Consegui um máximo de 1110 no teste Cinebench. Longe dos 1560 que o @LeBaldi conseguiu no i5 dele. Talvez ele pudesse falar mais sobre a coisa de regular a voltagem do processador. 
 

Essa dica da pasta térmica é interessante. Eu tenho uma Artic MX-4 que comprei alguns anos atrás pra fazer repaste do meu antigo Dell (e que tb serviu pra fazer repaste no PS4). Não sei como ela se compara com a que vc usou, mas já faz um tempo que quero pesquisar pastas térmicas. Talvez seja esse o momento. 
 

Valeu como sempre @PANTERA NEBULOSA e pessoal em geral aqui do fórum. Vcs são demais. 

  • Thanks 1
Link to post
Share on other sites
14 hours ago, Thiago Henrique Santos said:

Então, acabei arrumando tempo pra fazer o processo hoje. Deu certo. Fiz alguns testes com valores diferentes. Não acompanhei a temperatura em nenhum, mas não ouvi a ventoinha em velocidade máxima nenhuma vez (farei novos testes sobre isso na sequência). Consegui um máximo de 1110 no teste Cinebench. Longe dos 1560 que o @LeBaldi conseguiu no i5 dele. Talvez ele pudesse falar mais sobre a coisa de regular a voltagem do processador. 
 

Essa dica da pasta térmica é interessante. Eu tenho uma Artic MX-4 que comprei alguns anos atrás pra fazer repaste do meu antigo Dell (e que tb serviu pra fazer repaste no PS4). Não sei como ela se compara com a que vc usou, mas já faz um tempo que quero pesquisar pastas térmicas. Talvez seja esse o momento. 
 

Valeu como sempre @PANTERA NEBULOSA e pessoal em geral aqui do fórum. Vcs são demais. 

testei no Cinebench aqui. deixei o intel power gadget ligado para monitorar a frequência. Antes de realizar o benchmark a temperatura da CPU estava a 45 graus. no momento que dei o start n Cinebench a frequência da CPU imediatamente ficou fixa em 2.0 Ghz. Deve ser por isso que a tua e a minha pontuação ficaram baixo ( o meu ficou em 1112). Depois baixei o geekbenck e fiz um teste. A frequência não baixou 3 a temperatura bateu os 60 graus., mas perto do final do teste o clock caiu para 2,0 Ghz fazendo com que a pontuação caísse ( aqui no nordeste tá muito calor rssss). Mas de qualquer forma no dia a dia, mesmo que em games a gente não estressa o processador como no benchmark, não havendo necessidade de fazer undervolt.

  • Like 1
Link to post
Share on other sites
21 minutes ago, PANTERA NEBULOSA said:

testei no Cinebench aqui. deixei o intel power gadget ligado para monitorar a frequência. Antes de realizar o benchmark a temperatura da CPU estava a 45 graus. no momento que dei o start n Cinebench a frequência da CPU imediatamente ficou fixa em 2.0 Ghz. Deve ser por isso que a tua e a minha pontuação ficaram baixo ( o meu ficou em 1112). Depois baixei o geekbenck e fiz um teste. A frequência não baixou 3 a temperatura bateu os 60 graus., mas perto do final do teste o clock caiu para 2,0 Ghz fazendo com que a pontuação caísse ( aqui no nordeste tá muito calor rssss). Mas de qualquer forma no dia a dia, mesmo que em games a gente não estressa o processador como no benchmark, não havendo necessidade de fazer undervolt.

Pois é. Acabei de fazer o teste do Cinebench com o Power Gadget aberto e acontece exatamente o que vc falou. A temperatura salta e a frequência vai pra 2ghz. Por isso a ventoinha não dispara, ele entra em throttling. 
E apesar dos 9 graus C aqui em São Paulo, acho que vc tem razão. Numa situação normal de uso ele não deve repetir esse comportamento. 

  • Like 1
Link to post
Share on other sites

Ok. Fiz alguns testes hoje o dia todo e descobri algumas coisas. 
 

O procedimento indicado pelo @PANTERA NEBULOSA na verdade naoebstava funcionando com o OpenCore. Notei depois de algum tempo de boot que o processador baixava a frequência para 1300 ao invés de manter nos 3500 que pedi. Também notei depois de alguns reinicios que antes da tela de seleção de boot do OpenCore aparece uma msg muito rápido. Não consigo ler. Provavelmente editei a config.plist erroneamente, mas não sei encontrar meu erro. 
 

Dai tentei com o Clover e o processo funcionou. Eu poderia ficar no Clover sem problemas tb, mas encontrei um outro problema. Não há Cristo que faça o Clover atualizar no meu sistema. O instalador da erro no final.  Não sei se é culpa do fato de eu ter dois discos. Lembrando que removi completamente a instalação do Windows do meu computador e só estou com o MacOS. 
 

Alguma dica com relação a edição da config.plist no OpenCore? Em que lugar específico eu deveria adicionar aquelas linhas? Alguma noção de pq o Clover não atualiza não meu sistema? 

 

EDIT: Consegui atualizar o Clover baixando no Github o CLOVERX64.EFI, colocando ele dentro da pasta EFI/CLOVER e tb renomenado e substituindo o /BOOT/BOOTX64.efi. N√£o sei se √© a forma certa. Encontrei esse m√©todo pelos Google da vida e foi o √ļnico que funcionou. O Clover Installer n√£o vai de jeito nenhum. De qualquer aguardando o @PANTERA NEBULOSA¬†reportas de que maneira ele editou o config.plist do OpenCore.

Vou dizer que ainda acho o boot do Clover mais lento, e mais "sujo" visualmente, que do OpenCore. Mas a verdade é que eu raramente reinício o notebook e, para um noob nesses assuntos como eu, não me parece fazer tanta diferença assim.

Edited by Thiago Henrique Santos
Link to post
Share on other sites
  • MaLd0n changed the title to Olarila HackBook Lenovo IdeaPad S145 7th and 8th Gen / Mojave / Catalina / Big Sur Full DSDT Patches / Clover and OpenCore

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

:cap-Please Disable Your ADBlocker-:cap