Jump to content
Morgado

Como Habilitar Intel HD UHD 630

Recommended Posts

Boa Tarde,

Estou tentando habilitar a parte gráfica, mas está difícil de conseguir.

Já segu vários tutoriais e nenhum deu certo.

Gostaria de um ajuda.

Obrigado


Placa mãe Asus Prime H370 A

Processador Intel i3 8100

Placa de vídeo Nvidia Geforce GT 1030

Link to comment
Share on other sites

Eu tive muita dificuldade em habilitar a UHD630 até descobrir que o problema estava nos conectores de video.


Primeiro descobri que a única conexão que funcionava nativamente era a VGA -- sim, funciona como DiplayPort. A partir daí fiz como o @MaLd0n falou: usar o patch do Hackintool para 'corrigir' as outras portas de video, HDMI e DVI-d.


Então acho que você deve fazer o mesmo. Tem dois patches da ASUS 370 que, mesmo que não sejam iguais a tua placa, você poderia testar.


Claro que a BIOS tb interfere no gráfico interno, então verifique se está tudo certo lá.

iMac 19,2 (10.15.4) + Win 10 @ OpenCore UEFI Dual Boot

H310M-S2P | i3 8100 | 16GB DDR4 | UHD 630 + RX 580 (PowerColor) | ALC887 | Realtek RTL8118 | TP-Link WN781ND

Link to comment
Share on other sites

Olá

Aqui a única porta que está funcionando é a HDMI da placa de vídeo.

Já tentei usar as duas opções do Hackintool, não funcionaram, mas acho que tem alguma coisa errada, já que tem só umas 5 linhas, muito pouco para o tanto de informação que tem no aplicativo.

Tem alguns detalhes que acho relevante passar, a distorção na imagem acontece de eu abrir mais de uma aba, seja no Finder ou no safari.

Quando coloco em tela cheia não faz a distorção, também faz a distorção quando mexo a janela de um lado para o outro.

Link to comment
Share on other sites

a distorção na imagem acontece de eu abrir mais de uma aba, seja no Finder ou no safari.

Quando coloco em tela cheia não faz a distorção, também faz a distorção quando mexo a janela de um lado para o outro.

 

Não entendi muito bem, mas parece que o video já está habilitado, não?


A UHD é reconhecida em "Informações do Sistema"?


O problema é a distorção da imagem?


Ficou meio confuso, mas enfim…


Segue um dos patches do hackintool para comparação:

		<key>Properties</key>
	<dict>
		<key>PciRoot(0x0)/Pci(0x2,0x0)</key>
		<dict>
			<key>AAPL,ig-platform-id</key>
			<data>
			BwCbPg==
			</data>
			<key>AAPL,slot-name</key>
			<string>Internal@0,2,0</string>
			<key>device-id</key>
			<data>
			mz4AAA==
			</data>
			<key>device_type</key>
			<string>Display controller</string>
			<key>framebuffer-con0-busid</key>
			<data>
			AgAAAA==
			</data>
			<key>framebuffer-con0-enable</key>
			<data>
			AQAAAA==
			</data>
			<key>framebuffer-con0-index</key>
			<data>
			AgAAAA==
			</data>
			<key>framebuffer-con0-pipe</key>
			<data>
			CgAAAA==
			</data>
			<key>framebuffer-con0-type</key>
			<data>
			AAgAAA==
			</data>
			<key>framebuffer-con1-enable</key>
			<data>
			AQAAAA==
			</data>
			<key>framebuffer-con1-index</key>
			<data>
			AwAAAA==
			</data>
			<key>framebuffer-con1-pipe</key>
			<data>
			CAAAAA==
			</data>
			<key>framebuffer-con1-type</key>
			<data>
			AAgAAA==
			</data>
			<key>framebuffer-con2-busid</key>
			<data>
			AQAAAA==
			</data>
			<key>framebuffer-con2-enable</key>
			<data>
			AQAAAA==
			</data>
			<key>framebuffer-con2-index</key>
			<data>
			AQAAAA==
			</data>
			<key>framebuffer-con2-pipe</key>
			<data>
			CQAAAA==
			</data>
			<key>framebuffer-patch-enable</key>
			<data>
			AQAAAA==
			</data>
			<key>hda-gfx</key>
			<string>onboard-1</string>
			<key>model</key>
			<string>Intel UHD Graphics 630</string>
		</dict>
	</dict>

iMac 19,2 (10.15.4) + Win 10 @ OpenCore UEFI Dual Boot

H310M-S2P | i3 8100 | 16GB DDR4 | UHD 630 + RX 580 (PowerColor) | ALC887 | Realtek RTL8118 | TP-Link WN781ND

Link to comment
Share on other sites

Tenho que fazer pelo clover configurator?

 

O Maldon sugeriu um app, mas também dá pra fazer pelo Clover Configurator, basta clicar em Text Mode nas opções da barra lateral.


Daí, no texto, procure por Devices e faças as modificações necessárias.


A estrutura deve ser mais ou menos assim:

	<key>Devices</key>
<dict>
	. . .
	<key>Properties</key>
	<dict>
		<key>PciRoot(0x0)/Pci(0x2,0x0)</key>
		. . .
	</dict>
	. . .
</dict>

 

Depois que editar, clique em Synchronized para aplicar as modificações.


Só lembrando que o patch não é específico para sua placa, é apenas um teste. Aqui, eu consegui usar um patch de outra placa e depois que subi com a UHD funcionando foi que criei um patch para minha mobo.


Tente fazer o mesmo.

iMac 19,2 (10.15.4) + Win 10 @ OpenCore UEFI Dual Boot

H310M-S2P | i3 8100 | 16GB DDR4 | UHD 630 + RX 580 (PowerColor) | ALC887 | Realtek RTL8118 | TP-Link WN781ND

Link to comment
Share on other sites

  • Administrators

só tome cuidado com esse clover configurator, esse app não respeita muitas propriedades como number, data, string entre outros problemas graves.


por isso que muitos não usam esse app, mas a maioria nem sabe ou nem percebe a cagada que esse app faz

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Problems with Paypal HERE

Link to comment
Share on other sites

por isso que muitos não usam esse app, mas a maioria nem sabe ou nem percebe a cagada que esse app faz

 

pois é, vi falar que ele também corrompe os arquivos de configuração do OpenCore, talvez seja por conta das propriedades citadas (number, data, string)


eu sempre usei o PlistEdit Pro, mas não sei se é seguro ou não

iMac 19,2 (10.15.4) + Win 10 @ OpenCore UEFI Dual Boot

H310M-S2P | i3 8100 | 16GB DDR4 | UHD 630 + RX 580 (PowerColor) | ALC887 | Realtek RTL8118 | TP-Link WN781ND

Link to comment
Share on other sites

Teria algum tutorial para eu seguir?

 

Não é bem um tutorial, mas veja se te ajuda:


Abra o Hackintool…


nos menus siga por Patch » System Configs » Asus e escolha o modelo que desejar (note você não vai ver nenhum sinal de que o patch foi aplicado, mas foi)…


Depois, clique agora na aba Patch e assegure de ver Coffee Lake (Intel Generation) e 0x3E9B0007 (Platform ID).


Clique no último botão Patch, lá em baixo… Nas opções de General, deixe marcado apenas Deviceproperties, Conectors, Graphic Device e Auto Detect Changes. Nas opções de Advanced deixe marcado apenas Use Intel HDMI e Spoof Video Device ID: 0x3E9B Intel UHD Graphics 630. Finalmente Clique em Generate Patch.


De novo nos menus, siga por File » Export » Bootloader config.plist e aponte para o seu arquivo em EFI/Clover.


Salve e depois é só testar. :work:


Todos os valores (principalmente Bus ID e Type, em Connectors) poderão depois ser editados e testados, até você encontrar o ideal. No começo, parece complexo e com o tempo parece que tá no começo…mas depois que se acostuma com o Hackintool ele se torna mais amigável.

iMac 19,2 (10.15.4) + Win 10 @ OpenCore UEFI Dual Boot

H310M-S2P | i3 8100 | 16GB DDR4 | UHD 630 + RX 580 (PowerColor) | ALC887 | Realtek RTL8118 | TP-Link WN781ND

Link to comment
Share on other sites

O arquivo que gerou é bem menor e bem diferente em comparação ao que você postou:


<?xml version="1.0" encoding="UTF-8"?>




Devices


Properties


PciRoot(0x0)/Pci(0x1f,0x3)


AAPL,slot-name

Internal@0,31,3

device_type

Audio device

hda-gfx

onboard-2

layout-id


AAAAAA==


model

Cannon Lake PCH cAVS







Added in 3 minutes 9 seconds:

O arquivo que gerou e bem menor e bem diferente do que você postou.


<?xml version="1.0" encoding="UTF-8"?>




Devices


Properties


PciRoot(0x0)/Pci(0x1f,0x3)


AAPL,slot-name

Internal@0,31,3

device_type

Audio device

hda-gfx

onboard-2

layout-id


AAAAAA==


model

Cannon Lake PCH cAVS





Link to comment
Share on other sites

  • Administrators

[ref]Morgado[/ref], tem de selecionar as opções na aba "general" e na "advanced" pra gerar um full


Added in 1 minute 28 seconds:

veja aqui, vc pode trocar somente dev id e platform id, pode remover o disable external

https://Olarila.com/forum/viewtopic.php?f=28&t=10814

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Problems with Paypal HERE

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...