Jump to content
lsgcbr

DW1820A causando lentidão extrema no sistema

Recommended Posts

Olá, pessoal!


Meu hack está quase 100% funcional, se não fosse pela placa Wi-Fi. É uma Dell Wireless DW1820A (BCM94350ZAE), 2.4GHz+5GHz, reconhecida nativamente pelo macOS.


O problema é que, apesar dela ativar corretamente e funcionar por alguns minutos, ela eventualmente acaba com a conexão e causa lentidão extrema no sistema. Fica impossível de realizar qualquer tipo de tarefa.


O que já tentei:

> Adicionar a flag de compatibilidade via config no Clover (inicialmente funcionou, mas quebrou a compatibilidade com Bluetooth) - testada tanto sozinha, como com a flag -brcmfxoff, que desativa o driver e dava alguns minutos adicionais de estabilidade;

> Adicionar as boot flags brcmfx-driver=0, brcmfx-driver=2 e brcmfx-country=US, o primeiro para tentar usar o driver do NIC MFG, o segundo para usar o driver do NIC convencional e o terceiro para setar a região nos Estados Unidos para fins de compatibilidade;

> Instalar as kexts AirportBrcmFixup e Lilu em /Library/Extensions, mesmo problema;

> Executar sem a kext AirportBrcmFixup;

> Fazer modificações em IO80211Family a fim de trazer a compatibilidade para o arquivo 4360, sem sucesso.


Alguém possui alguma solução para essa placa?


Obrigado desde já!

Link to comment
Share on other sites

injeção de propriedades em Clover:

  1. compatible = pci14e4,4353
  2. pci-aspm-default = 0

https://osxlatitude.com/forums/topic/11322-broadcom-bcm4350-cards-under-high-sierramojavecatalina/

 

Edited by RV_ABZ

Latitude E6220, BIOS A13, Core i5-2520M 2.5GHz, 8Go DDR3-1333, HD3000@1366x768, HS 10.13.6 / Latitude E6230, BIOS A20, Core i7-3540M 3.0GHz, 8Go DDR3L-1600, HD4000@1366x768, Moj 10.14.6/Cat 10.15.3 | Latitude 7490, BIOS 1.13.1, Core i7-8650U 1.9GHz, 16Go DDR4-2400, UHD620@1920x1080, Cat 10.15.3 | Vostro200 ST, BIOS 1.0.16, C2D E8600 3.33GHz, 6Go DDR2-800, GT730/GT1030@1680x1050, HS 10.13.6/Cat 10.15.3

Link to comment
Share on other sites

insuficiente, precisa do ASPM desativado

Latitude E6220, BIOS A13, Core i5-2520M 2.5GHz, 8Go DDR3-1333, HD3000@1366x768, HS 10.13.6 / Latitude E6230, BIOS A20, Core i7-3540M 3.0GHz, 8Go DDR3L-1600, HD4000@1366x768, Moj 10.14.6/Cat 10.15.3 | Latitude 7490, BIOS 1.13.1, Core i7-8650U 1.9GHz, 16Go DDR4-2400, UHD620@1920x1080, Cat 10.15.3 | Vostro200 ST, BIOS 1.0.16, C2D E8600 3.33GHz, 6Go DDR2-800, GT730/GT1030@1680x1050, HS 10.13.6/Cat 10.15.3

Link to comment
Share on other sites

  • Administrators
20 minutes ago, RV_ABZ said:

insuficiente, precisa do ASPM desativado

essa kext já tem todos esses patches, alguns a gente só precisa ativar via bootarg, veja no readme do projeto 

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Problems with Paypal HERE

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...