Jump to content
m45k

[Request] DSDT for Dell Latitude E6520

Recommended Posts

Hello,


i am searching a DSDT for my Dell Latitude E6520 with this specs:


Intel Core i5 2520M

QM67 Express

NVIDIA NVS 4200M

Dell Wireless 375 Bluetooth


I installed Mac OS X Lion already and Touchpad, Keyboard, Ethernet is working. I tried different DSDTs already but nothing worked yet.

I was searching for a guide to create my own DSDT, but without results.

i already checked most stuff available on the internet but found nothing for that notebook =(


It would be nice to have sleep mode and a full working CPU / graphiccard


hope for your help.

Link to comment
Share on other sites

Ok, now i have a dsdt file. most stuff is working, exempt mutlitouch trackpad (ALPS), sleep mode and card reader (O2 Micro)


my trackpad is recognized as a mouse, not as a trackpad. i tried a lot of different kext files but nothing worked.

i thought maybe in the dsdt file is an error.

here is the part of PS2M which is for the mouse/trackpad i think

 

    Scope (_SB.PCI0.LPCB)
   {
       Device (PS2M)
       {
           Name (_HID, EisaId ("DLL0493"))
           Name (_CID, EisaId ("PNP0F13"))
           Name (_CRS, ResourceTemplate ()
           {
               IRQ (Edge, ActiveHigh, Exclusive, )
                   {12}
           })
           Name (_PRS, ResourceTemplate ()
           {
               StartDependentFn (0x00, 0x00)
               {
                   IRQNoFlags ()
                       {12}
               }
               EndDependentFn ()
           })
       }
   }

 

maybe someone could check this, it would be very nice.


i will attach my dsdt file, maybe someone can say my how to get sleep and the card reader working.


my hardware is:

Dell Latitude E6520

Intel Core i5 2520M

Nvidia NVS 4200M 512 MB (working with the DSDT and graphicenabler=no)

Dell Bluetooth 375 (working OOB)

DSDT E6520.zip

Link to comment
Share on other sites

Yes tried it. The alpsmultitouch is recognizing the touchpad, but is Crazy moving and clicking around when touching it. The voodoops2 and appleps2 is not recognizing it.


When trying to put the notebook to sleep mode, Display is turning of, power button LED is turned on and thats it. It is not possible to come back to normal mode.

Link to comment
Share on other sites

I also have the Dell e6520 and have had no luck getting past the initial install of Lion. All the POST inastal stuff get s me nowhere past many different Kernal Panics. Which sucks because I'm lookin at the desktop of LION right now on my e6520 but in -x -v safe mode. If you have any help you can offer I would very much appreciate it. Write me a PM if you can. I will subscribe so I get an immediate response. I have tried many instal methods. My latest was using myhack 3.1....also tried Iatkos

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...