Jump to content
shadow_keeper

Install GUI will not launch on Mojave - Panic Reboot

Recommended Posts

Hi everyone,


I can't seem to launch the install GUI for Mojave on bootup (using laptop config2.plist) as it panics every time in the same place. I do not have this problem with your High Sierra 10.13.6 image that I downloaded last week, the GUI launches fine using the config2.plist file that is embedded with it. I even tried copying the config2 file from HS image onto the Mojave 10.14.6 image as config3.plist with no luck and the same panic error - then the machine automatically reboots.


Any clues? Thanks in advance.....

Edited by Guest
Link to comment
Share on other sites

Okay, did some more trial and error today and got the install GUI to come up so I could install the base OS. I restored the original Olarilla EFI folder with my config3.plist file and added '-cdfon' to the boot line and also changed the ig-platform to 0x12345678. That does the trick, I still see the IOConsoleUsers message for a few seconds, but the GUI came up anyway.


Regardless, this basic config doesn't have video acceleration, so that takes video watching and most of my Adobe graphics out of the equation which is no good. I tried a HD530 config list from Rehabman's GitHub site, but all that does is cause my system to panic and reboot constantly. What is the easiest fix to get the HD530 to accelerate properly? The 'About this Mac' says 31MB lol. Or is it easier to get my NVidia GTX980M working since that is the item listed in the System Report and not the Intel HD530? Hmmm....


Thanks,

Larry

Link to comment
Share on other sites

10 hours invested today, and 12 hours invested in this same fiasco yesterday....way too much time to have gotten no where. I've had it.....most likely will swap hard drives and go back to El Capitan which works on this machine.


All possible config.plist scenarios were visited, adjusting this one thing, then next reboot adjusting another (platform IDs, device IDs), and all resulted in the same thing - black screen with the infamous IOConsoleUsers: ......


This machine will not give you a 'visible' desktop unless the worthless 0x12345678 platform-ID is used at boot-up, and we all know you will never get video acceleration out of that configuration. The desktop is running at the black screen hold up though, because at least I figured out the sequence 'TAB-TAB-SpaceBar' and that will reboot the machine without you having to hit the power button and shutting down the file systems harshly when you are at the IOConsoleUsers black screen ;-)


If anyone out there in the world has a 'working' Alienware 17R3 (UHD / 4K) laptop configuration, I would appreciate it they could send their Clover folder. *The clover folder on the website 'JesusRocks' does NOT work....that person hosts a site that has a bunch of different Alienware laptops, but his 17R3 config does nothing but Panics and restarts on my machine unfortunately, and was really built for 10.12.x


Thanks,

Larry

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...