Jump to content

checking on ASUS GL-502VS laptop with latest High Sierra image

Recommended Posts

hi there! i love your installers - they worked perfectly on my Gigabyte mobo (in my sig) when i had to hackintosh it!

now i'm working on my older laptop, an ASUS ROG-GL502VS. i know about the guide for it on tmacx86, but instead of using Sierra, i tried to use the High Sierra installer Olarilla image on a USB key from Jan 2019, but it failed to load the system at the last minute. i did try updating Clover myself on the EFI partition of the USB installer, and following a number of directions on this older guide including replacing config.plist. but it seems that this just messed things up with the installer and it no longer recognizes the Installer's macOS volume anymore.

so what i would like to know is if your latest installer burned to a USB key will likely work with the Asus GL502VS or is my hardware perhaps too specialized to work with your generic installer? i'm just thinking of the basic system, not the trackpad driver or backlight keyboard. just being able to install macOS. anyway, i'm downloading it now so i guess we'll see but your input would be appreciated, in case there's a simple fix. thanks!

Link to comment
Share on other sites

[ref]metaphysician[/ref], what processor ur notebook have?


it's an i7 6700HQ

oh BTW - i'm trying to image the USB using dd but i'm getting an error:

i unmounted the USB volume:

scottlooneys-iMac:~ scottlooney$ diskutil unmountDisk /dev/disk8
Unmount of all volumes on disk8 was successful


then i used 'dd' but it seems to not find the file. the example said 'rdisk2' but it couldn't find it. i wonder if it's because i unmounted the USB?


scottlooneys-iMac:~ scottlooney$ sudo dd if=/Users/scottlooney/Downloads/Olarila\ High\ Sierra\ 10.13.6.raw of=dev/rdisk8 bs=1m
dd: dev/rdisk8: No such file or directory
scottlooneys-iMac:~ scottlooney$ sudo dd if=/Users/scottlooney/Downloads/Olarila\ High\ Sierra\ 10.13.6.raw of=dev/rdisk2 bs=1m
dd: dev/rdisk2: No such file or directory


appreciate any help!

update - aha! forgot the slash - of=/dev/disk8. i think it's going now.

Link to comment
Share on other sites

[ref]metaphysician[/ref], burn with etcher and use config2.plist



oops, i did go ahead with the install on HFS+ journaled not APFS, and was using standard config.plist rather than config2. but the install seemed to work fine. thanks very much - you have really great installer images! i have wifi working automatically so i'm on the way!

still to do:

trackpad driver - most important

NVIDIA driver for 1070

internal sound

Ethernet i think is okay but not sure.

not sure about power management/sleep yet. display does sleep okay

i will look at all the links you posted to get Clover installed on the drive so i don't have to use the bootloader USB. thanks again! i'll update this thread if i need further assistance!

Link to comment
Share on other sites

hey there! looks like for some reason, I am unable to run Clover installer on the FILES section of the Olarilla USB key in UEFI config. perhaps my setup is the issue?

there are two drives. one SSD containing the Win10 OS install and the other larger 1TB SATA drive(non SSD). I installed the OS on a resized partition of the 1TB drive where the first volume was a NTFS data partition with no OS. I used a Linux LiveCD with gparted to create a 300GB partition from the unused space which I formatted with HFS+ and marked as the primary partition.

I tried UEFI both with and without the copy files to ESD option, and neither of these work. the standard install does seem to work, however. but it does mean that at the moment I have no ESD partition and the EFI folder is at the root on the macOS partition. is this going to cause significant issues? I've been hackintoshing for about 10 years and I remember the BIOS based boot loaders and they worked on the main partition, but wasn't sure if an EFI based boot would cause issues running from the macOS partition. the BIOS is definitely UEFI based.

I'll keep working on things and update this post if I run into further issues.

update#1 - okay looks like the UEFI setup can't find the other drive to boot from. it does appear to have an EFI partition on the main Win10 drive called SYSTEM and there is an EFI folder that appears there. I can mount it with Clover Configurator and can probably copy files to it, but I'm just trying to make sure I don't ruin the Win10 install in the process. what exactly should I copy to the SYSTEM partition? under EFI in SYSTEM there are three folders:




should I copy my CLOVER folder to this location? or should it be under APPLE maybe? advice appreciated! I can add a boot option to look for a boot file in my UEFI setup on the laptop. right now I do see a 'bootx64.efi' under the Boot folder (maybe it came from the Linux LiveCD?). I could copy over CLOVER from my HD and then replace the 'bootx64.efi' with the Clover 'BOOTX64.efi' file I have installed on my HD. does that sound like a good idea?

update#2 - trackpad is working via voodooI2C kext. I get click drag and two finger scroll all fine, and no drifting. however the pointer speed is too slow for me. any way to speed this up? nothing shows in SysPrefs under Trackpad. I know theres a config.plist file in the kext but not sure if changing settings that way is recommended.

for sound and other things, like battery indicator, i ran the runme app and am attaching the send me information. hopefully it shows enough info. at the moment I cannot boot directly from HD - only the USB.

Send me scottlooneys-MacBook-Pro.zip

Link to comment
Share on other sites

  • Administrators

[ref]metaphysician[/ref], DSDT.aml.zip


u need use some renames, don't forget

change GFX0 to IGPU

change HDAS to HDEF

change HECI to IMEI

change SAT0 to SATA

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Problems with Paypal HERE

Link to comment
Share on other sites

excellent - thanks - I am also wondering about moving the CLOVER folder onto the SYSTEM partition under EFI. should i do this to get the bootloader working from the HD?


EDIT - got the internal boot working. copying whole EFI folder from the USB key worked, then to get dual boot I copied the Windows folder under the older SYSTEM/EFI back to the same path.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Hey! Welcome to Olarila.com  Please Disable Your ADBlocker!


The popup will be closed in 15 seconds...