Jump to content

Hackintosh Guide - Catalina / Big Sur / Monterey on Mobos Series 100, 200, 300, 400 and 500 with OpenCore Bootloader

Recommended Posts

  • Replies 745
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Fixed it. Need to set XHCI handoff enabled in BIOS.

Buenos días Cuando el ordenador entra en reposo y quiero activarlo tocando el mouse o el teclado se reinicia. Probé muchas cosas, como darkwake, y nada funciona. Alguna solución? Saludos y g

same folder serie 100/200/300

First, stay with one USB Stick bootable for rescue if need or use EFI folder in USB Stick bootable with MacOs

*If u have a DSDT patched for Clover, don't use, need patch again for OC

1- Mount EFI partition and paste full EFI folder


2- Reboot

3- Extract Send_me for full DSDT patch, run this app


4- Put DSDT.aml in OC/ACPI



Please help me setup my files for Opencore.

Send me MacBook-Pro.zip

Im trying to redo DSDT and setup the OC folder.

When I use your OC folder I get KP


Link to post
Share on other sites

[ref]becoolio[/ref], use clover, now we can use with opencore uefi drivers


I have been using Clover, It’s just that most people who get the DW1820A wireless card to work use Opencore so I wanted to get it working.

The wireless card works with Clover but freeze after 5 - 10 minutes.

Link to post
Share on other sites


First some background information:

I've been having problems with Clover for the last year, it worked but not flawlessly so I left it there.

There was a recurring problem with the AptioFixes from build 48xx and up. Before these problems I had installed and configured Clover multiple times from scratch with succes (using only Clover Configurator)… Because It’s getting clear to me OpenCore is the future and much cleaner than Clover I decided to figure out if it is usable…

I've been trying to install Catalina for days using opencore using this setup and could not get it to work. (Stuck on boot before initialising kernel using -v)

I found a pre-build OC EFI folder for a different motherboard (I'm using a MSI z370m Gaming Pro AC, the EFI folder was build for a MSI B360 Mortar) and it booted and installed immediately. But of course it's not perfect.

Would you like to take a look at the used EFI folder?

And can you help me get up to speed with doing the post-install procedure?

The problems I have are:

- No onboard audio (not a problem, speakers are connected trough the monitor, they work)

- Crash on shutdown/restart (it will shutdown/restart as normal but at boot I get a popup that my system was shutdown due to a problem)

- Not all USB ports are working

- No FusionDrive support in OpenCore (I think this is because AfpsDriverLoader.efi does not support FusionDrives at this moment, not a problem but it would be nice if it works)

Things I still like to do myself when all is working:

- create new SMBIOS info

- try and activate FileVault later on

Included in WeTransfer Link (send me.zip is too large :( )


- Send me (from runme.app)

- EFI Folder (I downloaded for the MSI B360 Mortar)

- Shutdown crash report (generated after reboot)

EDIT: the used EFI folder is from here: https://github.com/SuperNG6/MSI-B360-10.14.6-EFI/tree/OpenCore

EDIT2: Things that do work but never worked well on Clover

- Boot is much faster

- Using AirPlay screen to Apple TV

- Bluetooth is stable (with clover it stoped connecting to devices once in a while, maybe this is because of the fresh install)

- much lower latency on my build in ethernet (from about 20ms to 0ms ping to router)

My hardware:

MSI z370m Gaming Pro AC - latest firmware (older firmware also did not work so I updated)

i5 8400

16GB ram

Saphire AMD RX580

iGPU BIOS setting: startup on PEG, IGPU enabled 64m

Link to post
Share on other sites

[ref]joeriko[/ref], use Olarila folder from first post



Stuck on (maybe) the same reboot loop as I started off with the first time I used the Olarila folder...

Replaced the EFI back to the MSI B360 one and booted again...

videos from startup (slomo):

FULL BOOT (including bios post) (60MB)


ONLY VERBOSE LOG (29MB) (sharper to read)


Thanks for trying to help me! You rock :guitar


First ERROR I could find in the verbose log:

ACPI Error: [\_SB_.PCI0.SATA] namespace lookup failure.......

After this it's full with errors

(02:05 in full video)

(00:09 in verbose video)


- I mounted the EFI

- Replaced the EFI/OC and EFI/BOOT with the Olarila one

- Added the DSDT.aml to the ACPI folder

- Rebooted

- entered the reboot loop

- Used a USB to SATA cable to revert back to the B360 EFI/OC + EFI/BOOT (with MacBook)

- Booted with no problem (other problems from previous post still exist of course)


Things I already tried


- build my own OC EFI folder using the getting started tutorial

- just didn't boot OpenCore


- Tried again to build OC EFI Folder using same getting started (I probably forgot something the first time)

- Booted OC and tied to install

- Did not boot kernel of installer

- Installed MacOS on SSD using MacBook and USB to SATA Cable

- Also did not boot kernel

3: Tried Olarila folder from this post

- tried installer (no boot)

- tried SSD with MacOS (no boot)

4: The MSI B360 EFI

- Booted installer, installed without a problem (except the installer was in Russian so I changed the language)

- Booted OS

5: Posted on this forum and got your response

- Swapped EFI back to Olarila EFI

- added the DSDT.aml to ACPI folder

- no boot (MacOS is already installed on SSD)

6: back to the MSI B360 EFI

- Booted again


- I always put EFI directly on a SSD (SSD 1) (internal SATA)

- I used the installer directly from different SSD (SSD 2) (connected trough internal SATA)

- MacOS is installed on SSD 1

Sorry for all the post edits, but I thought giving as much information as possible could be helpful)

Link to post
Share on other sites

[ref]joeriko[/ref], what happens with efi from first post, use -v and post one photo


Reboot loop, I can't make a photo of the error moment because the computer turns off (videos from previous post)


first error I could find:

ACPI Error: [\_SB_.PCI0.SATA] namespace lookup failure.......

zip with a few snapshots of video attached

Added in 31 minutes 14 seconds:

[ref]MaLd0n[/ref], I can also use your DSDT.aml on the B360 EFI

USB does not work

Audio also not

Attached OC folder with your DSDT on B360 EFI (EFI too large to attach)

heic screens.zip


Link to post
Share on other sites

Hi [ref]MaLd0n[/ref],

Thank you for the response. I downloaded the Olarila Image for Catalina but when I was in the process of installation, an error came up. Says the installer is damaged.

I used 7zip to extract the file and BalenaEtcher to write the image to my flash drive.

Also, is there a minimum for the donation?

Link to post
Share on other sites
  • MaLd0n changed the title to Hackintosh Guide - Catalina / Big Sur / Monterey on Mobos Series 100, 200, 300, 400 and 500 with OpenCore Bootloader

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

:cap-Please Disable Your ADBlocker-:cap