Jump to content
🎉 [ IMPORTANT ] Premium and Donators users 🎉 ×

Pequenos probleminhas para finalizar o hack


gleidson_h

Recommended Posts

Fala pessoal, belezera?


Tempo atrás estive fazendo hackintosh no Samsung RV411, mas por um problema da placa de vídeo deixei de faze-lo. Agora estou terminando de fazer no meu outro notebook, um ASUS K45VM. Já fiz praticamente tudo, agora a única coisa funciona que falta (que eu dei falta até o momento) é configurar o brightness.


Mas tem também duas coisas de 'design' que se eu conseguir arrumar, vai ficar top top top!


1 - Ao ligar, aparece o logo da asus, e posteriormente aparece umas letras sobrescrevendo o logo, e fica totalmente zuado. Eu gostaria, se possível, remover essas letras e deixar somente o logo da asus, ou até, se for possível (mas acredito que talvez seria na BIOS ou coisa assim), trocar o logo da ASUS pelo da Apple. Imagem: http://prntscr.com/nonbw8


2 - Após passar pelo clover, aparece a maça, depois dá esse problema da imagem (http://prntscr.com/none1s), e posteriormente volta mostrar a maça, exatamente do mesmo tamanho, bem configurado, apenas dá esse problema estranho. Cheguei a ver um vídeo sobre um fix pelo clover, mas no vídeo pelo que eu entendi era somente para nvidia. Preferi não descobrir a resposta arriscando.. haha


3 - E o Brightness também. Qual a melhor forma de corrigir?


Somente essas coisas para terminar o hackintosh, que por sinal ficou muito bom com o Mojave. Tenho algumas dúvidas também:


a) Pelo que li a respeito, geforce 630m não é possível instalar o kext, por isso estou usando intel hd4000. Já existe kext ou ainda não é possível instalar essa placa de vídeo?


b) Como saber quais kexts estão no /System/Library/Extensions que não estão sendo usadas? É aconselhável encontrar tais kexts e remove-las ou não é possível e nem é melhor mexer com isso?


c) Se por exemplo eu instalar alguma kext ou fazer alguma configuração no clover, por exemplo, que ferrar com a instalação, existe alguma forma de voltar atrás? Criar algum tipo de ponto de restauração ou coisa parecida?


d) Embora eu acredito que já está tudo ok, existe algum tipo de 'checklist' para eu ver se realmente está tudo ok ou se ainda falta fazer algo?

Link to comment
Share on other sites

  • Administrators

[ref]gleidson_h[/ref], 1- se vc usa hfs, remova ApfsDriverLoader-64.efi


2- pro high sierra tem o fix via clover

Name: com.apple.iokit.IOGraphicsFamily
Find* [HEX]: 01000075 22
Replace [HEX]: 010000EB 22
Comment: Boot graphics glitch, 10.13 beta (based on denskop patch)
MatchOS: 10.13.x

 

3- https://github.com/acidanthera/WhateverGreen/commit/a5158d0dd634855b98e87e2c63a139511ae9dc1f

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill [email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX @[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

[ref]gleidson_h[/ref], 1- se vc usa hfs, remova ApfsDriverLoader-64.efi


2- pro high sierra tem o fix via clover

Name: com.apple.iokit.IOGraphicsFamily
Find* [HEX]: 01000075 22
Replace [HEX]: 010000EB 22
Comment: Boot graphics glitch, 10.13 beta (based on denskop patch)
MatchOS: 10.13.x

 

3- https://github.com/acidanthera/WhateverGreen/commit/a5158d0dd634855b98e87e2c63a139511ae9dc1f

 

Fiquei fuçando aqui em diversas coisas e consegui ferrar com boot. Dai dei o boot novamente pelo pendrive, copiei a clover do pendrive e coloquei na EFI do HD. Após isso, o item 1 e 2 foi solucionado. (o item 1 totalmente, mas o 2 apareceu bem de leve um pequeno defeitinho, mas acho que nem perderei tempo com isso por enquanto não.. kkkk)


Já o Brightness, eu consegui, mas ao chegar no valor mínimo, a tela fica totalmente preta. Sabe se existe fix para isso para o Mojave?

Link to comment
Share on other sites

  • Administrators

[ref]gleidson_h[/ref], se vc usar o brightness da weg kext, esse problema não acontece

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill [email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX @[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • 4 weeks later...

Fala pessoal, belezera?


Tempo atrás estive fazendo hackintosh no Samsung RV411, mas por um problema da placa de vídeo deixei de faze-lo. Agora estou terminando de fazer no meu outro notebook, um ASUS K45VM. Já fiz praticamente tudo, agora a única coisa funciona que falta (que eu dei falta até o momento) é configurar o brightness.


Mas tem também duas coisas de 'design' que se eu conseguir arrumar, vai ficar top top top!


1 - Ao ligar, aparece o logo da asus, e posteriormente aparece umas letras sobrescrevendo o logo, e fica totalmente zuado. Eu gostaria, se possível, remover essas letras e deixar somente o logo da asus, ou até, se for possível (mas acredito que talvez seria na BIOS ou coisa assim), trocar o logo da ASUS pelo da Apple. Imagem: http://prntscr.com/nonbw8


2 - Após passar pelo clover, aparece a maça, depois dá esse problema da imagem (http://prntscr.com/none1s), e posteriormente volta mostrar a maça, exatamente do mesmo tamanho, bem configurado, apenas dá esse problema estranho. Cheguei a ver um vídeo sobre um fix pelo clover, mas no vídeo pelo que eu entendi era somente para nvidia. Preferi não descobrir a resposta arriscando.. haha


3 - E o Brightness também. Qual a melhor forma de corrigir?


Somente essas coisas para terminar o hackintosh, que por sinal ficou muito bom com o Mojave. Tenho algumas dúvidas também:


a) Pelo que li a respeito, geforce 630m não é possível instalar o kext, por isso estou usando intel hd4000. Já existe kext ou ainda não é possível instalar essa placa de vídeo?


b) Como saber quais kexts estão no /System/Library/Extensions que não estão sendo usadas? É aconselhável encontrar tais kexts e remove-las ou não é possível e nem é melhor mexer com isso?


c) Se por exemplo eu instalar alguma kext ou fazer alguma configuração no clover, por exemplo, que ferrar com a instalação, existe alguma forma de voltar atrás? Criar algum tipo de ponto de restauração ou coisa parecida?


d) Embora eu acredito que já está tudo ok, existe algum tipo de 'checklist' para eu ver se realmente está tudo ok ou se ainda falta fazer algo?

 


Tenho um K45VM e estou pensando em instalar o Mojave nele. Como está o seu hack? Poderia disponibilizar a sua pasta do clover?

Link to comment
Share on other sites

Tenho um K45VM e estou pensando em instalar o Mojave nele. Como está o seu hack? Poderia disponibilizar a sua pasta do clover?

 

Sim, depois coloco aqui. Os seguintes problemas existem:


1 - Ao abaixar o brightness no máximo, a tela fica totalmente preta, como se estivesse desligada

2 - O mouse some após inatividade por muito tempo (mas descobri como corrigir, basta passar o mouse no separador - barras verticais | - no dock que ele volta oaieioaeiaeoaieioe)

3 - Audio bem baixo

4 - Microfone fica chiado, parece voz robotizada

5 - Webcam não funciona

6 - Primeira vez que ligo a temperatura dele está em torno de 40º, mas com o tempo ligado vai pra 70-75º, apenas por ficar ligado um tempo, sem mexer nele. (faz muito tempo que não passa nem pasta térmica nele, talvez isso esteja influenciando nessa temperatura tão alta)


Até onde eu vi, várias pessoas disseram que o nvidia não funciona, mas a aceleração gráfica ficou boa, e ficou bem rapidão. Instalei programas gráficos do pack da Adobe e rodou liso.


Você já instalou alguma versão anterior ao Mojave e conseguiu solucionar algum dos problemas acima que listei?

Link to comment
Share on other sites

  • Administrators

[ref]gleidson_h[/ref], brightness vc pode usar a weg kext com o PNLF do clover, a whatevergreen agora gerencia isso

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill [email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX @[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

Sim, depois coloco aqui. Os seguintes problemas existem:


1 - Ao abaixar o brightness no máximo, a tela fica totalmente preta, como se estivesse desligada

2 - O mouse some após inatividade por muito tempo (mas descobri como corrigir, basta passar o mouse no separador - barras verticais | - no dock que ele volta oaieioaeiaeoaieioe)

3 - Audio bem baixo

4 - Microfone fica chiado, parece voz robotizada

5 - Webcam não funciona

6 - Primeira vez que ligo a temperatura dele está em torno de 40º, mas com o tempo ligado vai pra 70-75º, apenas por ficar ligado um tempo, sem mexer nele. (faz muito tempo que não passa nem pasta térmica nele, talvez isso esteja influenciando nessa temperatura tão alta)


Até onde eu vi, várias pessoas disseram que o nvidia não funciona, mas a aceleração gráfica ficou boa, e ficou bem rapidão. Instalei programas gráficos do pack da Adobe e rodou liso.


Você já instalou alguma versão anterior ao Mojave e conseguiu solucionar algum dos problemas acima que listei?

 

É a primeira vez que estou fazendo o hack, eu não estou conseguindo iniciar o instalador toda vez que corrijo um erro aparece outro . :(


Por isso pedi para você compartilhar a pasta EFI do Clover.

Link to comment
Share on other sites

É a primeira vez que estou fazendo o hack, eu não estou conseguindo iniciar o instalador toda vez que corrijo um erro aparece outro . :(


Por isso pedi para você compartilhar a pasta EFI do Clover.

 

Desculpa pela demora, mas estive bem ocupado esses dias com o trabalho. Segue o arquivo da pasta CLOVER da pasta EFI, é esse arquivo que é importante e configurável.

CLOVER.zip

Link to comment
Share on other sites

Olá amigos, tenho um Asus K45VM também, apanhei demais tentando fazer o meu funcionar. hora não pegava touchpad, hora tela ficava escura, hora wifi e lan... até que achei esse post, então tentei utilizar sua pasta clover, porém quando eu inicio o meu fica travado no logo da Apple com o Loading a uns 70% e não passa daí... alguma luz do que possa ser?

Link to comment
Share on other sites

Desculpa pela demora, mas estive bem ocupado esses dias com o trabalho. Segue o arquivo da pasta CLOVER da pasta EFI, é esse arquivo que é importante e configurável.

 

Obrigado!


Added in 9 minutes 3 seconds:

Durante o boot fica travado na mensagem "service exited with abnormal code 1". Alguma ideia do que seja?

Link to comment
Share on other sites

  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...