Jump to content
ūüéČ [ IMPORTANT ] Premium and Donators users ūüéČ √ó

HP Z820 Mojave - here we go


Flint Ironstag

Recommended Posts

Hello All,


first post, hope I'm in the right forum. I'm here to document my build from start to finish and see if it's viable for me to personally build and maintain a handful of these for a project. At least until Apple release a new Mac Pro.


Z820 non v2 BIOS

2 Xeon E5-2687W (8 core 3.1GHz)

BIOS J63 v03.94, 7/10/2018

32GB RAM DDR3

RX 580

GT 1030

HP Thunderbolt 2 card

240GB SSD (Windows)

1TB SSD (Mojave)

2 300GB 15k spinners for misc.


handful of USB drives for booting, images, etc.


I tried bare metal with ESXi but it kept hanging on install. If this goes well, and we finally get Nvidia drivers, I have a couple of GTX 1070s ready to replace the 580.

Link to comment
Share on other sites

  • 1 month later...

No progress, although to be fair I've been just reading and trying stuff. Haven't posted to ask the experts for help. Background:


I need Macs with GPU power to do some forensic work. I paid to have similarly specced Z820 Hackintoshed for the office. It is fast as hell! I wanted to test the feasibility of hackintoshing and maintaining a fleet of them myself. Obviously a no go - too much time and tinkering so far. I'd have to go the paid route again (if I can find the guy).


Have you tried ESXi 6.7?

Link to comment
Share on other sites

  • 4 weeks later...

Update: I had some more time to tinker with this and finally got it booted to the desktop. A lot of things don't work: ethernet, audio, thunderbolt, internal storage (booting from SSD on USB2). But it's progress. Now I'm this far I'll get reorganized today and seek some help.


What kind of problems are you having?

Link to comment
Share on other sites

  • Administrators

[ref]Flint Ironstag[/ref], u can extract a original dsdt? i'll check

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

Send me admins-Mac-Pro.zipOK I reinstalled and booted to the desktop again. Per the instructions I downloaded the clover 5,6,7,8,9 series folder and replaced my clover folder. I also ran the DSDT and it is attached. System will not boot now. last 3 entries are:


RTC: only single RAM bank (128 bytes)

HID: Legacy shim 2

AppleIntelCPUPowerManagement: (built 23:24:33 Apr 25 2019) Initialization complete


then it hangs.


Thanks in advance! Will drop you some beer money from the office next week.

Link to comment
Share on other sites

  • Administrators

[ref]Flint Ironstag[/ref], REPLACE FULL EFI, REBOOT, check if work

EFI.zip

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

Holy cow that fixed a bunch of stuff. Thank You! I have to run out shortly but will take a deeper look tonight and do some more reading to see what I can fix.


Things working now:

- Asus usb wifi adapter

- ethernet port 0

- airplay to Apple TV

- rear USB3 ports


Things kinda working:

- firewire 400 both ports front & rear (isight & external drives light up, but OS doesn't see them)


Things definitely not working:

- headphone jacks

- ethernet port 1

- front USB3 ports

- PS/2 port for my mechanical keyboard (man I wonder if I have an adapter somewhere)

- any kind of system sound - only airplay works

- HP Thunderbolt 2 card


GeekBench

single 2244

multi 31705

Right in the pack with iMac Pro 8 core and nMP 12 core on multi core


I am stoked! Will make a list and tackle these one at a time. Thanks a million! If I can get this sorted, I may treat myself to a barebones Z840 and build it up.


Thanks again!

Link to comment
Share on other sites

  • Administrators

[ref]Flint Ironstag[/ref], extract new send_me

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • Administrators

[ref]Flint Ironstag[/ref],

audio Realtek ALC262

check here, just inject via clover, reboot and test

https://Olarila.com/forum/viewtopic.php?f=28&t=9788


run Hackintools, go to PCI tab and export one txt, post txt here, i need check hardware


Added in 10 minutes 29 seconds:

one fix

DSDT.aml.zip

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

OK I went through the steps to verify that I have Realtek ALC262 for my own benefit.


I open the resources folder and have layouts: 7,11,12,13, and 28.


I tried 7 first and rebooted. That gave me sound from the internal speaker, but not from any of the jacks. I will try the other 4 before moving on to your next steps.


Thanks again.


Added in 10 minutes 33 seconds:

OK layout 11 worked! I will run Hackintools next and post that export. Thank You!


Added in 22 minutes 42 seconds:

From Hackintools PCI tab export:

 

pcidevices.txt

 

Thanks again!

Link to comment
Share on other sites

  • Administrators

[ref]Flint Ironstag[/ref], try it for other lan card

AppleIntelE1000e.kext.zip

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

Thanks, I will try it and let you know. I have not done anything with the DSDT.aml.zip file you sent me yet as I'm not sure where it goes. I'm reading and learning as we go!


[edit] firewire rear port is working for hard drives, but the isight is not recognized. It's the original one. Maybe it's not supported in Mojave. No big deal as I have a modern Logitech.


Man, there's a lot of details to get right.

Link to comment
Share on other sites

  • 1 month later...
  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...