Jump to content
Eternity87

[Solved] Z170+Skylake Mojave 10.14.3 + Intel 530+Sound

Recommended Posts

Hello,


Can someone help me create Clover EFI folder for Mojave 10.14.3 please.


My hardware:


=i7-6700k processor

=Intel HD 530 [works fine in High Sierra out of the box connected via VGA to Samsung monitor]

=Sound [Realtek builtin]

=WiFi and LAN [intel WiFi 8260 and Builtin Realtek Ethernet]

=USB and motherboard drivers

=500GB HDD


SMBIOS: iMac 17,1


I have attached my EFI folder in case it needs tweaking. Thank you :)

EFI.zip

Edited by Guest
Link to comment
Share on other sites

your wifi will not work use this clover folder https://Olarila.com/files/Clover.Folder/CLOVER.SERIES.100.200.300.zip

usb here https://Olarila.com/forum/viewtopic.php?f=79&t=7370

you should have a dsdt completed from here https://Olarila.com/forum/viewtopic.php?f=19&t=1131

an you gpu will not work in mojave so best is to be with high sierra

AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36

:superman:superman

HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB

Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler

Link to comment
Share on other sites

yes intel 530 is but you have a 1060 an that doesnt work in mojave

AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36

:superman:superman

HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB

Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler

Link to comment
Share on other sites

Ahh yeah. That is fine. I am happy with Intel 530 :) I am gonna re-install High Sierra and create Mojave from there. I heard that creating bootable USB etc .. from VMware can cause troubles as well.


By the way, which WiFi and Bluetooth do you recommend for High Sierra which would be compatible in Mojave? :)

Link to comment
Share on other sites

you can create a usb in windows also just follow this guide here https://Olarila.com/forum/viewtopic.php?f=50&t=8685

TP-Link Archer T9E will work

AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36

:superman:superman

HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB

Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler

Link to comment
Share on other sites

Hi,


I am back :P and managed to get Mojave installer working through Clover latest version kexts and UEFI drivers. I have attached the EFI file.


Problem was that it was booting without ACPI settings and kernel and kext patches. If I booted it up with Nvidai 1060GTX then it would boot without any issues and install, obviously without Nvidia acceleration due to lack of driver . If I boot with Intel 530 it may or may not work and therefore made changes to the EFI file which I attached here.


Now I need to figure out how to make Intel 530 work with full acceleration and my built in Realtek sound.


Need to see what WiFi and Bluetooth cards work out of the box for Mojave.


I thought I would share this with you guys. Thank you :)


Added in 2 minutes 44 seconds:

Re: [solved] Help me with EFI folder please Mojave 10.14.3

If anyone knows how to make Intel 530 work under Mojave, please do let me know. I am looking into patching frame buffer guides as well to see if I can implement something. Thank you :)

EFI_Mojave_Working.zip

Link to comment
Share on other sites

  • Administrators

Intel 530 work under Mojave

 

just InjectIntel work

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

I am back again :)


Got Mojave working on my motherboard including Intel 530, Sound, Intel bluetooth.


I have attached the EFI folder. Note that I am using VGA connection to the monitor and who ever downloads this and using HDMI / DP connection to their monitors need to change the value in Clover application> Graphics> ig-platform-id> Choose Intel 530 from the list depending on what Mac you are emulating etc ...


No need for fake ID and you will be booted to Apple logo without any forbidden sign.


Got Internet working as well through Bluetooth. My Galaxy S7 Edge passing on Internet to my machine through Bluetooth.


Thank you :)

Z170chipset_Skylake.zip

Link to comment
Share on other sites

[ref]Eternity87[/ref], :guitar:guitar

AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36

:superman:superman

HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB

Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler

Link to comment
Share on other sites



just InjectIntel work

Dear @MaLd0n

Please I need your help

I've installed Mojave

I am trying to use platform id : 0x19120000 I get black screen

and id : 0x19120001 cause KP and reboot

I want use IGPU intel HD 530 with Displayport for 4K monitor

Only the one is working id : 0x193b0005 ; and it show in my system as Iris pro 580

I've tried everything imac 17.1 14.2 Mac pro 6.1 ; I am looking for a fix everywhere and no result

I want use real platform id to get correct framebuffer


What I want is possible or impossible to happen?!!


I will upload all needed files upon your reply


Thank you


Asus z170i pro gaming

Intel i7 6700k

32 gb ram

Link to comment
Share on other sites

  • Administrators

[ref]Zkingtut[/ref], try other output video, if work use hackintool for create a correct video patch

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

[ref]Zkingtut[/ref], try other output video, if work use hackintool for create a correct video patch

You mean I should try HDMI ?

I did that ; but Hdmi is limited to @30hz ;

And I used Hackintool to create frmaebuffer but once I reboot with DisplayPort and ID 0x19120000 again black screen

I tried with and without Whatevergreen; and IntelFixUp

No way

Thanks

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now




×
  • Create New...
The popup will be closed in 15 seconds...