Jump to content

Olarila HackBeast Z390 M Gaming - Full DSDT patches


Recommended Posts

  • Replies 241
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Nice, thanks.

Posted Images

Hi


Currently, I have a strange behaviour with my z390 m gaming (F7) build.


This just happened suddenly after tinkering with my clover config.

Right after shutdown or sometimes after a crash after a long sleep, I get a "couldn't allocate runtime area" error that doesn't go away unless I re-flash the bios. Then I can boot again (usually only one time and then the same error shows up again).


I also checked memmap and I should have enough available space at 0x0000000000100000.

Anyone has an idea what the issue could be?


At the moment I use the 300 series clover config from your site here, but without a custom sdst or ssdt.


Thanks in advance for any tips..

Link to post
Share on other sites

Hi MaLd0n, after another BIOS flash :roll: boot-up looks good. Didn't spot any ACPI errors :D


The only thing is, with your EFI my Broadcom BCM94360CD PCIe Adapter doesn't work anymore.

Is this something that needs to be added back the ssdt?


Note to myself, I really need to check out how dsdt/ssdt's work :geek:

Link to post
Share on other sites

MaLd0n,

thanks for the tip, but you already included AirportBrcmFixup.kext in your EFI.zip.

I have added this kext but still the Broadcom card doesn't work with it.

Btw, if I boot without your DSDT then the card works natively.


Another strange thing is, that I still need to re-flash the BIOS (or clear the CMOS) after almost every shutdown or I still get the "couldn't allocate runtime area" error.

But I assume that are two different, unrelated issues.

Have you ever had this problem as well?


But hey, thanks alot so for for helping me out. Its really appreciated!

Link to post
Share on other sites

Looks like to following change made Bluetooth work again. Was probably just a typo ;)

 

--- a/patched MaLd0n for me/SSDT-6-A M I.dsl
+++ b/patched MaLd0n for me/SSDT-6-A M I.dsl
@@ -1448,7 +1448,7 @@ DefinitionBlock ("", "SSDT", 2, "ALASKA", "A M I", 0x00000000)
                {
                    If (LEqual (And (UMAP, 0x0200), 0x0200))
                    {
-                        Return (MALD (Zero))
+                        Return (MALD (One))
                    }
                    Else
                    {

 

Added in 5 minutes 49 seconds:

[ref]locus[/ref], if u update bios need edited again

 

Yes, I have read that in one of your previous posts.

I am on the latest version F7 all the time. I don't plan to upgrade it anymore, unless there is an important reason for it.

Link to post
Share on other sites
  • 2 weeks later...

Hi MaLd0n


I know why now, I normally stick my card in the pci 1 slot. However, I swapped it to the pci 2 slot since my new rx580 card is quite big and the fan hit my wifi card, so I had to move it to the pci 2 slot . Switching it back to the 1st slot solves the problem but then it also means I have to remove my wifi card


How do I modify the dsdt, ssdt you sent me so it works with pci slot 2?


Thanksss

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

:cap-Please Disable Your ADBlocker and Support Our Forum-:cap