Jump to content

Olarila HackBeast Z390 M Gaming - Full DSDT patches


Recommended Posts

[ref]Boriss[/ref], looks good

Mald0n, I am testing your configuration I think AptiomemoyiFix works better than my configuration, where with the mentioned Eufi Driver I did NOT pass the Pre Verbose......

I'm trying to evaluate if the NVRAM is native with your configuration and in any case I have seen x the first time turn off and start up regularly with AptiomemoryFix, I continue with the Tests .....


Thank's

Link to post
Share on other sites
  • Replies 245
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Nice, thanks.

New use donators room for that https://www.olarila.com/forum/84-dsdt-patch-requests/

Posted Images

good morning Mald0n, after days of testing, I verified that through 2 patches in configplist added to my initial configuration more Bios settings you recommended I have native NVRAM result ....

I realized in this period that in any case it is very dependent on all SMBios, IMAC 18.3 NVRAM always native, while IMAC 18.1 and macmini 8.1 are SMBios problematic the NVRam does NOT always work well .....

SMBios 19.x NVRAM NEVER native ........

Point out that I also have 10.14.5 last Beta .....

I attach my configuration with native NVRam with AptiomemoryFix ....

I take this opportunity to thank you and to congratulate you for everything you do in the Hack field


Sorry for my English , use Google traslate

Z390 M GAMING-CF.zip

Link to post
Share on other sites
  • Administrators

[ref]Boriss[/ref], u have a wrong config, ssdt have only cosmetics, u need a full DSDT patches with essentials, cosmetics and more, only cosmetic don't have any diff

Link to post
Share on other sites

I understand, could you adapt DSDT made by you in the clover posted x to be used without USBInjectAll and then use my SSDT mapping ports with your configurations ??

I'm asking too much ??

I tried to put it in your configuration, but USB doesn't work anymore

port mapping done in SSDT is targeted for my configuration

Link to post
Share on other sites

[ref]telepati[/ref], never enable ;)

 

Thanks. I tested it. Just like you said, after update the latest BIOS to F6, I used to default BIOS settings and change just IGPU enabled. And everything working without any hitch. :crazy:


But, one thing doesn't work anymore, iTunes DRM. Even the downloaded movie. Normally the downloaded movie would have work in any case. I tried boot arg shikigva=1, 57, 60 but they didn't help. I test with old BIOS settings but it didn't help probably this is not too related with the BIOS settings.


Thank you MaLd0n you're awesome :frantics

Link to post
Share on other sites

[ref]MacintoshHealer[/ref], u use a bios mod? very diff tables, extract original tables with f4 in clover boot screen or via windows

 

I just did cleanup the DSDT and opened the scopes. It is for better overview. But here are the original ACPI tables extracted with clover

Could you please apply all the patches you did for your mobo? We have quite similar machines so it will be good :-)

No need for UIAC device, I will delete the unused ports from the XHC device and try the default macOS injection from ACPI...

Big big thanks!!!

Designare Z390 F6.zip

Link to post
Share on other sites
  • Administrators

[ref]MacintoshHealer[/ref], DSDT.aml.zip

 

yes, don't need any injector


u can identify internal, usb 2, usb 3, usb-c... all via ssdt oem


<IMGUR id="YjK8mk6"><a href=https://i.imgur.com/YjK8mk6.png' alt='IMGUR>'>

Link to post
Share on other sites

Hey, MaLd0n

thanks a lot, the DSDT works like a charm... I am using iMac19,1 SMBios and I have edited some device-ids (SATA, XHC) to be the same as in the iMac19,1 - that rocks! Also in config.plist I added Intel injection with the iMac19,1 Intel UHD 630 device-ids. I don't need Whatevergreen anymore and my sleep is working again this way. Intel UHD 630 is fully recognised and accelerated. But I am using the Vega 64 as output. The injected ig-platform-id from the 2019 iMac 27" is a headless one I guess.

I also added a ETH1 device with device properties in order to display the second gigabit lan (intel i211 PRO) properly.

Thunderbolt 3 is also added.

I am waiting for the IMEI and XSPI device-ids from the iMac19,1 dump in order to load the kexts for this devices.


Only one thing I would like to improve is to drop the USBInjectAll.kext, even after removing the unused USB2/3 devices in the XHC to the number of 15 (I did not count the two USB3,1 devices) and adding the proper device-ids to the _DSM part, my USB keyboard/mouse is not recognised at all in no port without USBInjectAll.kext. I am not using USB patches to disable ports limit.

You said that you don't use USBInjectAll.kext neither, nor other kexts or port limit patches - can you share your XHC device from your DSDT, I want to have a look on it. I don't understand why mine is not working.

Maybe I will try TeamViewer to explore IOReg on this build from my macbook, but maybe you have other hints?


Thanks a lot so far!!!

Link to post
Share on other sites
  • 2 weeks later...

@MaLd0n before the help I want to ask you. is your system randomly crash? I don't get it what's going on but my system starts to randomly crash. But it looks like a graphics issue but I don't get it what causes this. Randomly screen turns whitish grey. The case still working, all fans running just I am losing the screen. I thought maybe my graphics card or display faulty but it never happens while using Windows OS. I am using the latest kexts with your DSDT created. But it is still happening randomly.

Send me iMac-2.zip

Link to post
Share on other sites

That's the problem. I just can open with the force restart from the case and no KP or report. Could you please give me a suggestion where should I look after the restart, to defining the problem.


BTW, I am already using these boot-args.

Link to post
Share on other sites
  • Administrators

[ref]telepati[/ref], first try u can remove shikigva, injectintel, intelgfx and ig-platform-id, now work really native

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

:cap-Please Disable Your ADBlocker-:cap