Jump to content
AnonyManx

Maybe my Clover setup needs tweaking for Mojave?

Recommended Posts

Over the past few weeks, I've managed to assemble a fairly-functional Hackintosh. With some help from this site specifically, I even ended up with HighSierra behaving properly for shutdown/restart! The only remaining gremlins were a WiFi glitch (sees networks; can't actually connect) and the Thunderbolt expansion card debacle.


Here's the hardware info:

  • Asus Prime Z390-A

  • Intel i7-8700k

  • Radeon RX 580 8 GB

  • 32 GB 2400 MHz DDR4

  • Broadcom BCM94360CD BT/WiFi on PCIe adapter

  • Asus Thunderbolt 3 expansion card

  • 3 SSDs at 1 TB each: 1 currently with HighSierra, 1 currently with Mojave, & 1 with a small Windows partition (unactivated) & also an exFAT data partition in case I decide to activate Windows (seems unlikely)

 

Oh, and a spiffy Corsair mechanical keyboard. When I installed drivers for it (GitHub project - not actual Corsair drivers), all sorts of headaches were spawned. So I removed the drivers, and was considering nuking that drive when I instead updated my HighSierra installation thumb drive and installed a second HighSierra drive. That install went *almost perfectly* (still the WiFi glitch). That's the drive from which I'm writing this post, by the way, because...


...the original HighSierra drive was wanting to be upgraded to Mojave. I thought, "Why not see what happens? This should be fun." I told it to install Mojave. It did. Perfectly and with no errors. And installing Mojave solved the WiFi glitch! Sweet! I noticed that Mojave wants to point /Documents to iCloud. Brilliant! Love it! Let's put all the things on iCloud! So I connect to my MacBook and start trying to pull things over... and get errors. Weird ones. My MacBook is old (late-2011 17" MacBook Pro with 16 GB RAM & 1 TB SSD), but has always been rock-solid reliable (except when the video chip failure hit it; that was covered by Apple). But suddenly the MacBook is being squirrelly and I want to get the data off of it. No big deal - I have a USB Time Machine backup as well.


So Mojave won't recognize the existence of internal SATA drives connected by a USB/SATA adapter. I have tried with 3 different drives (the Time Machine drive is spinny, but the others are SSDs) and 2 different USB/SATA adapters. No go. Mojave will recognize thumb drives without a hitch, though. Oh, and ejecting drives is... not always successful. So somethings not right in Mojave. But most things are.


Since I want continuity of data, and since I have this HighSierra partition, I booted into this and attached the Time Machine USB drive and POOF! I have access to my backups. Brilliant! I have just copied the things that are important onto the exFAT partition so that I can do what I will with them from there (not to iCloud yet because I haven't put my AppleID into this install).


ANYHOW, It seems like I may need some different kexts for Mojave? I'm truly not sure. The recognizing USB/SATA drives thing is annoying and I definitely want to be able to do that. I love pulling hard drives and hooking 'em up USB to do quick tweaks. Also the drive eject command not working right is a sign of a problem.


Other than that, any guidance on the Thunderbolt card would be appreciated, but at this point I'm leaning towards taking it to a gun range and using it as target practice (and also selling my Thunderbolt Display and buying a new 4k monitor)...


I have attached the CLOVER folder from the EFI partition on my Mojave drive. It is the same as on this HighSierra drive. Maybe it shouldn't be completely the same?

CLOVER.zip

Link to comment
Share on other sites

  • Administrators

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

WiFi works in Mojave. Upgrading to Mojave totally fixed that. The Mojave headache is recognizing USB drives (like a SATA SSD connected by USB) and ejecting any drives. So I have no problem getting USB thumb drives recognized, but ejecting doesn't happen.


But I will throw that into the 10.13 Clover kext folder and see what happens. After my current project (cloning the Mojave drive to a spare SSD) finishes.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now




×
  • Create New...
The popup will be closed in 15 seconds...