Jump to content

Dual Display (DVI & HDMI) na 9800 GT. HELP!


Recommended Posts

Olá pessoal.


Desde que montei meu hackintosh eu tento usar dual display e não consigo.

Já li e fiz de tudo, desde GraphicsEnabler=Yes até usar NVEnabler e GFX String. Nada...

Tudo funciona perfeitamente no Windows 7.


Será que alguém tem alguma última dica antes de eu me dar por vencido? :)


Estou com OS X 10.6.8 e drivers da NVidia atualizados.


Minha placa de vídeo é uma ECS NVidia GeForce 9800 GT 1024MB Green Edition (NR9800GTE 1GQU 10de.0614).

Ela tem uma saída DVI (mais próxima da placa-mãe), uma saída VGA e uma saída HDMI.


Na saída DVI está ligado um monitor LG E2250 (cabo DVI-DVI).

Na saída HDMI está ligada uma TV LG (cabo HDMI-HDMI).

Utilizo GraphicsEnabler=Yes e não uso nenhum kext (NVEnabler, NVInject, etc).

No org.chameleon.boot.plist eu uso o NVCAP: 04000000 00000200 00000000 00000000 00000000.

Funciona tudo perfeito mas se eu retiro o NVCAP ou tento outro a tela fica preta após o boot e só desconectando o cabo HDMI volta funcionar.


Alguma luz? :D


Abraços!

Link to post
Share on other sites

Cassio,

eu acho que a solução está em setar um NVCAP que funcione.


Com este NVCAP que eu estou usando agora não preciso nem desconectar o cabo HDMI da placa e o Mac OS funciona perfeito. Se eu não coloco NVCAP, ou seja, deixo o GraphicsEnabler=Yes extrair, dá tela preta. Então com esse NVCAP eu (acho que) estou dizendo para o Mac OS que só tenho uma saída na placa de vídeo funcionando (DVI, mais próxima da placa-mãe) e que nela sai sinal digital.


Eu listo abaixo alguns links onde li coisas sobre NVCAP, channels, outputs, etc, mas é tão confuso e às vezes contraditório que ainda não cheguei a solução. :(


http://projectosx.com/forum/index.php?showtopic=5

http://www.insanelymac.com/forum/lofiversion/index.php/t215236.html

http://acrocontext.wordpress.com/2009/07/08/mac-osx-nvcap/

Link to post
Share on other sites

Não sei se é tão simples assim. No meu caso, a placa nem tem saída HDMI, tem apenas duas DVI. Numa delas (primária) uso um monitor LCD. Na secundária, se eu ligar um adaptador DVI-VGA e ligar na entrada VGA ta TV de LCD, funciona normal. Se ligar um cabo DVI-HDMI na entrada HDMI da TV, ficam as duas telas pretas. O mesmo cabo no Windows funciona normal.


Dizem que até a versão 10.6.3 funcionava normal HDMI, depois começou esse problema.


Também tentei as chaves display-cfg como falam no tópico na NVEnabler (o Chameleon também tem essa opção) mas não adiantou.


http://www.projectosx.com/forum/index.php?showtopic=370

Link to post
Share on other sites

É, eu desisti de vez agora. Tentei todos os NVCAPs possíveis e nada.


Acho que li sobre um cenário parecido com o seu e o problema estava na pinagem do conector DVI-HDMI.


Enfim... Uma pena.

Nessa o Windows 7 ganhou de barbada. Pelo que li os drivers no Windows conseguem fazer a alocação de channel x output em tempo real.


E o seu cenário me desanimou a comprar outra placa de vídeo que tive 2 DVIs. :(

Link to post
Share on other sites

Eu já tentei o ROM da 8800GT mas não deu certo. :(


Os conectores são diferentes, eu sei, mas eu acho que a VoodooHDA chama o áudio HDMI ATAPI de SPDIF.

A saída de áudio da placa-mãe (ALC889) eu já liguei na placa de vídeo e, no Windows, eu mandava som para a TV pelo cabo HDMI.


:(

Link to post
Share on other sites
  • 9 months later...
  • 2 months later...
Comigo funcionou 100% DVI-HDMI no OS 10.8.1 e no 10.8.0


seguindo essa dica: http://uphuck.ggrn.org/forum/viewtopic.php?f=25&t=14868


Fazendo o download da rom da 8800GT e posteriormente renomeando a rom pra 10de_0614.rom e colocando no com.apple.Boot.plist as linhas:


UseNvidiaROM

yes

VBIOS

yes


Abs

Treak

 

Também estou com o mesmo problema.

Tentei aqui mas não rolou... 9800gtx+ Nem Lion nem ML... mais alguma sugestão?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

:cap-Please Disable Your ADBlocker-:cap