Jump to content

Hackintosh Guide - Install MacOS with Vanilla Olarila Image, Step by Step, Install and Post Install, Windows, Linux or Mac


Recommended Posts

  • Replies 2.8k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

-Donations with PayPal https://tinyurl.com/r2bvzm7 -Donations with Bitcoin 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 -Donations with PicPay  @danielnmaldonado -Donation with Mercado Livre  htt

I think it's important to say USB 2 only on installer. Because on my ASUS UX410 Laptop impossible to finish the install without this information 😉

yes. inside efi partition use smbios iMac13,2

Posted Images

2 hours ago, MaLd0n said:


Isso aqui?
http://ddfwj7npcq62r.cloudfront.net/2020/2020-11-22-x99-tiamat.ioreg


Uma coisa que não consegui acertar ainda é o audio pelo painel traseiro da placa mãe.

Instalei um windows em outro disco para ver qual é o hardware, é este aqui:
spacer.png

 

Tem outro ali ATI/AMD, mas acho que esse é da placa de vídeo.

 

Link to post
Share on other sites
2 minutes ago, MaLd0n said:

Alterar smbios?
Como faço isso?

40 minutes ago, MaLd0n said:


Para o audio eu segui os passos do link, inclusive o meu codec era o mesmo do exemplo ALC892.

Consegui alterar o config.plist usando o layout 1: alcid=1 

Mas nada. O painel traseiro não funciona.
O plug que fica no painel frontal funciona, mas a qualidade do audio é ruim.

Link to post
Share on other sites
5 hours ago, RenatoCN said:

Alterar smbios?
Como faço isso?


Para o audio eu segui os passos do link, inclusive o meu codec era o mesmo do exemplo ALC892.

Consegui alterar o config.plist usando o layout 1: alcid=1 

Mas nada. O painel traseiro não funciona.
O plug que fica no painel frontal funciona, mas a qualidade do audio é ruim.


Só para deixar um update aqui.

Consegui fazer o audio funcionar no painel traseiro.

Não sei dizer ao certo o que eu fiz além de seguir o tutorial de audio que @MaLd0n mandou, pois fiquei fuçando e reiniciando várias vezes aqui.

O tutorial é este:



-------------------------------------------------------------
[edit]

@MaLd0n sabe quando você falou para alterar smbios?

Para qual eu deveria alterar?

Eu aprendi como faz para alterar, mas não sei ao certo qual escolher.

Eu mudei para: iMacPro1,1 que foi o mesmo que usei lá no início para conseguir instalar.

Mas duas coisas aconteceram:

1) Não funcionou mais o vídeo pelo cabo displayport, só funciona pelo HDMI agora.

2) Da primeira vez que ligou, ficou meio lento, dando uma travadas, até que travou com umas coisas na tela, assim:
spacer.png
 

Reiniciei e agora está funcionando, mas estou achando que deveria ter escolhido outro smbios, só não sei qual.

Edited by RenatoCN
Link to post
Share on other sites
  • Administrators
1 hour ago, RenatoCN said:

Beleza, adicionei shikigva=128. Qual é função dele?

https://www.olarila.com/topic/5295-guide-hardware-encoder-hardware-decoder-video-processing-hevc-support-intel-quick-sync/

1 hour ago, RenatoCN said:

Para confirmar, está certo parar de funcionar o displayport com smbios iMacPro1,1?

pode ser que sim

Link to post
Share on other sites
17 hours ago, MaLd0n said:

Hum saquei, para codec de vídeo. Boa!
 

Aqui aconteceu da tela congelar, estava em uma call via zoom e conseguia falar com o resto do pessoal, só a tela ficou travada.
Vi que tem gente dizendo para desabilitar o audio do HDMI, mas não sei como fazer isso ou se é esta a solução.

Link to post
Share on other sites
  • Administrators
6 hours ago, eaduril said:

Hi again! One question... Does the new image of Big Sur (20B50 compilation) contains the new Clover folders? Do we need to do anymore? Or just run the USB and start the installation?

u need test

with quirk dont exist preset

5 hours ago, Renttor said:

Vi que tem gente dizendo para desabilitar o audio do HDMI, mas não sei como fazer isso ou se é esta a solução.

isso é pra radeon vii

Link to post
Share on other sites
  • Administrators
35 minutes ago, Cuzco said:

https://imgur.com/2B8xJ18

I keep getting error from etcher. NO mattter how i download the image

use terminal

Quote

diskutil list
diskutil unmountDisk /dev/diskX  (replace X by the USB stick identifier)
sudo dd if=[drag and drop the raw file in terminal] of=/dev/rdiskX bs=1m  (replace X by the USB stick identifier)

 

Link to post
Share on other sites
  • 2 weeks later...

Hello,
    New to all of this, put together a build for a home recording studio, wanted MacOS to use Logic and other plugin software. Not incredibly knowledgeable in this area, but was able to keep up reasonably well with the vanilla guide (Thanks a lot!). Got up to about step 7, MacOS starts up and works fine (as far as I can tell thus far). Still have to boot from the flash drive each time, as normal startup brings me to the (Christmas themed) clover menu and then to nothing. Not sure how to work with the DSDTs, which specs are right for me, or where to put the files when working with clover.

I would greatly appreciate if someone who understands this better than I do could talk me through completing the final steps of the setup to make the machine function on its own. I'll send any specs requested, provided I know how and where to find them for you. Thanks!

Link to post
Share on other sites

That's what I was missing, Thanks for that. Copied new Clover and Boot folders to replace the ones in the hard drive EFI folder (and the original boot drive, by accident); Guide says not to reboot at this point, so I haven't.

Created a new send me, too large to attach. If it's not apparent already, I'm not terribly familiar with the higher end tech side of all of this, including the best places used for file sharing and so on, so below is a link for Dropbox with the send me. Hope that's acceptable.

https://www.dropbox.com/s/6skzruch2pwzj8l/Send me Jacks-iMac.zip?dl=0

Link to post
Share on other sites

If I recall, I put the GPU in that slot and filled the first slot with other connectors because it didn't fit properly. I can try to rearrange it if it's necessary. I take it rebooting at this point to do that won't be an issue then?

 

To remove Olarila, would I do that by using Clover or OpenCore Configurator to edit it from the OC/ACPI folder, as you describe in the guide below? Should I insert the DSDT from your post in its place?

 

Edited by Jherna95
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

:cap-Please Disable Your ADBlocker and Support Our Forum-:cap