Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
onemanosx

Enable I2C Trackpad (VoodooI2C) - Not a Guide... not really

    Recommended Posts

    On 3/16/2020 at 11:47 PM, riyanardian said:

    is my kext correct? the trackpad working like mouse only, there is no option for gesture

    https://imgur.com/hj1LAo9

    Try to remove "VoodooPS2Mouse.kext" and "VoodooPS2Trackpad.kext" from "VoodooPS2Controller.kext/Contents/PlugIns"

    • Like 1

    Share this post


    Link to post
    Share on other sites
    18 hours ago, Rafis Bikbov said:

    Try to remove "VoodooPS2Mouse.kext" and "VoodooPS2Trackpad.kext" from "VoodooPS2Controller.kext/Contents/PlugIns"

    still not working 😅

    Share this post


    Link to post
    Share on other sites

    Can someone help me pls? my problem is that my trackpad doesn't work To make it work, I need to deleted my kext from the Kexts / Other folder, and put them back there, rebuild the kextcache with sudo kextcache -system-prelinked-kernel reboot and it worked, then I rebooted and it no longer worked . its like random if it will work or not.
    WORKING: 
    http://s000.tinyupload.com/index.php?file_id=20261312987899219841

    NOT WORKING:
    http://s000.tinyupload.com/index.php?file_id=40792482548307332919

    I could not find any difference when it works and when not more than in the IOReg, below my TPDX device more things appear when it works, but in the bootlog and the kernel log I did not find anything different. Please someone help me :(

    Share this post


    Link to post
    Share on other sites
    31 minutes ago, elechocruz said:

    Can someone help me pls?

    DSDT.aml.zip

    update kexts and bootloader

    Share this post


    Link to post
    Share on other sites
    Posted (edited)

    Hello 

    I'm followed this guide step by step but no working for me 

    I edit My DSDT and apply GPI0 controller patch but IOReg doesn't show ACPI ID

    My windows ACPI ID:: TPDE

    My ELAN based on ACPI: ELAN0501, ELAN0511

    please help me 

     

     

    Edited by Rezarg

    Share this post


    Link to post
    Share on other sites
    Posted (edited)
    On 4/13/2020 at 2:55 AM, MaLd0n said:

    first u need a folder with correct settings, check here

    https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/

    for start with a good config

    now I using olarila config but Nothing has changed and My trackpad Does not work and Thermal subsystem no longer installed 


    only I'm removed some DSDT Rename like GFX To IGPU based on FAQ whatevergreen and AppleALC

     

    Edited by Rezarg

    Share this post


    Link to post
    Share on other sites
    10 hours ago, Rezarg said:

    now

    first use a macbookpro13,1 smbios

    Share this post


    Link to post
    Share on other sites
    Posted (edited)
    18 hours ago, MaLd0n said:

    first use a macbookpro13,1 smbios

    smbios changed to macbookpro13,1 
    Now trackpad works 👍 but unstable and No multitouch 
    plus, IOReg still doesn't show ACPI ID

     

    Edited by Rezarg

    Share this post


    Link to post
    Share on other sites
    2 hours ago, Rezarg said:

    smbios changed to macbookpro13,1

    DSDT.aml.zip

    USE VoodooI2C.kext and VoodooI2CHID.kext

    Share this post


    Link to post
    Share on other sites
    5 hours ago, MaLd0n said:

    DSDT.aml.zip 28.64 kB · 1 download

    USE VoodooI2C.kext and VoodooI2CHID.kext

    Hello MaLd0n

    problem solved 

    trackpad is full functional and now IOReg shows my ACPI ID 🤘

    thank you so much for your support and patching my DSDT

    Share this post


    Link to post
    Share on other sites
    4 minutes ago, Rezarg said:

    problem solved 

    enjoy

    Share this post


    Link to post
    Share on other sites
    On 1/22/2020 at 4:54 PM, strangeralot said:

    Hello everyone.

     

    I put Mojave 10.14.6 in a Dell Inspiron 15 3000, i15-3583-D3X. Everything is ok, except the multi gesture of trackpad. I dont have scroll and two fingers touch (right button) in touchpad. Someone know what I should have do to enable at least the scroll?

     

    Mald0n help me in another topic and instructed me to update my kexts, I used kext updater and just the VirtualSMC and WhateverGreen I can't update because the last versions of this kexts bugs the boot.

     

    Mald0n even told me to exclude ps2mouse and ps2trackpad kexts, because my touchpad are I2C ( my APCI ID is TPD0). I did, without sucess.

     

    I did this guide of this topic, whitout success too.

     

    Here my Send me.

     

    Please, someone can help me?

     

    Thank you.

    Hello, I have a laptop like that too, could you please send the links to download the OS and the software used? If it is possible to explain, I thank you very much!

    I already did a hackintosh on my old Lenovo, but several things didn't work and I couldn't get all the kexts.

    Thank you!

    Share this post


    Link to post
    Share on other sites

    Hello,

    I Have a Samsung X20 (NP350XAA-KFWBR) with ATMEL3000.

    I could´t find the strings:

    1. ACPI ID

    2. APIC Pin Number

    3. Ensure I2C Serial bus name are correctly labelled in DSDT.

    Even looking in Windows. It seems to have different name entries.

    spacer.png

    Could anyone give me a hand?
    Thanks.
     

    I´m runing Mojave 10.14.6
    Aida report: https://drive.google.com/open?id=1z5VVoD9iuDCv5EiLarMrWxgdkoi7223L
    Send-me.zip:  https://drive.google.com/open?id=1oeDZ3urcJLIkI17ZSMRPDiG7Sf_BGG8X

    Share this post


    Link to post
    Share on other sites

    Hello guys

    I installed the mojave hackintosh on my ideapad 330, I'm using the latest versions of VoodooI2C.kext and VoodooI2CHID.kext to my trackpad and VoodooPS2Controller.kext to my keyboard, and the pinning with https://www.olarila.com/ topic / 5644-enable-i2c-trackpad-voodooi2c-not-a-guide-not-really /

    but my trackpad ends up working like a usb mouse, and the worst part, it keeps "jumping" when I use it.

    I'm doing tests here and I noticed that, no matter what PIN I put on GpioInt SBFG, it doesn't change it behavior.

    And I also noticed that the "jumps" only happen when the notebook is using the battery, it doesn't happen when it's plugged in.

    could someone help me? 

    Clover and send me
    https://drive.google.com/open?id=18oElJPUOLud2Lg5DW8EZS3tiOvggwDK9

    Share this post


    Link to post
    Share on other sites

    Had someone managed to make it work Samsung X20 (NP350XAA-KFWBR) ?

    I made all the procedures but no way.

    Even the pinout is the same as in the example.

     

     

    Já responderam antes, desculpe.

    Edited by Avenger-RP

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    ×
    ×
    • Create New...