Jump to content
MaLd0n

VirtualSMC — SMC Emulator

Recommended Posts

Ok. got it.


One question. Do we gain anything from building ourselves rather than using the "ready ones" ? Like speed ,stability etc.

Share this post


Link to post
Share on other sites

Is this a replacement for FakeSMC? And which sensors do what?

yes, use it instead fakesmc


is a new project, some sensors missing

Share this post


Link to post
Share on other sites

is virtualSMC has temperature sensors support for Vega based card?

and are there list of features virtualSMC vs fakeSMC?

thank you

Share this post


Link to post
Share on other sites

 

Hi,

Thanks for your support.

I changed from FakeSMC to VirtualSMC.

It works without problems.

However, I looked at the kernel log and found it.

kernel: (kernel) VirtualSMC: efend @ failed to find valid status (800000000000000, 8), VirtualSMC EFI module is broken


Can I ignore this?

Share this post


Link to post
Share on other sites



Hi,

Thanks for your support.

I changed from FakeSMC to VirtualSMC.

It works without problems.

However, I looked at the kernel log and found it.

kernel: (kernel) VirtualSMC: efend @ failed to find valid status (800000000000000, 8), VirtualSMC EFI module is broken


Can I ignore this?

yes, ignore, but report it for dev, he solve it in next releases

Share this post


Link to post
Share on other sites

Is anyone using PCG Tools on a Mac through an emulator? If so, how easy/hard is it to set it up?


Is it as simple as installing something like VirtualBox or do I then need to install Windows on top of/within VirtualBox?

Share this post


Link to post
Share on other sites

[ref]MaLd0n[/ref],

is there any tutorial or special requirement to install virtualsmc on Olarila hackintosh? i tried to install virtualsmc using hackintool and remove fakesmc, but unable to boot and stuck on AppleLMUController:: getSMCProvider Error: Wait for AppleSMC

Share this post


Link to post
Share on other sites

[ref]aryaone[/ref], just put kexts in clover/kexts/other

Share this post


Link to post
Share on other sites

[ref]aryaone[/ref], just put kexts in clover/kexts/other

 

i already tried to put kexts in clover/kexts/other, but resulting error in getsmcprovider

then i try to choose "boot with injected kext" on clover, and its booting well and all the sensor working, but the trouble now is my sound is gone (it's working well before)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...