Jump to content
barfusti

High Sierra Dell Laptop

Recommended Posts

Hello everyone,


I would like to install a fully working hackintosh as much as possible to my pc. I am a super noob, I need learning in time but actually I need expert hands to find my ways.


I am trying to find guides, tutorials etc. to find my way, but even if they are so simple, I don't know how to do things. There are always saying like patch this , use this id ... but I don't know how to patch them, how to use that id.


Now I am writing this message from a high Sierra build, maybe the latest one. It seems somethings work. For example my trackpad is working in its' way but I cannot see the settings in system settings because it says there is no one. I can't touch the click or pointer speed is too low for me. I tried the find trackpad.prefpane I found one I replaced it ... nothing changed for example


I don't know if my nullcpu or stuff for cpus are working. I am afraid to make a harm to my pc I can't afford any other one in years :)


I learned Geforce GTx 1050ti is not working, it is ok because I use mackintosh to surf internet watching videos and stuff like that. I am playing steam games on windows 10. Wifi card is not working it is ok I connected through cable.


I made iMessage work but when I changed my smbios to macbook 14,3 for example my USB ports stopped working and I can't find a way. I choose MacBook Air 6,2 and it solved but does it matter for example?


There are things I know there are lots of things I don't know. So I need help. I attach my Windows Aida64 report and Clover f4 acpi tables.


Can someone here help me after looking this and guide me to run this system full as much as possible with kexts dsdts and necessary stuff


thank you all in advance

ACPI.zip

ReportAida64.txt.zip

Link to comment
Share on other sites

  • Administrators

Hello everyone,


I would like to install a fully working hackintosh as much as possible to my pc. I am a super noob, I need learning in time but actually I need expert hands to find my ways.


I am trying to find guides, tutorials etc. to find my way, but even if they are so simple, I don't know how to do things. There are always saying like patch this , use this id ... but I don't know how to patch them, how to use that id.


Now I am writing this message from a high Sierra build, maybe the latest one. It seems somethings work. For example my trackpad is working in its' way but I cannot see the settings in system settings because it says there is no one. I can't touch the click or pointer speed is too low for me. I tried the find trackpad.prefpane I found one I replaced it ... nothing changed for example


I don't know if my nullcpu or stuff for cpus are working. I am afraid to make a harm to my pc I can't afford any other one in years :)


I learned Geforce GTx 1050ti is not working, it is ok because I use mackintosh to surf internet watching videos and stuff like that. I am playing steam games on windows 10. Wifi card is not working it is ok I connected through cable.


I made iMessage work but when I changed my smbios to macbook 14,3 for example my USB ports stopped working and I can't find a way. I choose MacBook Air 6,2 and it solved but does it matter for example?


There are things I know there are lots of things I don't know. So I need help. I attach my Windows Aida64 report and Clover f4 acpi tables.


Can someone here help me after looking this and guide me to run this system full as much as possible with kexts dsdts and necessary stuff


thank you all in advance

runn app and send me files

http://Olarila.com/files/Utils/RunMe.app.zip

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

  • Administrators

Thank you for showing interest to my topic @MaLd0n


Here is the result you asked for.

Extract original tables with F4 key in clover boot screen, send me folder clover/acpi/origin

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

  • Administrators

So is there any news for me Mr MaLd0n, can you check the specs ?

CLOVER.zip

for disable DGPU check my tutorial, u dont need disable 10 devices, only one.

http://Olarila.com/forum/viewtopic.php?f=50&t=6257

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

Thanks for replying @MaLd0n


I want to ask some more questions. I hope I don't bother you with my noob questions.


First of all , I want to make a clean install again. So if I put the Clover folder you provided is it ok? Can I make the installation perfectly? What do I need for that? Which kexts according to my system? If I just disable my DPGU do I have to do anything else ? For battery, trackpad preferences, smbios, or any stuff I need?


Trying to learn but most of the time it is tricky. Thanks again for providing me that Clover folder. You are the most helpful person in entire community.

Link to comment
Share on other sites

  • Administrators

first check wehat device ur DGPU use, i add in DSDT

the others we chek after

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

Mr MaLd0n, I deleted the EFI/CLOVER folder and paste the one you uploaded for me. Now I can't boot system it says while flashing :


IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0


For DPGU, I check device manager in Windows 10. I have a Nvidia Geforce GTX 1050 ti as the post you sent for the tutorial . It has the same

PCIROOT....

ACPI(SB)#....

so I didn't do any modify , I just paste the SSDT-DPGU.aml to my EFI/CLOVER/ACPI/DSDT/Patched folder

Nvidialocationpaths.jpg.7c16d7492ecdc8d4be75b4752850ac0a.jpg

Link to comment
Share on other sites

  • Administrators

For DPGU, I check device manager in Windows 10. I have a Nvidia Geforce GTX 1050 ti as the post you sent for the tutorial . It has the same

DSDT.disable dgpu.zip

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

DSDT.disable dgpu.zip

 

So I placed the " DSDT.aml " to EFI/Clover/Acpi/Patched and problem is the same.

After that I deleted " SSDT- DGPU.aml " and nothing changed.


At the first flashing messages it is written more things but after that it keeps flashing the message :


IOConsoleUsers: time(0) 0>0, lin0, llk1

IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0


I have a 128 gb ssd+ 1 tb hdd on my laptop. Ssd part is installed with windows. I formatted 500 gb of 1 tb as HFS journaled and rest is Exfat.


In boot options , ssd is the first if I want to boot into os x I push F12 and choose that disk.


My clover bootloader is not the latest. Mine is 4380 but latest one is 4414 if I am not mistaken. Is it ok to download latest package and run it? In customize menu, what should I choose in this scenario?


Mr MaLd0n, I appreciate all of the things you have done thanks a lot really.

Link to comment
Share on other sites

  • Administrators

use IntelGFX 0x12345678 for install


for post install just need disable dgpu and correct ig-platform-id, intect intel and intelgfx if need

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

Mr MaLd0n , with SSDT-DPGU.aml I can't make any progress. I changed it with the one I had before and now it seems working.


I installed high Sierra again with the knowledge and files you provided to me , so far so good except for audio part.


There is no output or input devices in system preferences>audio. Here is the list I have done so far:


* I changed my layout id to 13 and 56 in config.plist, Neither of them is working. Generally they say layout id 13 for this alc256 codec.

I have AppleAlc.kext + lilu.kext + shiki.kext in /EFI/CLOVER/Kexts/Other


I downloaded RehabMan's codeccommander.kext , I tried this kext in both EFI/CLOVER/Kexts/Other and Library/Extensions and no success.

I rebuild the cache within terminal.


I added SSDT-256.aml to CLOVER/ACPI/Patched


Ioregistryexplorer gives me the result I attached when I type "hdef"


I have untouched AppleHDA.kext , there is no kext like VoodooHDA, HDADisabler ... I just installed the system and trying to keep it clean as much as possible


Is there any way you can suggest to me, otherwise I go with VoodooHDA package to solve this. Which one do you prefer, AppleAlc or Voodoohda?


Thanks again , I also attached the SSDT-NVIDIA-DISABLE.aml if you want to check out. Thanks for all you have done for me.

iohdef.thumb.png.988d8737075b850d21fc2b7288d3830c.png

SSDT-NVIDIA-Disable.aml.zip

Link to comment
Share on other sites

  • Administrators

u tell PEG0/PEGP, i think DGPU use other device

what is this?

Device (NVDA)
   {
       Name (_HID, "NVDA0000")  // _HID: Hardware ID
       Method (_INI, 0, NotSerialized)  // _INI: Initialize
       {
           If (CondRefOf (\_SB.PCI0.RP05.PEGP._OFF))
           {
               \_SB.PCI0.RP05.PEGP._OFF ()
           }

           If (CondRefOf (\_SB.PCI0.RP05.PXSX._OFF))
           {
               \_SB.PCI0.RP05.PXSX._OFF ()
           }

           If (CondRefOf (\_SB.PCI0.PEG0.PEGP._OFF))
           {
               \_SB.PCI0.PEG0.PEGP._OFF ()
           }

           If (CondRefOf (\_SB.PCI0.PEG0.PXSX._OFF))
           {
               \_SB.PCI0.PEG0.PXSX._OFF ()
           }

           If (CondRefOf (\_SB.PCI0.PEG0.PXSX._OFF))
           {
               \_SB.PCI0.RP01.PXSX._OFF ()
           }

           If (CondRefOf (\_SB.PCI0.PEGR.GFX0._OFF))
           {
               \_SB.PCI0.PEGR.GFX0._OFF ()
           }

           If (CondRefOf (\_SB.PCI0.PEGP.DGFX._OFF))
           {
               \_SB.PCI0.PEGP.DGFX._OFF ()
           }

           If (CondRefOf (\_SB.PCI0.RP01.PXSX._OFF))
           {
               \_SB.PCI0.RP01.PXSX._OFF ()
           }

           If (CondRefOf (\_SB.PCI0.RP01.PEGP._OFF))
           {
               \_SB.PCI0.RP01.PEGP._OFF ()
           }
       }
   }

 

disable 9 devices, u need disable only 1, just need check a correct device

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

Mr MaLd0nProbably I don't know how to check it. I followed the guide and it says something about windows part and as you see in the post #10 I attached that picture. I don't know how to check other ways. When I have time, I can check the devices one by one so maybe I can solve that.


Can you suggest me anyway for audio? What can I do and where to look for misnaming graphic and audio devices? It is possible that my Audio codec is different? Thanks for being interested until now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...