Jump to content
lukascaska

Notebook A515-51g-58vh

Recommended Posts

Olá pessoal, pesquisei no fórum sobre a possibilidade de instalar o High Sierra no meu notebook (A515-51g-58vh) e vi que é possível, mas o tópico em questão não havia muitas explicações, vocês poderiam me ajudar com os primeiros passos para realizar a instalação?

Muito obrigado desde já.

Link to comment
Share on other sites

  • Administrators
Olá pessoal, pesquisei no fórum sobre a possibilidade de instalar o High Sierra no meu notebook (A515-51g-58vh) e vi que é possível, mas o tópico em questão não havia muitas explicações, vocês poderiam me ajudar com os primeiros passos para realizar a instalação?

Muito obrigado desde já.

qual é o hardware?


faz download da Olarila High Sierra

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Link to comment
Share on other sites

qual é o hardware?


faz download da Olarila High Sierra

 

Olá MaLd0N, obrigado pela resposta, o hardware é o seguinte:

i5-7200

8GB memória

GeForce 940MX com 2gb (que acho que não vai dar pra usar)

1TB HD


Já baixei a versão High Sierra 10.13.3 da Olarila


Já realizei a instalação com o Sierra no meu desktop algumas vezes com sucesso, porém no notebook nunca fiz, por isso preciso de ajuda, to com medo de ficar tentando métodos diferentes sendo que existe um maneira certa.

Link to comment
Share on other sites

 

Olá, estou travado na parte de modificar o arquivo SSDT_DGPU.aml

Modifiquei o arquivo com as informações certas e coloquei na pasta ACPI/patched do Clover do Pendrive.

porém ele para de carregar após alguns minutos e mostra o seguinte erro:

Window Server Service only ran for 0 seconds



Que pesquisando descobri que tem a ver com a minha placa de vídeo.


Estou fazendo algo de errado?

Link to comment
Share on other sites

Cara, continua dando a mesma coisa, vou explicar o que fiz mais detalhado pra ver se pulei alguma coisa.


Primeiro baixei a imagem do seu tópico da versão HighSierra.

Coloquei em um penDrive com o win32DiskImager.

Tentei dar Boot a primeira vez e deu o seguinte erro:Service only ran fro 0 seconds. Pushing respawn out by 10 seconds.

procurei soluções e encontrei sobre a mudança no arquivo SSDT_DGPU.aml e colocar na pasta ACPI/patched do Clover do penDrive.

Alterei de acordo com a informação obtida no Gerenciamento de dispositivos. (verifiquei mil vez e o nome ta certo e o resto do arquivo de acordo com o modelo kkk )

E novamente o mesmo erro.

Fiz o que vc me pediu, coloquei o patch e coloquei o FakeID para 0x12345678 e ainda persiste :/

Link to comment
Share on other sites

  • Administrators
Cara, continua dando a mesma coisa, vou explicar o que fiz mais detalhado pra ver se pulei alguma coisa.


Primeiro baixei a imagem do seu tópico da versão HighSierra.

Coloquei em um penDrive com o win32DiskImager.

Tentei dar Boot a primeira vez e deu o seguinte erro:Service only ran fro 0 seconds. Pushing respawn out by 10 seconds.

procurei soluções e encontrei sobre a mudança no arquivo SSDT_DGPU.aml e colocar na pasta ACPI/patched do Clover do penDrive.

Alterei de acordo com a informação obtida no Gerenciamento de dispositivos. (verifiquei mil vez e o nome ta certo e o resto do arquivo de acordo com o modelo kkk )

E novamente o mesmo erro.

Fiz o que vc me pediu, coloquei o patch e coloquei o FakeID para 0x12345678 e ainda persiste :/

vc adicionou a ssdt no sorted order?

qual o device de vídeo?

me envia a pasta clover que vc está usando

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Link to comment
Share on other sites

  • Administrators
Parece que to perdido mesmo kkk


Device de vídeo: GeForce 940mx com 2GB

Nome no Gerenciador de Dispositivos: _SB.PCI0.RP01.PXSX

No tutorial tinha visto para aplicar o arquivo somente no ACPI/patched, mas acho que coloquei de forma errada.

em anexo a pasta clover.

usa a pasta do meu tópico, tá usando uma pasta toda zoada

CLOVER.zip

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Link to comment
Share on other sites

Cara deu certo! aquela pasta devia ta zuada mesmo kkkk

consegui dar boot e realizar a instalação do sistema mais o clover, alterei a pasta dele pela do tutorial e agora ta com os seguintes itens não funcionando:

-Teclado e mousepad

-Audio

-porta HDMI do note

-Ethernet


por enquanto notei isso, to procurando as soluções pra cada um

Link to comment
Share on other sites

Updates até agora.


-HDMI(video) funcionando

-Teclado do Notebook funcionando

-Ethernet funcionando (vou usar um adaptador que sei que é compatível para Wifi)

-Webcam funcionando


Erros principais até agora:

-Trackpad não funciona

Fiz o procedimento de patch necessário para a kext VoodooI2C e fiz o teclado rodar tranquilo, o trackpad ainda não, to usando um mouse externo.

-Audio

Não tentei ainda, vou começar essa parte depois do trackpad

Link to comment
Share on other sites

-Audio funcionando normalmente!

-Bateira funcionando nativamente com as kexts presentes na pasta que você me passou :D:D

-falta só o trackpad mesmo, que não é tão importante kkk


usei esse driver para meu adaptador Wifi (dwa-123 D1)


http://www.edimax.com/edimax/download/download/data/edimax/global/download/for_home/wireless_adapters/wireless_adapters_n150/ew-7811un

Link to comment
Share on other sites

  • Administrators
-Audio funcionando normalmente!

-Bateira funcionando nativamente com as kexts presentes na pasta que você me passou :D:D

-falta só o trackpad mesmo, que não é tão importante kkk


usei esse driver para meu adaptador Wifi (dwa-123 D1)


http://www.edimax.com/edimax/download/download/data/edimax/global/download/for_home/wireless_adapters/wireless_adapters_n150/ew-7811un

roda nosso app e me envia os arquivos

RunMe.app.zip

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Link to comment
Share on other sites

Valeu pela resposta:) infelizmente não deu ainda, provavelmente pq meu teclado e trackpad usam I2C e não PS2.

Tentei aplicar o patch na DSDT citado no tutorial do VoodooI2C (patch windows 10) na pasta clover só que não está dísponível.

na DSDT antiga foi possível, e foi o que fez o teclado funcionar

algum palpite?

Link to comment
Share on other sites

Consegui!!

Meu teclado funcionou com o VoodooPS2Controller e o trackpad com o voodooI2CHID+VoodooI2C sem o VoodooELAN


Funcionando perfeito.


Bug's percebidos até agora.


-Áudio no Hdmi não funcionando

-Wifi interna (que já era esperado, tudo bem)


Queria já agradecer pela ajuda gigantesca do MaLd0n que conhece tudo disso aqui, encontrei seu nome ajudando em todos os fóruns de Hackintosh, mesmo antes quando fiz no desktop.

Obrigado mesmo!

Link to comment
Share on other sites

Valeu pela resposta:) infelizmente não deu ainda, provavelmente pq meu teclado e trackpad usam I2C e não PS2.

Tentei aplicar o patch na DSDT citado no tutorial do VoodooI2C (patch windows 10) na pasta clover só que não está dísponível.

na DSDT antiga foi possível, e foi o que fez o teclado funcionar

algum palpite?

Se seu teclado e trackpad usam I2C deveria funcionar apenas com VoodooI2C.

btn_donate_SM.gif
Link to comment
Share on other sites

Concordo com você, achei esquisito tbm, pretendo fazer mais alguns teste pra ver se consigo deixar somente o PS2.

Hoje trabalhei com meu Hack durante o dia inteiro ( dev Front-End ) e estou com os seguintes bugs, buscando soluções :geek:

-Entrada de fone de ouvido chiando de vez em quando

-Telas de brilho do teclado não funcionam

-Audio HDMI


acho que de essencial é isso mesmo.

um bug extra que não tem muita relevância mas achei curioso é o modo com a tampa fechada, ele funciona normalmente!

mas quando abro a tampa do notebook a tela ta totalmente sem brilho, da pra ver que ta funcionando e que as janelas estão lá, mas sem brilho algum.

Estou procurando as soluções e a medida que for encontrando vou relatando aqui.

No final do processo pretendo fazer um guia do que eu (leia-se vocês do fórum) fiz pra fazer tudo funcionar.

Link to comment
Share on other sites

Ainda sem avanço no áudio do fone de ouvido, vi que a forma certa de instalar o audio do meu note é usando o AppleHDAPatcher, mas quando rodo o app ele da erro e não completa o processo, alguma ideia do porquê?


o erro é o seguinte:

mkdir: /Users/lsales/Desktop/AppleHDA-280.12-ALC255: File exists

Copying kext

Copying zlib files

Adding data entry AFGLowPowerState to plist

Adding integer entry CodecID to plist

Adding data entry ConfigData to plist

Adding integer entry FuncGroup to plist

Adding integer entry LayoutID to plist

OSX version 10.13.3 detected

Default target codec: 10ec0255 detected.

Patching AppleHDA codec 11d41984 with 10ec0255

3 codec range comparison(s) to patch

Patching range comparison 11d41983

Patching range comparison 10ec0884

Patching range comparison 10ec0261

Unexpected codec range match count: 2 (6 expected)

Aborting with AppleHDA NOT patched

Copying README file

Creating zip file

Done.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...