Jump to content

Hackintosh Guide - Sierra / High Sierra / Mojave / Catalina on Sky/Kaby/CoffeeLake Notebooks with Clover Bootloader

Recommended Posts

  • Replies 760
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Donation with Paypal https://tinyurl.com/r7fchn9 Donation with Stripe https://tinyurl.com/2ssnydn6 Donation with BuyMeaCoffee https://tinyurl.com/bvsbpf6e Donation with BTC 33HeGCuCSh4t

use ssdt Olarila SSDT-OLARILA.aml.zip

Posted Images

primetrack, did you try to boot in safe mood, sometimes it will solve the panic


how can i boot in safe mode?


primetrack, i think is a framebuffer problem, use our updated clover folder, if need use intelgfx 0x12345678


so i only have to download updated clover? where can i find it?

Link to post
Share on other sites

Thanks MaLd0n for your answer! I'll try to use that above files to see what happens! :shock:

Added in 21 minutes 17 seconds:




(39.66 KiB) Downloaded 1 time

check here

Arquivo Comprimido.zip

(487.37 KiB) Downloaded 1 time

With these files I have no more sound and the keyboard has stopped working i using now a external one! No keyboard backlight, no functioning trackpad.

Link to post
Share on other sites

Unread post by MaLd0n » 17 Jan 2019, 01:30

free1975yuly, kexts work good in asus


I had to modify your DSDT for make audio working (patched with Mirone's stuff) and patch skylake instant wake. Now I'll try with EmilyDinesh DSDT patch for that keyboard backlight. That is the reason for I'm upset for: keyboard backlights!

Added in 39 minutes 41 seconds:

And with those kexts sended by you the keyboard and trackpad won't work. Installed them in S/L/E with kext utility, after removing voodoops2.controller.

Added in 29 minutes 28 seconds:

Another weird thing this time: I have now backlights working on the keyboard but I cannot use it! I mean I cannot type on it (using an external one) and that trackpad won't work. I think these malfunction are because I didn't installed voodooi2c controllers??

Link to post
Share on other sites

Finally I have almost working here: keyboard backlight solved after editing DSDT from MaLdOn, sound also after DSDT editing and sound patching with Mirone's HDA patcher (included in olarilla mojave image). I had to remove some kext, install others..still no working HDMI (I don't use) and trackpad (I don't use also). Now I have mojave 10.14.2., updated also after some little work.

Link to post
Share on other sites

I tried but is give me the errors! Tried to delete that error, no luck.

Added in 3 minutes 13 seconds:

And jarvis (under mirone' s audio patcher tell me that I have more than one audio definition in DSDT, that I don't know how to delete them.

To have audio I had to modify DSDT created by MaLdOn with audio definition=2 patch.


Link to post
Share on other sites

I have done that in Clover before HDA patching. No sound until HDA patching and DSDT.

Added in 1 minute 58 seconds:

I will install your DSDT but there are allready more than one audio definition: one is HDEF, one BOD3 or something like that.

Added in 2 minutes 18 seconds:

With your DSDT should I let untouched that HDA kext? And I have renames in Clover (osi to xoxi, gfx to igpu...should I remove them, because you have done it in DSDT?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

:cap-Please Disable Your ADBlocker-:cap