Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
MaLd0n

Hackintosh Guide - Sierra / High Sierra / Mojave / Catalina on Serie 100/200/300/400 with Clover Bootloader

Recommended Posts

Pressed F4 in Clover and got one (1) DSDT.aml file and fifteen (15) SSDT*.aml files, all of them different in size. Disassembled them with iasl and got sixteen (16) new *.dsl files in total. All of these go through maciasl with no errors. How can I tell what patches need to be applied? Most patches appear to be for laptops, this is a desktop system (my profile), running 17F77 with the following issues: (a) it goes to sleep ok but when I press a key to wake it reboots, problem report says "Kernel Extensions in backtrace: com.apple.iokit.IOGraphicsFamily(519.19)" and (b) I would like to investigate if I can make it burn less than 55 watts at idle.

Share this post


Link to post
Share on other sites

you can send me a complete clover file ?


Thank you

is a same folder, just update kexts and usb patch in config.plist

Share this post


Link to post
Share on other sites

Pressed F4 in Clover and got one (1) DSDT.aml file and fifteen (15) SSDT*.aml files, all of them different in size. Disassembled them with iasl and got sixteen (16) new *.dsl files in total. All of these go through maciasl with no errors. How can I tell what patches need to be applied? Most patches appear to be for laptops, this is a desktop system (my profile), running 17F77 with the following issues: (a) it goes to sleep ok but when I press a key to wake it reboots, problem report says "Kernel Extensions in backtrace: com.apple.iokit.IOGraphicsFamily(519.19)" and (b) I would like to investigate if I can make it burn less than 55 watts at idle.

???

Share this post


Link to post
Share on other sites

Good afternoon MaLd0n.


Starting with a fresh install and used F4 to extract the clean DSDT and used your post clover folder for booting into the system and ran the runme.app without doing anything else. I wanted to optimize this system to 100%. I have not found a DSDT that matches the GA Z270MX-Gaming 5 as of yet. Thanks for the help in advance and will donate to you for your time with this.

Send me iMACs-iPro-2.zip

Share this post


Link to post
Share on other sites

Good afternoon MaLd0n.


Starting with a fresh install and used F4 to extract the clean DSDT and used your post clover folder for booting into the system and ran the runme.app without doing anything else. I wanted to optimize this system to 100%. I have not found a DSDT that matches the GA Z270MX-Gaming 5 as of yet. Thanks for the help in advance and will donate to you for your time with this.

CLOVER.zip

USE LAST CLOVER VERSION

Replca, reboot and send me new SEND_ME

Share this post


Link to post
Share on other sites

Thanks for that. I have installed the latest clover and replaced the clover folder. Ran the runme.app and here is the latest file. Thanks for the help so far.

delete old SEND_ME in ur desktop, and run app again, just to avoid merge

Share this post


Link to post
Share on other sites

I did notice that it was named the same after running it again. Here is the new one for you. Thanks.

looks good

u don't need more apfs_patched.efi, the ApfsDriverLoader.efi+AptioMemoryFix.efi solve it now, loads apfs.efi from ApfsContainer located on block device.

2007381028_MaLd0n2018-06-17s17_04_11.png.81f609057f699065171e308da09d1d38.png

Share this post


Link to post
Share on other sites

Thanks man, I will remove that one. Everything shows in PCI list and all is well on my end. Sending a donation your way bro! Thank you for the help on this one.

Share this post


Link to post
Share on other sites

Thanks man, I will remove that one. Everything shows in PCI list and all is well on my end. Sending a donation your way bro! Thank you for the help on this one.

Welcome, bro!

Enjoy!

Share this post


Link to post
Share on other sites

so what should I use from now on my computer?

if i usually update clover regularly and i have two systems mounted ssd hsierra hdd mojave


Captura_de_pantalla_2018_06_22_a_las_14_01_32.png

Share this post


Link to post
Share on other sites

so what should I use from now on my computer?

if i usually update clover regularly and i have two systems mounted ssd hsierra hdd mojave

use it, but remove csm driver, just use it if u don't have other option

Captura_de_pantalla_2018_06_22_a_las_14_01_32.thumb.png.3bf120dfe364360d83b96afb691c96fa.png

Share this post


Link to post
Share on other sites

Hi MaLd0n


I got the Z370 running quickly from a CCC clone of 10.13.5

I booted using a DSDT from a very similar board but It would be great if you could do the same edits to my vanilla DSDT taken from pressing F4 in clover.

I've attached the send me files.

System so far is:

Z370 Gaming K3 (Bios F6)

i7 8700k

intel UHD Graphics


Thanks a lot

PlexiPuter

Send me PlexiPuter Z370.zip

Share this post


Link to post
Share on other sites

Hi MaLd0n


I got the Z370 running quickly from a CCC clone of 10.13.5

I booted using a DSDT from a very similar board but It would be great if you could do the same edits to my vanilla DSDT taken from pressing F4 in clover.

I've attached the send me files.

System so far is:

Z370 Gaming K3 (Bios F6)

i7 8700k

intel UHD Graphics


Thanks a lot

PlexiPuter

CLOVER.zip

use last clover version

Share this post


Link to post
Share on other sites

Thanks MaLd0n!


I've now updated to Clover_v2.4k_r4515.

What does the com.apple.driver.AppleMikeyDriver Patch Assertions patch do?

Not added that yet as I don't know what it does.

I've got rid of XHCI-200-series-injector.kext as well.

I'm using USB 10.13.4+ by PMHeart patch instead of raise port limit.


I can recommend this board!

Everything seems to be working, even on internal graphics!

Sleep is even working with no Radeon RX560 installed, and also HDMI audio is working OTB using internal graphics.

I've got the audio set to 7 in both the DSDT and in config.plist/Devices.

It's doing 43 FPS in Cinebench and 27200 in Geekbench.

I'm not using any overclock.

This is on 10.13.5 installed onto a mechanical HDD then cloned over to an SSD so it's still running HFS+J.

(My method of keeping it HFS)

Share this post


Link to post
Share on other sites

Thanks MaLd0n!


I've now updated to Clover_v2.4k_r4515.

What does the com.apple.driver.AppleMikeyDriver Patch Assertions patch do?

Not added that yet as I don't know what it does.

I've got rid of XHCI-200-series-injector.kext as well.

I'm using USB 10.13.4+ by PMHeart patch instead of raise port limit.


I can recommend this board!

Everything seems to be working, even on internal graphics!

Sleep is even working with no Radeon RX560 installed, and also HDMI audio is working OTB using internal graphics.

I've got the audio set to 7 in both the DSDT and in config.plist/Devices.

It's doing 43 FPS in Cinebench and 27200 in Geekbench.

I'm not using any overclock.

This is on 10.13.5 installed onto a mechanical HDD then cloned over to an SSD so it's still running HFS+J.

(My method of keeping it HFS)

com.apple.driver.AppleMikeyDriver avoid logs in boot ;)


Just Enjoy!

Share this post


Link to post
Share on other sites

Where can I find all these patches?

 

-FIX ERRORS AND WARNINGS
-HPET
-SATA
-DMAC
-SLPB
-DARWIN
-XHCI
-PLUGIN TYPE
-HDAS to HDEF
-HDEF
-RTC
-IRQs
-SBUS
-MIKEY
-BUS1
-MCHC
-ALS0
-SHUTDOWN
-LAN
-USBX
-PMCR
-IMEI
-EC
-PNLF
-GFX0
-HDAU
-NVME
-ASMEDIA USB 1
-ASMEDIA USB 2
-ARPT
-INTELHDGRAPHICS

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...