Jump to content
FCU4ever

Black screen with SMBIOS MacBookPro8,2 [Asus G73SW]

Recommended Posts

Hello everyone,


I've a problem to do the Native Power Management patch to get the PC awake after sleep.


I want to use the MacBookPro8,2 SMBIOS because this MacBookPro comes close to my CPU.


When I'm trying to generate the MacBookPro8,2 SMBIOS with CloverConfigurator and inject Nvidia and boot with nvda_drv=1 and add the board-id to GraphicsDevicePolicy.kext. After reboot the apple logo shows up, loader start loading, at the end I get a black screen.


The strange part is that when I generate the MacBookPro8,2 SMBIOS with CloverConfigurator and ONLY change the productname to iMac13,2, inject Nvidia and boot with nvda_drv=1 and add the board-id to GraphicsDevicePolicy.kext. After reboot the mac boots well. But I can't run ./ssdtPRGen.sh because the board-ID mismatch model.


The problem is that there isn't a SMBIOS with SandyBridge and Nvidia.


Hope someone can help me!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...