Jump to content
garcia de moura

Divergências sobre um mesmo erro

Recommended Posts

Saudações!


Depois de um tempo afastado do fórum e do meu hackintosh, estou voltando à ativa e resolvi instalar o Yosemite 10.10.

Tenho dois SSDs Corsair de 120 giga cada e estou tentando fazer dual boot com o Windows 8.1 e Yosemite, cada um em um SSD.

o Windows já está rodando em um SSD normalmente e depois de ler os processos mais comuns de intalação do OS X, resolvi tentar

o método unishit + multishit por ser, teoricamente, o mais fácil. Pra começar, reinstalei o Mavericks (em um SSD dedicado) pra poder começar o processo do zero.


Baixei o unishit e o multishit, além do instalador do Yosemite por um torrent. Usei um pen drive de 8 giga pra criar o pendrive bootável conforme as instruções do tonycrap (pen drive de 1 partição em MBR e o SSD em GUID) etc... com o instalador criado, ele boota com GraphicsEnabler=Yes e a instalação inicia.

Abro o Disk Utility, formato o SSD do Mavericks (lá sei foi...) e prossigo. Quando o carregamento dos arquivos começa,

a instalação tem previsão de término em 12 minutos. A transferência dos arquivos do pendrive começa e passados alguns

instantes, a atividade da CPU pára e aparece a seguinte mensagem:


"An error occurred while extracting files from the package Essentials.pkg", ou seja, não consegue extrair o Essentials.pkg!

Aí toca instalar o Mavericks tuuuudo de novo. Fiz isso algumas vezes trocando de pendrive, dessa vez tentei com um de 16 giga. Mesma coisa. Comprei um NOVO de 16 giga também. Idem. Baixei o Instalador direto da AppStore. Outra vez o mesmo problema... Nessa altura do

campeonato, já particionei o SSD e deixei o Mavericks rodando pra poder fazer os testes em outra partição. De novo, de novo...

baixei outra vez o instalador do Yosemite da AppStore e nenhum progresso. Fiz várias pesquisas com os seguintes resultados:


Hipóteses levantadas:

-o pen drive DEVE ser de 8 giga. Embora já tivesse tentado com um de 8 giga, particionei os meus de 16 (2 partições de 8 giga) e não funcionou.

-formatar o pendrive em GUID, ao invés de MBR. Nada feito.

- subir a instalação com as flags -no-zpm maxmem=4096 entre outras. Nada! (http://www.tonycrapx86.com/yosemite-desktop-support/145639-error-occurred-while-extracting-files-package-essentials-pkg.html). Houve sucesso em alguns casos usando essas flags, trocando de pendrive ou baixando novamente o instalador, mas não é unânime.

- na comunidade de discussão da Apple, recomendam para esse mesmo problema (no caso de Mac original, obviamente), usar memórias originais da Apple. Também não unânime (https://discussions.apple.com/thread/6602734). Recomendam - e para alguns resolveu - refazer o processo.


-Houve relatos de sucesso quando se troca memória não-Apple, pelas originais, mas não é o meu caso. (http://forum.crucial.com/t5/Crucial-memory-for-Mac-systems/Fresh-install-of-Yosemite-crashing-constantly-with-Crucial/td-p/161043)

-Relatos sobre a impossibilidade de instalar o Yosemite em SSD não Apple. A empresa teria bloqueado a instalação com assinatura de kext (entendi isso)

do recurso TRIM. Só faltou eu tentar instalá-lo em um HD SATA normal. Tentarei fazer isso.


Estou baixando o pendrive bootável do forum e ver se consigo instalar, mas o download vai levar pelo menos mais dois dias.

O que posso tentar:

-instalar pelo pendrive que estou baixando do fórum (para descartar problema do unishit);

-instalar o Yosemite em um HD SATA (não SSD).


Pergunto: alguém passou por esse problema? Seria verdade que a Apple está boicotando os Hackintoshes através de bloqueio de instalação por hardware?

Obrigado!

Gigabyte GA-B75M-D3H UEFI

Corsair 1X4 Gb 1600 Mhz Vengeance

Intel i3 3240

Fonte Corsair CX 600

EVGA NVidia GT 630 2Gb

Storage SSD Corsair Force GT 120 Gb

Samsung Syncmaster P2370

OS X macOS Sierra 10.12.6 Olarila Version

MacBook Pro 2008, sim: 2008!

Link to comment
Share on other sites

tenho instalado o yosemite num ssd não apple com trim ativado.



apple está usando kexts assinadas, mas não tem nada de boicote. existem muitas kexts osx86 que estão na lista de exceções.

Se quando viaja faz o que quer, quando viajar, não leve a mulher

.

Core I5 750 12gb 500gb GTX 760(macOS 10.12, macOS 10.12.Xb, Win10)

Pentium 4 3.06 2gb 80gb fx5200 (10.5.8)

iMac G3 400Mhz 512mb Rage 8Mb (10.4.11)


Save OSX86... Don't Let Tony win!

Link to comment
Share on other sites

Então...

Baixei novamente o instalador da AppStore;

Comprei OUTRO pendrive NOVO;

Tentei instalar em um HD SATA II

Não deu certo...

Removi todos os periféricos, inclusive uma memória...

Esse hack tá difícil...

Gigabyte GA-B75M-D3H UEFI

Corsair 1X4 Gb 1600 Mhz Vengeance

Intel i3 3240

Fonte Corsair CX 600

EVGA NVidia GT 630 2Gb

Storage SSD Corsair Force GT 120 Gb

Samsung Syncmaster P2370

OS X macOS Sierra 10.12.6 Olarila Version

MacBook Pro 2008, sim: 2008!

Link to comment
Share on other sites

Não damos suporte a ferramentas do tonycrap, tenta perguntar no fórum dele.


Ou usa um dos métodos aqui do fórum.

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Valeu, Perna!

Eu já tinha tentado fazer pelo vosso método, mas enrosquei na hora de instalar o Clover e o Chameleon no pendrive pra dar boot, não consegui fazer,

mas vou tentar de novo e vou conseguir SIM.

Hackintosh é isso: é paciência, dedicação e muito estudo. Não é pros fracos.

Com um pouco mais de calma vai dar certo. É que estou fazendo isso no serviço kkkkkk já viu, né? Não posso baixar

o pendrive pronto porque o proxy da intranet aqui não permite. Mas vou conseguir...

Abraço!

Gigabyte GA-B75M-D3H UEFI

Corsair 1X4 Gb 1600 Mhz Vengeance

Intel i3 3240

Fonte Corsair CX 600

EVGA NVidia GT 630 2Gb

Storage SSD Corsair Force GT 120 Gb

Samsung Syncmaster P2370

OS X macOS Sierra 10.12.6 Olarila Version

MacBook Pro 2008, sim: 2008!

Link to comment
Share on other sites

Bom...

Não sei aqui é o local adequado pra discutir isso, se não for, favor mover o tópico. Pode ser que o assunto saia

do escopo Discussão Geral. :shock:


Entrei de férias agora e estou tendo tempo disponível pra tentar instalar o Yosemite na minha máquina. Estou com o Mavericks agora.

Conforme relatado há posts anteriores, tentei o método unishit + multishit, porém todas as vezes sem exceção fiquei preso num erro de extração

de arquivos extensão .pkg. Tentei de tudo, sem êxito.


É inegável que o Clover é melhor, embora seja bem diferente (pra não dizer mais difícil) mas vale a pena investir algumas horas nele.

Minhas experiências com Clover e Yosemite estão se resumindo em alguns problemas. Tentei o método do fórum http://Olarila.com/forum/viewtopic.php?f=3&t=4630 mas

não deu certo. Foram tantos percalços que nem lembro direito quais foram, mas uma me deixou intrigado:

Fiz todo o processo como indicado e consegui botar o pendrive e iniciar a instalação. A barra de progresso da instalação inicia com tempo restante

de 12 minutos para previsão do término e vai percorrendo... mas não acaba! Fica preso em "about 1 second"... fica ali indefinidamente... Receoso de que o problema

fosse relativo ao SSD, tentei em um HD SATA e deu na mesma. Então percebi (durante outras tentativas) que o LED da CPU fica apagado o tempo todo! :!: , ou seja,

é como se o Clover estivesse retirando os arquivos do pendrive mas não estivesse escrevendo eles no HD. Inclusive, quando entro no Mavericks e vejo o HD (ou SSD) ele está vazio,

a ponto do sistema operacional perguntar se quero usar este disco no Time Machine...

Tentei outras alternativas de outras fontes, também com o Clover, por exemplo, do blog francês

www.hackintosh-montreal.com, que traz algumas soluções bem legais, automatizadas, mas também não funcionou. Deu no mesmo problema.

Se fosse problema de kext SATA ou coisa parecida, teria que dar o erro "still wait root device", certo? Se não for, o que pode ser?

Alguma configuração ou driver errado no Clover. Segui os passos no fórum e outras fontes, instalando o Clover para placa-mãe UEFI com os

drivers 64 bit indicados, inicio com -v kext-dev-mode=1 e não vai.

Outra coisa: comprei e instalei uma placa wi-fi TP-Link DWN4800 que é reconhecida nativamente e funciona muito bem, mas por alguns instantes, depois ela pára,

então tenho que desligá-la e reconectar novamente, mas isso eu vejo depois que estiver com o Yosemite no ar.

Obrigado.

Gigabyte GA-B75M-D3H UEFI

Corsair 1X4 Gb 1600 Mhz Vengeance

Intel i3 3240

Fonte Corsair CX 600

EVGA NVidia GT 630 2Gb

Storage SSD Corsair Force GT 120 Gb

Samsung Syncmaster P2370

OS X macOS Sierra 10.12.6 Olarila Version

MacBook Pro 2008, sim: 2008!

Link to comment
Share on other sites

Baixei o Install OS X Yosemite mais duas vezes, fiz o procedimento do Fórum e nada. :shock:

Pesquisando por aí vi algo sobre a Apple usar assinatura de kext para controlar o hardware utilizado (tesourar hardware não Apple):

http://translate.googleusercontent.com/translate_c?depth=1&hl=pt-BR&prev=search&rurl=translate.google.com.br&sl=en&u=http://www.cindori.org/trim-enabler-and-yosemite/&usg=ALkJrhgcdiDJRUdsN8ehPb7VqpZ14lFT8Q


também aqui (inclusive o mesmo erro que tenho) http://www.google.com.br/url?sa=t&rct=j&q=&esrc=s&source=web&cd=2&cad=rja&uact=8&ved=0CCUQFjAB&url=http%3A%2F%2Fsuperuser.com%2Fquestions%2F830191%2Ferror-installing-mac-os-x-10-10-yosemite-on-a-512gb-ssd-in-my-2010-macbook&ei=-tGmVMy1JYKggwTkmoL4DA&usg=AFQjCNGhxLBDX3lDrRQFyyxKtS499zg-Cg&sig2=qrpOiIvpjw23PaysUpRhfg


Aqui, no post #125, o usuário conseguiu, após usar um TRIM Enabler.pkg http://www.insanelymac.com/forum/topic/301138-new-usb-installer-os-x-yosemite-chameleon-r2510-v5/page-7


Realmente parece que a teoria tem fundamento, pois não é possível que após eu ter baixado tantas vezes o instalador e trocado de pendrive tantas vezes, o problema seja corrupção do arquivo...


Neste post aqui do fórum http://Olarila.com/forum/viewtopic.php?f=35&t=5008

diz "O argumento de boot (kernel flag) kext-dev-mode=1 permite que kexts não assinadas (ou com assinatura inválida) sejam incluídas no kernelcache, ou seja, para poder instalar kexts modificadas ou sem assinatura em /System/Library/Extensions é necessário usar esse argumento. Se você colocar essas kexts na pasta EFI/CLOVER/kexts/10.10 o parâmetro não será necessário.". Surgiu uma dúvida:


Esse argumento já está presente no Clover, aliás, estou usando o v2k r3113. As kexts que tenho em EFI/CLOVER/kexts/10.10 são FakeSMC e NullCPUPowerManagement. Se eu for usar alguma kext de TRIM, devo

colocá-la em EFI/CLOVER/kexts/10.10, certo? Se eu conseguir finalizar a instalação devo depois instalar essa mesma kext de TRIM em S/L/E usando o Kext Wizard, por exemplo e depois não precisa mais

usar esse argumento?

Gigabyte GA-B75M-D3H UEFI

Corsair 1X4 Gb 1600 Mhz Vengeance

Intel i3 3240

Fonte Corsair CX 600

EVGA NVidia GT 630 2Gb

Storage SSD Corsair Force GT 120 Gb

Samsung Syncmaster P2370

OS X macOS Sierra 10.12.6 Olarila Version

MacBook Pro 2008, sim: 2008!

Link to comment
Share on other sites

olá


qualquer kext que não tenha assinatura válida e instalada no sistema .. precisa sempre do argumento


se estiverem em clover/10.10 não é necessário o argumento pois as kext são injetadas no cache sempre no boot..


mas nem todas as kext funcionam ai..


bom hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

Obrigado, artur-pt pelo esclarecimento!

Então, posso tentar colocar a IOAHCIFamily.kext em EFI/CLOVER/10.10 e botar com o argumento?

Vou tentar.

Tks!

Gigabyte GA-B75M-D3H UEFI

Corsair 1X4 Gb 1600 Mhz Vengeance

Intel i3 3240

Fonte Corsair CX 600

EVGA NVidia GT 630 2Gb

Storage SSD Corsair Force GT 120 Gb

Samsung Syncmaster P2370

OS X macOS Sierra 10.12.6 Olarila Version

MacBook Pro 2008, sim: 2008!

Link to comment
Share on other sites

Faiô...

Coloquei a IOAHCIFamilily.kext em EFI/CLOVER/10.10, bootei com o argumento, mas deu o mesmo erro.

Gigabyte GA-B75M-D3H UEFI

Corsair 1X4 Gb 1600 Mhz Vengeance

Intel i3 3240

Fonte Corsair CX 600

EVGA NVidia GT 630 2Gb

Storage SSD Corsair Force GT 120 Gb

Samsung Syncmaster P2370

OS X macOS Sierra 10.12.6 Olarila Version

MacBook Pro 2008, sim: 2008!

Link to comment
Share on other sites

Estou fazendo uma visita ao meu pai e a internet dele é de 10 Mb. Aproveitei pra trazer meu hackintosh e tentar de novo.

Baixei o OS X Install da AppStore, montei o instalador e novamente deu o erro Essentials.pkg. Deve ser algum outro problema que não arquivo corrompido.

Vou aproveitar a internet aqui pra tentar baixar novamente o pendrive do forum.

Cruzando os dedos....

Gigabyte GA-B75M-D3H UEFI

Corsair 1X4 Gb 1600 Mhz Vengeance

Intel i3 3240

Fonte Corsair CX 600

EVGA NVidia GT 630 2Gb

Storage SSD Corsair Force GT 120 Gb

Samsung Syncmaster P2370

OS X macOS Sierra 10.12.6 Olarila Version

MacBook Pro 2008, sim: 2008!

Link to comment
Share on other sites

EBAAAAA!!!!!

1375027116_ScreenShot2015-01-17at18_38_50.png.942302d8c49f19bec60c4db04c7cd1f9.png


Depois de muuuuito quebrar a cabeça, consegui!!!!!

Realmente não era corrupção de arquivo.

Depois de incontáveis downloads, baixei o pendrive pronto aqui do fórum e gravei o RAW pelo Windows. Bootei e deu o mesmo erro;

Desliguei tudo o que não era necessário pra instalação (gravador de DVD, outros HD, placa wi-fi), tentei instalar e não deu. Lendo mais um pouco,

vi outras pessoas que tiveram problema semelhante o obtiveram êxito deixando apenas um pente de memória.

Fiz isso, deixei só um pente, tentei e não deu. Comecei a ler a etiqueta do pente e vi que ela é 1600 Mhz. Dei uma olhada no site da Gigabyte e vi que a minha mobo

roda em 1333, 1066 e 1600 Mhz, mas na BIOS aparece 1333 e essa opção fica desabilitada. Comecei fuçar e tentei mudar isso pra 1600. Até onde li, minha mobo não dá

suporte a overclock, mas ativei as opções que "dariam" overclock (eu acho) e pra minha surpresa consegui instalar!!

Estou sem um pendrive pra fazer uns prints da BIOS pra mostrar o que mudei nela.


Depois de tudo instalado, pus o segundo pente (2 de 4Gb) comecei ter kernel panic um atrás do outro com tudo (Safari, Firefox, isso e aquilo), até que coisas muito estranhas começaram acontecer,

por exemplo, arquivos com extensão .dmg ficaram irreconhecíveis, não instalavam de jeito nenhum, vários reboots do nada etc, etc...

Reinstalei o sistema sem formatar só com um pente e voltou ao normal, não tive mais nenhum kernel panic.

Realmente o problema é relacionado de alguma forma com a memória.

Agora reinstalei o segundo pente em outro slot e por enquanto tá normal.

Obrigado pela atenção de todos. Pode marcar o tópico como resolvido.


Antes, só uma dúvida:


Minha placa gráfica é um EVGA NVidia GT 630 de 2 Giga DDR5, mas o sistema reconhece só 1 giga (vide imagem). A questão é:

Só está rodando 1 giga ou só está mostrando 1 giga mas pode estar funcionando os 2? Há algum teste pra confirmar??

Quando executo o LaunchPad ou outros recursos, o monitor mostra a imagem meio em "câmera lenta", não tão lenta, não sei se me expressei bem. Dá uns "lags".


EDITANDO>>

Li isto: http://Olarila.com/forum/viewtopic.php?f=3&t=3014 e fiz o procedimento para Clover e consegui isto:

1757177115_Voila_Capture2015-01-18_11-02-44_PM.thumb.png.2ba6062113ef47580dab5c1e1f5e34c5.png

porém, continua mostrando 1 Giga. O que fiz de errado? Os 2048 Mb não deveriam estar em outro lugar? Coloque junto com Graphics mas fica aí embaixo!


EDITANDO 2 >>

Após fazer isso dá esse problema no boot:

20150118_232759_resized.jpg.bcb7bb03cd7d3c0acf205bc730ade611.jpg

 


Resumindo: volto o config.plist original da partição EFI do pendrive baixado do fórum. Surge a questão: há problema em usar esse config.plist "pelado", ou

é necessário tentar editá-lo?

ou

Mais uma vez obrigado!!!

Gigabyte GA-B75M-D3H UEFI

Corsair 1X4 Gb 1600 Mhz Vengeance

Intel i3 3240

Fonte Corsair CX 600

EVGA NVidia GT 630 2Gb

Storage SSD Corsair Force GT 120 Gb

Samsung Syncmaster P2370

OS X macOS Sierra 10.12.6 Olarila Version

MacBook Pro 2008, sim: 2008!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...