Jump to content
matuskela

Mavericks scrambled screen

Recommended Posts

Sorry for my english.


I managed to install 10.9.5 on my laptop mavericks, is even with graphics acceleration, but the screen is with artifacts as image attachment.


My settings:


Lenovo notebook G400s

Processor i7 - 3612 QM - 2:10 GHZ

8G memory

T 1 HD

Video Resolution: 1366x768


I do not know what else to do, just need it to work. :cry:

foto.JPG.c46d943f6511704a5795d9712070298e.JPG

Link to comment
Share on other sites

hello


i have the same problem in my lenovo and exist also with other laptops


solution


use ig-platform-id 4


and this patch

 

capri.png.a7d1c3ad672ff4ad03919c02328de306.png

 

that is for clover


with chameleon must do that find and replace in kext (hexfriend)


good hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

hello


should boot


-f


to rebuild caches


and the platform is 0x01660004


maybe the kext is loaded is the one in caches..


good hack

 


Many thanks Artur-pt! :D:D:D:D:D:D:D


Follow their guidelines, as I am using chameleon, needed just reinstall the patched kext (preferably with kext utility or similar) and use the following flags:


GraphicsEnabler = Yes = No IGPEnabler IGPlatformID = 01660004


I'm posting a kext corrected again (correct me if I can not do this) to anyone who has problems with artifacts on the screen in Lenovo G400s.

Just missing test the HDMI output, I'll do that when I get home and post the results.

Thank you dear Artur-pt!

AppleIntelFramebufferCapri.kext.zip

Link to comment
Share on other sites

hdmi only using fb=3. and with 3 you will have that problem.

Se quando viaja faz o que quer, quando viajar, não leve a mulher

.

Core I5 750 12gb 500gb GTX 760(macOS 10.12, macOS 10.12.Xb, Win10)

Pentium 4 3.06 2gb 80gb fx5200 (10.5.8)

iMac G3 400Mhz 512mb Rage 8Mb (10.4.11)


Save OSX86... Don't Let Tony win!

Link to comment
Share on other sites

Hi Mendietinha!


I'm using the flag IGPlatformID = 01660003 would it? 1080p HDMI port works but the notebook screen is with artifacts , if I change from 1080p to 720p both work without the artifacts but at 720p , but for this to work I have to go there in the display settings , putting 1080p and return 720p as soon linking it comes with independent video configuration artifacts. Remembering that I am using the original kext AppleIntelFramebufferCapri unedited in Yousemite .

Link to comment
Share on other sites

no need edits. you have what you have with fb=3. artifacts. must deal with it if you need hdmi.

Se quando viaja faz o que quer, quando viajar, não leve a mulher

.

Core I5 750 12gb 500gb GTX 760(macOS 10.12, macOS 10.12.Xb, Win10)

Pentium 4 3.06 2gb 80gb fx5200 (10.5.8)

iMac G3 400Mhz 512mb Rage 8Mb (10.4.11)


Save OSX86... Don't Let Tony win!

Link to comment
Share on other sites

There is a problem of damaging the graphics card in notebook using with the artifacts ? For the hdmi port will not be with the artifacts and the notebook screen I'll close and work with only the TV to HDMI . It can damage something the being with artifacts on display closed ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...