Jump to content
pernacabeluda

Chameleon e OS X 10.10

Recommended Posts

Atualizado:


A versão atual do Chameleon já faz boot do Yosemite

http://www.insanelymac.com/forum/files/file/59-chameleon-22-svn/


Para fazer a instalação você pode usar o mesmo método que usando o Clover

http://Olarila.com/forum/viewtopic.php?f=35&t=4630


Coloque o arquivo Preboot.dmg na pasta /Extra

Preboot.dmg.zip

Coloque o arquivo kernel na pasta /System/Library/Kernels (extraia de /System/Installation/Packages/Essentials.pkg usando o Pacifist 3.2.14)


Atualizado: a partir da versão r2394 o Chameleon suporta lzvn, então o passo abaixo não é necessário

Depois de instalar, para poder usar kernelcache edite o arquivo bootcaches.plist na pasta /usr/standalone e mude lzvn para lzss

            <key>Preferred Compression</key>
           <string>lzss</string>

Adicione kext-dev-mode=1 em Kernel Flags (/Extra/org.chameleon.Boot.plist)

	<key>Kernel Flags</key>
<string>kext-dev-mode=1</string>

Rode este comando para reconstruir o kernelcache

sudo kextcache -prelinked-kernel

Fonte

http://www.insanelymac.com/forum/topic/231075-chameleon-22svn-official-pkg-installer-binaries/?p=2028035


Os arquivos abaixo não são mais necessários com a versão atual do Chameleon

boot.zip

org.chameleon.Boot.plist

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Kernel</key>
<string>/System/Library/Kernels/kernel</string>
<key>Kernel Flags</key>
<string>-f -v kext-dev-mode=1</string>
</dict>
</plist>

Fonte

http://www.insanelymac.com/forum/topic/231075-chameleon-22svn-official-pkg-installer-binaries/?p=2028653

Edited by Guest

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

a v2 do installer está fazendo quase tudo automático.

Se quando viaja faz o que quer, quando viajar, não leve a mulher

.

Core I5 750 12gb 500gb GTX 760(macOS 10.12, macOS 10.12.Xb, Win10)

Pentium 4 3.06 2gb 80gb fx5200 (10.5.8)

iMac G3 400Mhz 512mb Rage 8Mb (10.4.11)


Save OSX86... Don't Let Tony win!

Link to comment
Share on other sites

Finalmente, o clover e eu não temos uma relação de amizade tão grande, mas agora finalmente consegui instalar o 10.10, to lidando com uns bugs, mas é coisa de software beta e dá para relevar. Obrigado perna pela dica.

 

Eu sofria do mesmo mal Andre... não me dou muito bem com o Clover mas agora está tudo funcionando direito com o Chameleon! :)

Link to comment
Share on other sites

Sempre usei o Chameleon mas na última atualização do Mavericks decidi experimentar o Clover e me adaptei muito bem. Boot mais rápido e em UEFI - estou satisfeito! Mas fico feliz pelo Chameleon agora dar boot também no Yosemite...

Por falar nisso, alguém já tem notícias do Java para usar no Yosemite?

MB: GA Z87M-D3H, 4 SATA 3Gb/s + 08 USB 2.0 e 04 USB 3.0

CPU: Intel Core i3 3,4Ghz

HD: SATA 1Tb Sansung

Graphics: Intel HD Graphics 4400

Audio ALC 892

Ethernet RTL8168E

Keyboard & Magic Mouse bluetooth

Link to comment
Share on other sites

Sempre usei o Chameleon mas na última atualização do Mavericks decidi experimentar o Clover e me adaptei muito bem. Boot mais rápido e em UEFI - estou satisfeito! Mas fico feliz pelo Chameleon agora dar boot também no Yosemite...

Por falar nisso, alguém já tem notícias do Java para usar no Yosemite?

 

Eu não sei se seria o mesmo Java, mas eu instalei o Dreamweaver por causa do curso que faço e ele me redirecionou para uma página da Apple que me forneceu um link pra download do Java pro Yosemite...

Link to comment
Share on other sites

Conseguí instalar aquí na minha máquina usando o método do Chameleon!

O problema é q antes eu tentei instalar usando o método do Clover e não sei como desinstalar o clover! toda vez tenho q dar boot do pendrive! eu tenho audio via usb mas por algum motivo o youtube trava o vídeo e sem audio, vcs sabem o q pode ser?! Minha máquina é a mesma da assinatura!

Gigabyte GA B75M-D2V / Core i5 - 3330 ivy bridge 3.0Ghz / EVGA GTX750 ti FTW 2gb / 8Gb DDR3 Markvision / 500Gb Hdd Seagate - SSD kingstone 60gb / USB Mouse & Keyboard
Link to comment
Share on other sites

Você poderia postar isso em outro tópico, já que este é sobre os procedimentos para quem quer instalar sem usar esses "utilitários", ou seja, entender o que está fazendo.

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Não sei, é o primeiro caso que vejo.


Você não teria removido ou renomeado o arquivo kernel de dentro do Preboot, né?


Tenta copiar esse arquivo para a raiz do pen drive e digita apenas "kernel" no prompt do Chameleon.

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Eu usei o que está anexado no primeiro post, mas o oficial mais recente já tem suporte ao 10.10


http://www.insanelymac.com/forum/files/file/59-chameleon-22-svn/


Tenta remover o Preboot e colocar o kernel na raiz do pen drive renomeado para mach_kernel, ou na pasta /System/Library/Kernels (nesse caso com nome kernel mesmo) e coloca as kexts básicas (FakeSMC, NullCPUPowerManagement e outras que você precise) em /Extra/Extensions.

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Já consegui instalar o yosemite, há algumas semanas, mas estou com 2 problemas estranhos e não sei como resolver:

1º instalo o kext voodooHda, reinicio o pc e fico com som, na 2ª vez que reinicio já não tenho som novamente, apesar da kext permanecer na pasta extensions mas não detecta nenhum dispositivo de saída. será que tenho de colocar alguma flag no boot?


2º altero a foto de fundo da secretária, mas quando reinicio vai buscar sempre a mesma, a padrão.


o meu som é onboard de uma Asus P7P55D.


obrigado


Cumprimentos


João Paulo Martins

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...