Jump to content
tosbaha

Dell 5437 Sound and stability issues

Recommended Posts

Hi,

I am trying to mke this laptop run Mavericks. I am jumping out from one forum to another but still can't fix the problems I have.


1. System freezes. It happened couple of times

a. Inserting USB device (not always)

b. Running IoReg

c. During Web browsing

d. No apparent reason.

I just can’t find the real reason.


2. Audio doesn't work. It works if I use patched dsdt and VoodoHDA but sound quality is not good and I hear noise from headphones.


I am really tired. Last night I stayed till 5 AM to find solutions which I couldn't. I really want to fix it. I have attached everything I have for now


https://dl.dropboxusercontent.com/u/157304/My%20Files.zip


Extracted Folder

This folder has my original unpatched DSDT and SSDT tables extracted from Windows with AIDA


Patched Folder

This folder has my patched files that I use right now. It has patched DSDT, SSDT.aml which is created with ssdtPRGEN and SSDT-*.aml files. I have patched SSDT-4.aml for brightness.


Codec Folder

This folder has my CodecDump.zip extracted with Ubuntu. I have also added converted txt and svg files.


Settings Folder

This folder has my IoReg created with DSDT=no option and chameleon settings.


My Specs

-------------

Computer: DELL Inspiron 5437

CPU: Intel Core i5-4200U (Haswell ULT, C0/D0)

2300 MHz (23.00x100.0) @ 1596 MHz (16.00x99.8)

Motherboard: DELL 0DM7G0

Chipset: Intel Lynx Point-LP (Premium)

Memory: 4096 MBytes @ 798 MHz, 11.0-11-11-28

- 4096 MB PC12800 DDR3 SDRAM - Hynix (Hyundai) HMT451S6AFR8A-PB

Graphics: Intel Haswell-MB ULT GT2 - Integrated Graphics Controller [C0/D0] [DELL]

Intel HD Graphics 4600, 1820430 KB

Drive: WDC WD10JPVX-75JC3T0, 976.8 GB, Serial ATA 6Gb/s @ 6Gb/s

Drive: TSSTcorp DVD+-RW SU-208CB, DVD+R DL

Sound: ALC283

Network: Atheros Communications AR9565 Wireless Network Adapter

Network: RealTek RTL8106E-US


I am really tired and I am sorry if I sound whining. I just want to fix this laptop. I will really appreciate if you give me a hand. Thanks very much.

Link to comment
Share on other sites

Hi,

I am trying to mke this laptop run Mavericks. I am jumping out from one forum to another but still can't fix the problems I have.


1. System freezes. It happened couple of times

a. Inserting USB device (not always)

b. Running IoReg

c. During Web browsing

d. No apparent reason.

I just can’t find the real reason.


2. Audio doesn't work. It works if I use patched dsdt and VoodoHDA but sound quality is not good and I hear noise from headphones.


I am really tired. Last night I stayed till 5 AM to find solutions which I couldn't. I really want to fix it. I have attached everything I have for now


https://dl.dropboxusercontent.com/u/157304/My%20Files.zip


Extracted Folder

This folder has my original unpatched DSDT and SSDT tables extracted from Windows with AIDA


Patched Folder

This folder has my patched files that I use right now. It has patched DSDT, SSDT.aml which is created with ssdtPRGEN and SSDT-*.aml files. I have patched SSDT-4.aml for brightness.


Codec Folder

This folder has my CodecDump.zip extracted with Ubuntu. I have also added converted txt and svg files.


Settings Folder

This folder has my IoReg created with DSDT=no option and chameleon settings.


My Specs

-------------

Computer: DELL Inspiron 5437

CPU: Intel Core i5-4200U (Haswell ULT, C0/D0)

2300 MHz (23.00x100.0) @ 1596 MHz (16.00x99.8)

Motherboard: DELL 0DM7G0

Chipset: Intel Lynx Point-LP (Premium)

Memory: 4096 MBytes @ 798 MHz, 11.0-11-11-28

- 4096 MB PC12800 DDR3 SDRAM - Hynix (Hyundai) HMT451S6AFR8A-PB

Graphics: Intel Haswell-MB ULT GT2 - Integrated Graphics Controller [C0/D0] [DELL]

Intel HD Graphics 4600, 1820430 KB

Drive: WDC WD10JPVX-75JC3T0, 976.8 GB, Serial ATA 6Gb/s @ 6Gb/s

Drive: TSSTcorp DVD+-RW SU-208CB, DVD+R DL

Sound: ALC283

Network: Atheros Communications AR9565 Wireless Network Adapter

Network: RealTek RTL8106E-US


I am really tired and I am sorry if I sound whining. I just want to fix this laptop. I will really appreciate if you give me a hand. Thanks very much.

Delete VoodooHDA.kext, HDAEnable.kext, HDAdisble.kext if available. Install kext AppleHDA, copy DSDT.aml to Extra then reboot. Feedback hope this help

Archive.zip

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...