Jump to content
fariel23

Asus N53SN-SZ139V Help me out please!!

Recommended Posts

Hello guys i having a few issue with my laptop running OSX LION GM. Hoop u guys can help!!


I have the following system:


Asus N53SN-SZ139V


Intel Core i7 2630QM - 2,0GHz - Intel HM65 chip-set


6 GB DDR3 @ 1333MHZ


120GB SSD OCZ VERTEX 2


NVIDIA GeForce GT 550M 2GB


Intel HD 3000


USB 3


Bootloader: Chimera 1.5.3

SMBIOS: MacBook Pro 8,1

Extras: Extensions.mkext + DSDT.aml I made it trough Aida64 in windows 7


What is working:

-Bluetooth (Sometime + when it does work cant send files or connect)

-Trackpad + Keyboard with the extension.mkext (NF key doesn't work)

-Audio Works with VoodooHDA.kext + AppleHDADisabler.kext

-Webcam Works only with CameraControl.app

-Battery Works with the VoodooBattery.kext + a modified AppleACPIPlatform.kext that i download. (NOTE: without the modified AppleACPIPlatform.kext that i download it wont work)

-LAN is working with the Lnx2Mac's RTL81xx driver within multishit 3.8.0

-Intel HD 3000 is reported working with 384MB BUT my screen is mess up greenish with artifacts, i think it needs the DSDT duallink fix: http://www.tonycrapx86.com/viewtopic.php?f=15&t=28851

But i don't now how to do it!! so at the moment aim just screensharing trough another hackingtosh.


What is NOT working:

-Nvidia GT 550M

-Atheros AR9285


So please mald0n en others user help me on this i would really appreciate it. i also would like if u can fix my buggy DSDT. i'm also including my EDID from windows.


Here you have my files + Systems info:

EDID.zip

1954249166_sysinfo.thumb.png.c5c8c1f4871e0ab6742b7bd1a526a597.png

Extra.zip

Link to comment
Share on other sites

  • Administrators

Atheros 9285

http://Olarila.com/forum/viewtopic.php?f=7&t=93


The DualLink patch is simple, like GMA950

into device name_adr 0x00020000 insert
begin
Method (_DSM, 4, NotSerialized)\n
{\n
   Store (Package (0x02)\n
       {\n
           "AAPL00,DualLink",\n
           Buffer (0x04)\n
           {\n
               0x01, 0x00, 0x00, 0x00\n
           }\n
       }, Local0)\n
   DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))\n
   Return (Local0)\n
}
end

Remember to check the address in ioreg, in the examples video is @2 (0x00020000) and wireless @1C,1 (0x001C0001).

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

thank for replying but when i do the atheros patch fix i got this error on the DSDT Editor: 5208 Error Object does not exist (DTGP)

please can u tell me how to do it step by step cause, i don't understand were to insert the code or how to patch it right. again thank u very much

Link to comment
Share on other sites

  • Administrators

Apply DTGP too

http://Olarila.com/Patches/DTGP.txt


nZIHw-QYO64

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

waaaaaouuu men u save me i did the duallink patch on osx with dsdt editor and it worked!!!!! my display work just fine (only don't have the brightness control) thank u very much oldnapalm love yaaaa

however the atheros fix did not work i must doing something wrong??? also my shutdown doesn't work i did try the patch asus shutdown but no success. again thank u for u patience!!!

please i almost there i just need help to make it happens....

Edited by Guest
Link to comment
Share on other sites

  • Administrators

Did you check in ioreg under which device the wlan is located?


Remove these kexts

AtherosFix.kext

NullCPUPowerManagement.kext

OpenHaltRestart.kext

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

  • Administrators

Re-install NullCPUPowerManagement until you have working power management.


Extensions folder or mkext is your choice.


You may need this

http://www.insanelymac.com/forum/index.php?showtopic=258611

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

  • Administrators

Just put back the kext I asked you to remove (NullCPUPowerManagement), I didn't notice you have a Sandy Bridge system.


The other 2 kexts you can remove.

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

Just put back the kext I asked you to remove (NullCPUPowerManagement), I didn't notice you have a Sandy Bridge system.


The other 2 kexts you can remove.

 

i did that but shutdown did not work + atheros.....thanks

also i dont have the AICPUPM.kext in my S/L/E mention in the link you post http://www.insanelymac.com/forum/index.php?showtopic=258611 so i dont know how to do that !! sorry for no being to smart and keep coming back at you...

Link to comment
Share on other sites

  • Administrators

Did you check if you applied the Atheros patch in the correct place?


AICPUPM = AppleIntelCPUPowerManagement


You will need to read that topic carefully to get power management working.

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

Did you check if you applied the Atheros patch in the correct place?


AICPUPM = AppleIntelCPUPowerManagement


You will need to read that topic carefully to get power management working.

 

hey my dear friend i did it! i patch the AppleIntelCPUPowerManagement but only to STEP 3 and it says successfully patched then i update kextcache en reboot at this moment i only need to do STEP 4 found http://www.insanelymac.com/forum/index.php?showtopic=253642 but i don't know how maybe u can help? thanks again. about the atheros patch i just patch it with the http://Olarila.com/Patches/Atheros%209285.txt .so i don't know how to enter my device id or how to view it.

Link to comment
Share on other sites

  • Administrators

The Atheros patch is an example, you have to look in IORegistryExplorer the correct address


wlan.png


In my case the WLAN is inside RP02@1C,1 (0x001C0001).


I also had to boot Windows and enable the wireless with Fn + F2, then it started to work in Mac OS.


Sorry, I don't have any experience with Sandy Bridge, can't help with that.

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

is it also possible to patch my dsdt to make audio work without the VoodooHDA.kext + AppleHDADisabler.kext? and also get Battery support without the VoodooBattery.kext? thanks! i notice the the bluetooth is connecting to device but no able to send files.. any suggestion? thanks again for your time!!!

Link to comment
Share on other sites

The Atheros patch is an example, you have to look in IORegistryExplorer the correct address


wlan.png


In my case the WLAN is inside RP02@1C,1 (0x001C0001).


I also had to boot Windows and enable the wireless with Fn + F2, then it started to work in Mac OS.


Sorry, I don't have any experience with Sandy Bridge, can't help with that.

 

ok buddy no prob thanks anyways u help me out alot. q: lets say i have the same wlan as then were i need to put RP02@1C,1 (0x001C0001).

Link to comment
Share on other sites

  • Administrators

Sorry, the Atheros patch was wrong, first remove it with

into method label _DSM parent_adr 0x001C0001 remove_entry

then download and apply it again

http://Olarila.com/Patches/Atheros%209285.txt


Change the values according to your ioreg (WLAN@0 and RP02@1C,1)

into device name_adr [color=#FF0000]0x00[/color] parent_adr [color=#FF0000]0x001C0001[/color] insert

 

Only DSDT patch won't make audio work, you will also need to edit AppleHDA

http://Olarila.com/forum/viewtopic.php?f=17&t=212


If you don't have a patched kext for Snow Leopard it's more complicated

http://www.projectosx.com/forum/index.php?showtopic=465


For battery info you will always need VoodooBattery (or other similar kext). You can fix DSDT to get VoodooBattery working in Lion without AppleACPIPlatform from Snow Leopard. More info in this topic

http://www.insanelymac.com/forum/index.php?s=&showtopic=181293&view=findpost&p=1736543

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

  • Administrators

It's exaclty like the one in the example (from an Asus N53JQ).


You can use the device name, just make sure the method _DSM is inserted in the correct device

into device label WLAN insert
begin
Method (_DSM, 4, NotSerialized)\n
{\n
   Store (Package (0x0C)\n
       {\n
           "AAPL,slot-name", \n
           Buffer (0x08)\n
           {\n
               "AirPort"\n
           }, \n
           "device-id", \n
           Unicode ("*"), \n
           "device_type", \n
           Buffer (0x08)\n
           {\n
               "AirPort"\n
           }, \n
           "model", \n
           Buffer (0x34)\n
           {\n
               "Atheros 9285 8802.11 b/g/n Wireless Network Adapter"\n
           }, \n
           "subsystem-id", \n
           Buffer (0x04)\n
           {\n
               0x8F, 0x00, 0x00, 0x00\n
           }, \n
           "subsystem-vendor-id", \n
           Buffer (0x04)\n
           {\n
               0x6B, 0x10, 0x00, 0x00\n
           }\n
       }, Local0)\n
   DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))\n
   Return (Local0)\n
}
end

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

It's exaclty like the one in the example (from an Asus N53JQ).


You can use the device name, just make sure the method _DSM is inserted in the correct device

into device label WLAN insert
begin
Method (_DSM, 4, NotSerialized)\n
{\n
   Store (Package (0x0C)\n
       {\n
           "AAPL,slot-name", \n
           Buffer (0x08)\n
           {\n
               "AirPort"\n
           }, \n
           "device-id", \n
           Unicode ("*"), \n
           "device_type", \n
           Buffer (0x08)\n
           {\n
               "AirPort"\n
           }, \n
           "model", \n
           Buffer (0x34)\n
           {\n
               "Atheros 9285 8802.11 b/g/n Wireless Network Adapter"\n
           }, \n
           "subsystem-id", \n
           Buffer (0x04)\n
           {\n
               0x8F, 0x00, 0x00, 0x00\n
           }, \n
           "subsystem-vendor-id", \n
           Buffer (0x04)\n
           {\n
               0x6B, 0x10, 0x00, 0x00\n
           }\n
       }, Local0)\n
   DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))\n
   Return (Local0)\n
}
end

 

can you explain what you mean by saying You can use the device name, just make sure the method _DSM is inserted in the correct device?? thank u again buddy..

when i did the dsdt patch with what u told me i was no enable to boot into the os by saying this when i booted it take long like 2mins and when it should boot to the welcome screen its stay the with a blue screen. so maybe i did something wrong but i notice that on the laptop the wifi light when on so thats a good sign so now im goin to restore the last working dsdt to boot. and wait for you.

Link to comment
Share on other sites

  • Administrators

Look at the first line, it defines where the code is inserted

into device [color=#FF0000]name_adr 0x00 parent_adr 0x001C0001[/color] insert
into device [color=#FF0000]label WLAN[/color] insert

 

Apply the patch, attach the resulting file and I will take a look.

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

sorry my friend but i dont get it can u please provide me de patch text to insert it cause i try this


into device name_adr 0x00 parent_adr 0x001C0001 insert

into device label WLAN insert

begin

Method (_DSM, 4, NotSerialized)\n

{\n

Store (Package (0x0C)\n

{\n

"AAPL,slot-name", \n

Buffer (0x08)\n

{\n

"AirPort"\n

}, \n

"device-id", \n

Unicode ("*"), \n

"device_type", \n

Buffer (0x08)\n

{\n

"AirPort"\n

}, \n

"model", \n

Buffer (0x34)\n

{\n

"Atheros 9285 8802.11 b/g/n Wireless Network Adapter"\n

}, \n

"subsystem-id", \n

Buffer (0x04)\n

{\n

0x8F, 0x00, 0x00, 0x00\n

}, \n

"subsystem-vendor-id", \n

Buffer (0x04)\n

{\n

0x6B, 0x10, 0x00, 0x00\n

}\n

}, Local0)\n

DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))\n

Return (Local0)\n

}

end


and got something saying

2 invalind comand


so i dont know what i doing wrong?

thank u very much again for takeing your time helping me!!!!!

Link to comment
Share on other sites

  • Administrators

Use the patch in this post

http://Olarila.com/forum/viewtopic.php?f=17&t=391&p=3625#p3614


Try to understand what the patch does, it's pretty simple.

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
  • Create New...
The popup will be closed in 15 seconds...