Jump to content
TxHammer68

Problem installing Mavericks Asus Z87

Recommended Posts

Just built new PC and trying to install Mavericks for the past 2 days...

finally got past loading drivers, now stuck at kernel panic, cant capture the screen, but it says something about UiMiIntiliaze invalid number of root hub ports??

Also something about AppleHDA failed to load??


Currently runnning Kubuntu and ran the system info from your site, everything checked out as ok for my system


Ive tried some of the boot flags suggested from your site, but no luck

(cpus=1,USBBusFix=yes, npci,graphicsenabler,PCIrootuid, -x -f -v)


Any suggestions?


thanks


My setup

Mainboard-Asus Z87-plus

CPU Intel i5-4670k

GPU-ATI Radeon HD4850

SSD-Corsair 128GB

RAM-Corsair 16GB 2133 DDR3

snapshot3.thumb.png.5544af0da2e8b2da23a30a12c1cc4b0f.png

Link to comment
Share on other sites

As for more info ok


I am using Olarila OS X Mavericks USB bootable image from TPB

I have tried both chameleon and clover boot options

for the kernel panic problem i removed these

/OS X Install USB/EFI/CLOVER/kexts/10.8/GenericUSBXHCI.kext

/OS X Install USB/System/Library/Extensions/backup/IOUSBFamily.kext


that got me past the kernel panic, but stuck at waiting for root device


did some more research saw some people had success with 3rd Party AHCI kext, so i added that to the Extensions folder...but it did not work. Also tried AHCIDisk=1. npci=0x2000 and (0x3000), dsdt=null, usekernelcache=no, USBBusFix=yes


none of these options have made a difference...maybe you have something i don't know


thanks

Link to comment
Share on other sites

hello


if u remove the iousbfamilly .. how the usb works ?


xHCI Mode see how options u have in bios , try to set to auto


xHCI Hand-off / EHCI Hand-off see if are enabled


how to set the bios

 

asus-pdf.zip

 

http://www.insanelymac.com/forum/topic/290187-asus-z87-deluxe-4770k-a-guide-to-mavericks/


good hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

thanks for the info but the link u referenced requires a working mac, which i do not have...there is good info there but most are post install issues i cant even get to the installer; still stuck at waiting for root device. i know there is a fix as i have seen many people with this issue resolved, but i cant seem to get it working


as for the usb issues i got it worked it with the bios changes you suggested.


thanks i keep looking

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...