Jump to content
pernacabeluda

SMC:smcReadKeyAction ERROR

Recommended Posts

Para quem tem várias mensagens

 

SMC:smcReadKeyAction ERROR: kSMCReadKeyComm/kSMCReadKeyWithSMCComm failed for key ... (kSMCSuccess)

 

e o boot trava antes de entrar no ambiente gráfico (depois do DSMOS has arrived, normalmente com a última mensagem relacionada a IOBluetoothHCIController)

smcReadKeyAction.jpg.5a309fdd4c081572bbca2ab3228947e3.jpg

 

use o kernel flag dart=0 (remove mapper present) ou faça um drop da tabela DMAR

<key>ACPI</key>
<dict>
<key>DropTables</key>
<array>
	<dict>
		<key>Signature</key>
		<string>DMAR</string>
	</dict>
</array>
</dict>
 

Editado: o problema ocorre a partir da versão 10.8.2, então antes do Mirone postar essa solução, a sugestão para contornar o problema era usar a AppleACPIPlatform da versão anterior

AppleACPIPlatform.kext.zip

Share this post


Link to post
Share on other sites

Pra quem tem esse erro, e seu processador tem suporte a VT-D

tente dar boot com as flags, dart=0 ou DropDMAR=Yes.

em algumas placas Asus mesmo desabilitando esta função na Bios ainda da esse erro.

Share this post


Link to post
Share on other sites

Valeu, Mirone.


Eu não tenho esse tipo de hardware então não posso testar, mas só para confirmar, é necessário usar uma coisa ou outra, certo?


No caso do Chameleon, pelo visto apenas o branch do andyvand tem o DropDMAR, então quem usa o trunk deve usar dart=0?


No caso do Clover isto deve funcionar?

<key>ACPI</key>
<dict>
 <key>DropTables</key>
 <array>
   <dict>
     <key>Signature</key>
     <string>DMAR</string>
   </dict>
 </array>
</dict>

Share this post


Link to post
Share on other sites

Isso Pernacabeluda, os dois funcionam.

sim, so o Branch do Andy tem DropDMAR quem usa o trunk pode usar dart=0.

Sim, no caso do clover, isso deve funcionar estou usando dart=0 e tudo funciona bem.

edit:

<key>ACPI</key>
<dict>
 <key>DropTables</key>
 <array>
   <dict>
     <key>Signature</key>
     <string>DMAR</string>
   </dict>
 </array>
</dict>

Funcionando!!

Share this post


Link to post
Share on other sites

Ola amigos...

Estou acompanhando este topico e graças a ele estou com o mavericks 10.9.2 baixado aqui mesmo do site funcionando .....estava com o erro na hora do boot "smc readkey action error msds ksmcbadarg " com a dica de usar a flag dart=0 junto com - f consigo subir o sistema e usar, mas sempre tenho que usar esta frag, sem usa-la agora aparece o erro "panic cunable to find driver for this plataforma: \acpi\....como acertar para que este erro não aconteça mais??


Gostaria de saber se tem como incluir este comando no momento do boot -f dart=0 para não ter que sempre estar lançando ele quando entrar no sistema ...


minha maquina

gigabyte z87 , hd 1 tera, placa de video ati radeon 7700, 8 gig memoria ,


Obrigado

Share this post


Link to post
Share on other sites

Olá Artur-Pt, obrigado pelo retorno, mas você poderia indicar como eu devo incluir este comando no arquivo org.chameleon.boot.plist pois sou leigo com relação ao hack..

o comando com o qual eu consigo subir o sistema é -f dart=0

Obrigado


<?xml version="1.0" encoding="UTF-8"?>




EthernetBuiltIn

Yes

GraphicsEnabler

No

IGPEnabler

Yes

Kernel

mach_kernel

Kernel Flags

PCIRootUID=1

Legacy Logo

Yes

Timeout

5

GenerateCStates

Yes

GeneratePStates

Yes

UseKernelCache

Yes


Share this post


Link to post
Share on other sites

Ola Artur..

Deu certo irmão, valeu meu muito obrigado pela ajuda....agora sim estou com o hackhintoshi rodando do jeito que tem que ser.....


Agora vou atras das informações de como ativar o audio hdmi da placa de video pois uso uma tv samsung como monitor , no linux e windows o som sai perfeito , no hack mavericks ainda ñ consegui....


abraço

Share this post


Link to post
Share on other sites

olá artur..


seguinte amigo, rodei na rede e ñ achei nada sobre a questão acima, será que você ñ teria nenhuma sugestão sobre como habilitar o som com o cabo hdmi pela placa de video ati 7700 ?


desde já agredeço

Share this post


Link to post
Share on other sites

olá


se usares applehda, precisas de edição das propriedades para o hdmi


se usares voodoohda deve detetar auto


bom hack

Share this post


Link to post
Share on other sites

Olá Artur ...


No momento uso voodoohda, o som ou placa de som detectada é on bord, nas preferências de sistema e som não aparece nada mencionando hdmi , consigo ouvir som mas sempre pela opção on bord da placa mãe

Share this post


Link to post
Share on other sites

Oi Artur, tudo bom amigo...


Seguinte, baixei a pasta que você indicou, mas nesta pasta existem vários arquivos , como devo proceder para fazer a instalação pois até aonde eu sei tinha que colocar o arquivo voodohda.kext na pasta sistema/biblioteca/extensions, mais como tem vários arquivos dentro desta pasta que baixei como devo fazer? Você pode indicar como por favor?

Share this post


Link to post
Share on other sites

olá


deve estar numa pasta provavelmente em binaries a kext


e sim é para instalar em s/l/e


bom hack

Share this post


Link to post
Share on other sites

Positivo Artur..

Dentro da pasta baixada tem a pasta binaries e dentro desta pasta tem os arquivos abaixo, destes arquivos eu tenho que copiar somente o voodooHda.kext para s/l/e ???

Os outros posso ignorar??


getdump

voodoohda.kext

voodoohda.prefpane

voodoohdasettingsloader.app

Share this post


Link to post
Share on other sites

Boa tarde.


tenho esses logs:


May 6 10:35:56 localhost kernel[0]: SMC::smcReadKeyAction ERROR LsNM kSMCKeyNotFound(0x84) fKeyHashTable=0x0

May 6 10:35:56 localhost kernel[0]: SMC::smcGetLightshowVers ERROR: smcReadKey LsNM failed (kSMCKeyNotFound)

May 6 10:35:56 localhost kernel[0]: SMC::smcPublishLightshowVersion ERROR: smcGetLightshowVers failed (kSMCKeyNotFound)

May 6 10:35:56 localhost kernel[0]: SMC::smcInitHelper ERROR: smcPublishLightshowVersion failed (kSMCKeyNotFound)

May 6 10:35:56 localhost kernel[0]: SMC::smcInitHelper ERROR: MMIO regMap == NULL - fall back to old SMC mode



Tem alguma coisa com essa solução do tópico?

eu estou usando a flag dart=0, e o erro continua.

Share this post


Link to post
Share on other sites

Atualizei a FakeSMC como vc falou pernacabeluda.

 

fake.thumb.jpg.d8184f30ed7ed0decf618bbf47de4270.jpg

 

Outro problema, não sei se tem alguma coisa haver, de um tempo para ca, meu hack na maioria das vezes quando vou desligar ou reiniciar ele fica parado na tela cinza, estou dando boot com -v e não mostra nada.


Obrigado.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...