Jump to content
lucyinthesky

Enable QE/CI on Intel HD3000

Recommended Posts

Hi everybody, I'm new on the forum - and the topic - but i'm I've been trying my best to install Mountain Lion on my Acer Timeline and I've almost made it although some bugs I can't fix, first of all to get a full accelerated intel hd3000 graphics.

My laptop is set as a MacBook Pro 8,1. Stock kexts are loaded, the card is well recognized by system and resolution is fine but acceleration isn't working, so I'm stuck here.

What can I do? Any suggestion is welcome ;)


-------


Modello: Acer Aspire Timeline-U M3-581tg-32364G52mnkk BIOS: insyde EFI V1.08 Scheda madre: HM77 Processore: Intel i3 2367M 1,4Ghz (Sandy Bridge) Ram: 4Gb DDR3 Scheda video integrata: Intel HD3000 384MB shared memory (dev.id 8086:0116) Scheda video dedicata: Nvidia GeForce GT 640M 1Gb dedicated memory Scheda audio: ALC269 Scheda wireless: Atheros AR9287 Scheda ethernet: Broadcom BCM57780 Bootloader: Chimera 2.1 Sistema operativo: Mountain Lion 10.8.2 (iATKOS ML2)

Link to comment
Share on other sites

Are you sure all stock kexts are loaded, and not only framebuffer?


AppleIntelHD3000Graphics.kext

AppleIntelHD3000GraphicsGA.plugin

AppleIntelHD3000GraphicsGLDriver.bundle

AppleIntelHD3000GraphicsVADriver.bundle

AppleIntelSNBGraphicsFB.kext

AppleIntelSNBVA.bundle

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

hello


try this in AppleIntelSNBGraphicsFB.kext, that is in info.plist

 

AppleIntelMEIDriver

CFBundleIdentifier
com.apple.driver.AppleIntelSNBGraphicsFB
IOClass
AppleIntelMEIDriver
IOMatchCategory
IODefaultMatchCategory
IOPCIPrimaryMatch
0x1C3A8086

 

and u have this

 

IOPCIPrimaryMatch
0x1C3A8086

 

and change to this

 

IOPCIPrimaryMatch
0x1E3A8086

 

copy the kext to desktop and apply this changes


reintall the kext in s/l/e


boot


-f -v


good hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

Thank you guys, I've already tried this but I'm trying again right now, I'll let you know!


EDIT: Ok I tried and it won't boot. It says: "SNB framebuffer did not show up, unload".

I'm now trying to change SMBios.plist and boot again to see what happens..


Ps: just in case this may help, sometimes when I boot finder bar doesn't show up and comes later (e.g. when I open safari), could it possibly be related?

Thank you again!!

Edited by Guest
Link to comment
Share on other sites

Make sure you have the kexts AppleIntelHD3000Graphics* as well. I've seen iAtkos installs with missing kexts.

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...