Jump to content
RCOO

Problemas na instalação

Recommended Posts

Instalei no meu Toshiba P755-103 (http://www.toshiba.eu/discontinued-products/satellite-p755-103/ , Atheros AR9002-1NGWB WiFi card, more info - http://prntscr.com/r7pux) o iAtkos ML2. Até aqui tudo bem. Conseguir pôr a funcionar a minha HD3000 e desisti da minha Geforce GT540M.


1 - No entanto, a minha HD3000 tem imensos bugs no display, quando não uso a flag cpus=1! Há alguma forma de remover os bugs no display e poder utilizar todos os núcleos?

----------------------------------------------------

2 - Tenho de iniciar sempre com a flag UseKernelCache=no, se não obtenho o seguinte: http://postimage.org/image/6zdn9kfdr/ - em modo verbose: http://postimage.org/image/kuug43fzd/

Obtenho este problema sempre que não coloco a flag. Se ela não existir no org.chameleon.boot.plist, obtenho o erro na mesma (apesar de o facto de não existir ser equivalente ao no, não?)

----------------------------------------------------

3 - Será que tenho de usar a flag npci=0x2000? Neste momento está a ser usada, mas não sei para que é precisa...

----------------------------------------------------

4 - O meu Bluetooth também não funciona. Alguma sugestão?


Obrigado

Edited by Guest
Link to comment
Share on other sites

Olá,


observe que as dicas abaixo podem ser inúteis por ter instalado com iatkos. Recomendo começar por uma instalação limpa seguindo tutoriais do fórum.


1 - http://forge.voodooprojects.org/p/voodootscsync/downloads/


2 - http://Olarila.com/forum/viewtopic.php?f=26&t=1701


3 - Teste sem o flag, se não travar em "PCI configuration begin", não precisa.


4 - Faça uma busca pelo chipset.

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Olá,


observe que as dicas abaixo podem ser inúteis por ter instalado com iatkos. Recomendo começar por uma instalação limpa seguindo tutoriais do fórum.


1 - http://forge.voodooprojects.org/p/voodootscsync/downloads/


2 - http://Olarila.com/forum/viewtopic.php?f=26&t=1701


3 - Teste sem o flag, se não travar em "PCI configuration begin", não precisa.


4 - Faça uma busca pelo chipset.

 

A primeira solução funcionou perfeitamente!

Para a segunda solução, em vez de aplicar esse patch, instalei os kexts que estavam em /Extra/Extensions em S/L/E e deixei de precisar da bootflag!

O problema 3 também foi resolvido.

Quanto ao bluetooth, continua sem dar. O sistema nem o deteta. Pelo que sei vem junto com a minha placa de rede!

Link to comment
Share on other sites

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

 

A questão é que não tenho acesso ao device id e ao vendor id, visto q o bluetooth não é detetado na info do sistema.

Sei, através do windows que, supostamente, o VID é 0930 e o PID é 0215, mas não acho que sejam estes os ID's para o MAC OS. E instalei esse exato KEXT, mas sem o editar.

Link to comment
Share on other sites

Os IDs são os mesmos, não interessa o OS, só tem que conferir a base.


Isto parece hex

vendor: 0930 ("Toshiba Corp."), product: 0215

http://cateee.net/lkddb/web-lkddb/BT_ATH3K.html


No plist parece decimal

			<key>idProduct</key>
		<integer>533</integer>
		<key>idVendor</key>
		<integer>2352</integer>

 

Só não sei se a kext suporta esse dispositivo...

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Os IDs são os mesmos, não interessa o OS, só tem que conferir a base.


Isto parece hex

vendor: 0930 ("Toshiba Corp."), product: 0215

http://cateee.net/lkddb/web-lkddb/BT_ATH3K.html


No plist parece decimal

			<key>idProduct</key>
		<integer>533</integer>
		<key>idVendor</key>
		<integer>2352</integer>

 

Só não sei se a kext suporta esse dispositivo...

 

Qual o kext que, supostamente, funciona então?

Link to comment
Share on other sites

Se essa não funciona, editando o Info.plist com os seus IDs, supostamente nenhuma funciona, já que essa é a única.

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...