Jump to content

Multi boot em UEFI com Clover


Recommended Posts

  • Replies 272
  • Created
  • Last Reply

Top Posters In This Topic

Talvez seja problema na versão do Clover que você está usando.


A que eu usei na imagem do 10.8.4 que está na minha assinatura (r1835) funciona com a NullCPUPM em EFI/CLOVER/kexts/10.8


Questiona no tópico oficial do Clover, não adianta postar aqui.


Lembra que

Você pode criar um instalador desta forma, ou baixar um pronto da minha assinatura. Não precisa iniciar o instalador no modo UEFI, só é necessário no passo seguinte, para instalar o Clover.

Link to post
Share on other sites
Como alternativa você pode botar as kexts em /System/Library/Extensions e remover /System/Library/Caches/com.apple.kext.caches/Startup/kernelcache

 

Essa alternativa funcionou!!!

Antes de fazer o que vc indicou, eu refiz meu Pendrive, antes estava em MBR, agora está em GUID.

Dai quando eu instalei o Clover, instalei ele dessa forma:

382543657_CapturadeTela2013-08-06s20_02_10.png.9aa6f86ea4206dd675e8a1481306f6f3.png

 

Dai ele fez uma partição no Pen, chamada EFI.

Dai eu copiei a pasta EFI (da partição EFI) para a partição Clover, pois essa partição não tinha a pasta EFI.


Tem problema excluir a pasta EFI da partição EFI?

Link to post
Share on other sites
A pasta EFI só deve estar na partição EFI, tanto no pen drive (se estiver em GUID, claro) quanto no HD. Não copie para a partição do sistema (ou do pen drive) para não criar confusão.

 

Blz. há eu estou baixando a imagem do ML 10.8.4 que vc indicou no topico.

Pois acredito eu, seria uma boa opção, pois eu uso no Pen o ML 10.8.0, não sei se tem a ver, mas poderia me ajudar muito!


Uma duvida, eu restauro ela no Pen como faço aqui certo.

Dai lá no inicio do topico vc diz assim:

 

Você pode criar um instalador desta forma, ou baixar um pronto da minha assinatura. Não precisa iniciar o instalador no modo UEFI, só é necessário no passo seguinte, para instalar o Clover.

 

Então, o que isso significa? "Não precisa iniciar o instalador no modo UEFI.."

Desculpa cara, eu não entendi mesmo!



Vlw

Link to post
Share on other sites

Significa que não precisa iniciar o instalador do OS X no modo UEFI (pode ser no modo legacy). Não imagino outra forma de explicar isso.


Se você ler todo o tópico acho que vai ficar mais claro. Em certo ponto você vai precisar iniciar o Clover no modo UEFI, mas não é na instalação do OS X.

Link to post
Share on other sites
Significa que não precisa iniciar o instalador do OS X no modo UEFI (pode ser no modo legacy). Não imagino outra forma de explicar isso.


Se você ler todo o tópico acho que vai ficar mais claro. Em certo ponto você vai precisar iniciar o Clover no modo UEFI, mas não é na instalação do OS X.

 

Entendi, posso iniciar ele em ambos...muito bom cara!

Falta pouco pra baixar o OSX, ele vem em .iso?


Há testei o que vc me falou, como disse antes, deu certo, coloquei as Kexts em S/L/E, e deletei o "kernelcache". Subiu de boa, pena que o instalador só abre em Inglês. Não instalei o OS X ainda.


Acredito que vou precisar iniciar o OS X em UEFI, somente quando ele estiver instalado, que é onde eu realmente vou usar o UEFI.

Link to post
Share on other sites
Veja o link na minha assinatura, ele explica como gravar no pen drive, tem que ser pelo Windows.


É igual a este


http://Olarila.com/forum/viewtopic.php?f=26&t=1618

 

Blz, ja li!

Dai como o tuto diz, em vez de eu instalar o Chameleon, eu instalo o Clover certo.

Dai coloco a mesma pasta EFI do Pen, na partição EFI que já está no meu HD.


Está certo assim?

Link to post
Share on other sites

Inicie o sistema pelo pen drive para testar o boot UEFI.


Rode os comandos a seguir no terminal, substituindo X pelo número do HD.


Para formatar a partição EFI como FAT32

diskutil list
sudo newfs_msdos -v EFI -F 32 /dev/disk[color=#FF0000]X[/color]s1

Para montar a partição EFI

mkdir /Volumes/EFI
sudo mount_msdos /dev/disk[color=#FF0000]X[/color]s1 /Volumes/EFI

Crie a pasta EFI na partição EFI.


Copie a pasta EFI/CLOVER do pen drive para a pasta EFI da partição EFI.


Faça boot novamente pelo pen drive. No menu do Clover, entre na opção Clover Boot Options e selecione Add as UEFI boot option. A partir de agora você conseguirá iniciar sem o pen drive, pelo Clover da partição EFI, no modo UEFI.

Link to post
Share on other sites
Do outro tópico só interessa como gravar o pen drive do instalador. O restante você deve seguir este tópico.

 

Blz, cara agora to bem mais seguro instalar o OSX em UEFI.

Mas uma coisa que queria saber.....

As Kexts que eu copiei para S/L/E do Pen, na hora de instalar o SO, elas serão instaladas juntas certo?

Coloquei essas olha:

528188405_CapturadeTela2013-08-07s00_54_25.png.c35146c68d7d943241c12ff54a4f2483.png

Link to post
Share on other sites

Não, elas não serão instaladas. Por isso é melhor você usar a imagem da minha assinatura, com ela você vai conseguir fazer o primeiro boot depois de instalar o sistema no HD, ela tem as kexts na pasta do Clover. Com as kexts em /S/L/E no pen drive você não vai conseguir subir o sistema depois de instalar.

Link to post
Share on other sites
Não, elas não serão instaladas. Por isso é melhor você usar a imagem da minha assinatura, com ela você vai conseguir fazer o primeiro boot depois de instalar o sistema no HD, ela tem as kexts na pasta do Clover. Com as kexts em /S/L/E no pen drive você não vai conseguir subir o sistema depois de instalar.

 

Uffs! Cara se você não me falasse isso amanha de manhã estaria doido da vida, quase que refaço minha instalação agora!!


Vou usar agora a sua imagem, o download já terminou, e vou fazer o metodo no Windows!

Vlw


Eu peguei todas as dicas que vc me deu, de ambos os posts, e dei print nelas pra não esquecer na hora da install!

Se tiver mais alguma coisa a relembrar eu agradeço.

Link to post
Share on other sites
  • 2 weeks later...

Boa noite, estou com o chameleon 2248, tenho os so: 10.8.4, 10.9 dp5, windows 7 x64, windows 8 pro x64, windows 8 pro sem verificação de drivers. A pergunta e' no 10.9 queria fazer um teste com o clover, tenho minhas kexts n s/l/e, preciso tirar as kexts de la?

Outra coisa, vale mesmo a pena instalar isso?

Link to post
Share on other sites

Valeu perna, é que vi um monte de informação a respeito da instalação do clover, e no meu pc está tudo bl, inclusive o 10.9. Estou pensando em montar um hd so com o 10.9 e testar o clover. usei o chimera e não gostei, outra coisa relacionada aos hacks é o monte de coisa a ser lido e tempo gasto, mas enfim sempre foi assim desde o tiger.

Link to post
Share on other sites
  • 2 months later...

As imagens raw para USB têm uma partição EFI com o Clover, então você pode formatar (ou apenas montar) a partição EFI do HD (substitua X pelo número do HD)

diskutil list
sudo newfs_msdos -v EFI -F 32 /dev/disk[color=#FF0000]X[/color]s1
mkdir /Volumes/EFI
sudo mount_msdos /dev/disk[color=#FF0000]X[/color]s1 /Volumes/EFI

montar a partição EFI do USB (substitua Y pelo número do USB)

mkdir /Volumes/EFI1
sudo mount_msdos /dev/disk[color=#FF0000]Y[/color]s1 /Volumes/EFI1

e copiar a pasta EFI de EFI1 para EFI.


Então

Faça boot novamente pelo pen drive. No menu do Clover, entre na opção Clover Boot Options do drive SATA (normalmente 0x1F, 0x2) e selecione Add as UEFI boot option. A partir de agora você conseguirá iniciar sem o pen drive, pelo Clover da partição EFI, no modo UEFI.

 

Configure o config.plist de acordo com o wiki


http://clover-wiki.zetam.org/Configuration


Depois de configurar o config.plist para gerenciamento de energia, você pode remover a kext Disabler de EFI/CLOVER/kexts/10.X, bem como outras kexts que você não precise (ou que tenha instalado em /System/Library/Extensions)


http://Olarila.com/forum/viewtopic.php?f=2&t=34

Link to post
Share on other sites

Ola a todos.


Venho a dias tentando configurar o clover no meu pc, porem, todas as vezes que mexo em algo, pode ser um tema (usando o clover configurator) tenho um kp relacionado ao IOPlaformExpert.cpp não ser encontrado, estou usando o config.plist que veio pendrive de instalação do Maveriks com o seguinte conteúdo abaixo, e seu adicionar algo, sempre tenho um kp, alguém sabe o que pode estar acontecendo? Gostaria muito de usar o clover pois ele deixou minha maquina mais rápida que o chameleon mas vejo que pode ser ainda melhor.

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Boot</key>
<dict>
	<key>Timeout</key>
	<integer>1</integer>
	<key>Arguments</key>
	<string>npci=0x2000</string>
</dict>
<key>GUI</key>
<dict>
	<key>Theme</key>
	<string>metal</string>
	<key>Custom</key>
	<dict>
		<key>Entries</key>
		<array>
			<dict>
				<key>Path</key>
				<string>\EFI\BOOT\BOOTX64.efi</string>
				<key>Hidden</key>
				<true/>
			</dict>
		</array>
	</dict>
</dict>
<key>SystemParameters</key>
<dict>
	<key>InjectKexts</key>
	<true/>
</dict>
</dict>
</plist>

 

Obrigado a todos.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

:cap-Please Disable Your ADBlocker and Support Our Forum-:cap