Jump to content
TheConnactic

[Request] ASUS T101 MT Laptop.

Recommended Posts

Good evening, folks!


I would like to make a patched dsdt for my tiny shiny laptop.


My goal is to obtain native power management. If it's not possible because of my CPU, i'd just like the dsdt solves my black-screen-after-sleep issue (system wakes, but the display don't), which it's what i've got following the recipe SleepEnabler+NullCPUPowerManagement+darkwake=0+pmVersion=102+hibernatemode=0 (3 or 25 give me the headers size error when i try to wake-from-disk)


I tried some individual patches before, using the DSDT Editor, but only got KPs and frustration, since i didn't really know what i was doing.


Here is my extracted file, attached to the post. dsdt.aml.zip

 

My video card is the dreaded GMA3150 and i don't expect to have it supported at all. If sleep, wake, speedstep and built-in audio work properly without legacy kexts, i'll be more than satisfied.


Thanks a lot, really.

Link to comment
Share on other sites

First of all, thank you very much, artur-pt! :)


In fact, i'd already fine-tuned my system to the extent i could, using kexts for all my hardware, when available (unfortunately a GMA3150.kext isn't a reality yet, so i'll have to cope with native resolution only, which is good enough for me) and, until now, used this org.chameleon.plist:

 

<key>Boot Graphics</key>
<string>Yes</string>
<key>Default Partition</key>
<string>hd(0,3)</string>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>custom</string>
<key>Kernel Flags</key>
<string>darkwake=0</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Timeout</key>
<string>5</string>
<key>npci</key>
<string>0x2000</string>

 

I used also the smBIOS of a Mac Book Air 11-inch, mid 2011.


My system works to the extent i have proper resolution, all i/o devices works just fine (including the FN keys of my keyboard) and i have good battery life. But sleep/speedstep was always a problem, since, well, it's a netbook. Setting via pmset the hibernate mode to 0, i managed to get sleep partially working with NullCPUPowerManagement/SleepEnabler. Partially, because my scree does not wake up, so it's still pretty useless.


Again, thank you very much for your help! Really! Maybe now i'm one step closer to have a near-perfect netbook :) I have some questions, and since i don't want to be a pain, i'll ask all of them using this post. So let's go:


1) Using the dsdt.aml you made, can i get rid of NullCPUPowerManagement/SleepEnabler?


2) Is my smBIOS suited to my goals (native power management)? If not, can you suggest me a better choice?


3) As for the dsdt.aml, do i simply put it at the extra folder and point Chameleon to it?


4) Should i set hibernate mode back to =3 (wake from disk)?


5) The most important: if everything goes fine, should my scree finally wake up from sleep?


6) Could you, when you have time, explain me what did you do, so i won't need to be spoon fed the next time i need a dsdt?


Thank you

Link to comment
Share on other sites

hello


see this, and try apply it


http://Olarila.com/forum/viewtopic.php?f=27&t=1716


powermanagement


u smbios is wrong, use chameleon wizard and generate a new one


about u problems with sleep i don't know, but with u problems with graphics, don't think so it work


good hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

Thank you for answering again, artur-pt! :)


That smBIOS was generated with Chameleon Wizard (Mac Book Air 4,1). Why is it wrong? What would be the right choice? Thank you!


I'm already using the dsdt.aml you made for me (thank you a lot!) but i'm still not able to use AppleIntelCPUPowerManagement.kext without NullCPUIntelPowerManagement. Trying do do it results in an "unsupported CPU kernel panic". Is there a way to patch this kext for Atom CPUs, or am i stuck forever with NullCPUPowerManagement?


As for sleep, it already worked with SleepEnablerUniversal.kext, since the option generate C and P states was already enabled in my Org.Chameleon.Boot.plist. The problem is that the computer sleeps, but when i try to wake it, the display does not wake so i get a black screen. The dsdt.aml didn't solve this :(


Thank you again, artur-pt! Your help is much appreciated!

Link to comment
Share on other sites

Hello, guys! Everybody's fine?


I've been trying these days the dsdt way aiming at get rid of the most legacy kexts i can. Thanks to artur-pt and others, i've made a lot of progress. The last success i had was to patch my dsdt so my Atheros 9285 loads the AirPortAtheros40.kext, solving the wi-fi instability i had for so long. For a couple of days now, i've been unsuccessfully trying to make AppleHDA load with my ALC 269 so i can stop using VoodooHDA.


Tried some methods for AppleHDA patching i learnt here on insanelymac and elsewhere. Tried also a lot of already patched HDAs with and without dsdt edits. Finally, i tried the command line autopatch tool available at this subforum. All of them resulted in absolutely no success.


I confess that i couldn't follow one step that now i'm thinking that should be crucial to get the work done: the Linux CodecDump, since i don't use Linux (or Windows, by the way). Could it be indeed the cause of my failure? Is there any alternative around?


I'll attach my patched dsdt, so if someone has time and wan't to check it out, maybe helps me in finding something.


Thank you very much in advance!

DSDT.aml.zip

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...