Jump to content
Digitalizer

Snow Leopard 10.6.8 não inicializa no meu HP

Recommended Posts

Já faz algum tempo instalei com sucesso o Mac Lion 10.7 (DVD bootável) em meu notebook HP Pavilion DV7-3188CL, mas devido a incompatibilidade de um programa multitrack (audio) que só funciona em versões do Snow Leopard, resolvi apagar o Lion e instalar o Snow Leopard 10.6.8 (Mac.OS.X.10.6.8.Snow.Leopard.Untouched.Full.Retail.DVD), usei o CD de boot OSX86 ModCD, utilizei as flags: CPUS=1 BUSRATIO=17. Mas terminada a instalação o Snow só entra se eu bootar com o ModCD e digitando as flags anteriormente ditas. Como resolver? Abaixo algumas imagens das telas:


http://imageshack.us/a/img811/6664/20052479.jpg

http://imageshack.us/a/img560/3643/94146811.jpg

http://imageshack.us/a/img685/385/35954499.jpg

http://imageshack.us/a/img801/5313/49573662.jpg

http://imageshack.us/a/img145/5535/15849713.jpg



• Motherboard: HP - 365C - North Bridge: Intel Ironlake-M IMC - South Bridge: Intel Ibex Peak-M PM55

• CPU: Intel/ Core i5 430M/ 2266MHz/x86, x86-64, MMX, SSE, SSE2, SSE3, SSSE3, SSE4.1, SSE4.2

• Audio: IDT 92HD75B3 Intel Ibex Peak PCH

• Audio: nVIDIA HDMI @ nVIDIA GT218 - High Definition Audio Controller PCI

• Wireless Network: PCI-E Broadcom 4322AG

• Video: nVIDIA GeForce G105M CUDA 512MB - onboard


Grato


Digitalizer.

Link to comment
Share on other sites

olá


dentro do cd estão varios kernel


usa um deles no teu hd


pois o cd está a usar um kernel proprio


deve ser o legacy_kernel


procura no cd deve estar num dos dmg k ele tem


bom hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

<?xml version="1.0" encoding="UTF-8"?>


Deletei o Legacy_Kernel da raiz do HD Snow Leopard e copiei o "Legacy_kernel" do CD de boot e colei no lugar do original deletado. Não funcionou.


Obs. Legacy_Kernel original -----> 12MB ............ Legacy_kernel do CD OSX86 ModCD ----> 7.5MB

A tela do Chameleon Wizard é a mesma de antes e o arquivo "org.chameleon.Boot.plist" é:





GraphicsEnabler

Yes

Kernel

legacy_kernel

Kernel Flags

cpus=1

Timeout

5

busratio

17





Grato.


Digitalizer

Link to comment
Share on other sites

Não funcionou.


Fiz fiz o download do legacy_kernel --> legacy_kernel-10.6.0.pkg e executei o pkg configurei o "org.chameleon.Boot.plist" assim:


<?xml version="1.0" encoding="UTF-8"?>




GraphicsEnabler

Yes

Hide Partition

hd(0,2) hd(1,1)

Kernel

legacy_kernel

Kernel Flags

arch=i386

cpus=1

Timeout

5

busratio

17




Arquivos no HD do Snow Leopard: http://imageshack.us/a/img803/8247/conteudodohdsnowleopard.jpg


Grato.



Digitalizer.

Link to comment
Share on other sites

Concordo plenamente! Eu achei estranho quando você indicou-me o link ---> http://www.nawcom.com/osx86/files/10.6/Kernels/ ---- mas mesmo assim, tentei e utilizei na verdade o ---> legacy_kernel-10.7.0.pkg.zip. Nessas horas quando nada dá certo, a gente tenta de tudo um pouco.


Observação # 1 - Na instalação original do SL 10.6.8, já possuia um Legacy_kernel e mach_kernel, e editei o "org.chameleon.Boot.plist" como dito acima também.

Observação # 2 - Na pasta EXTRA do OSX86 ModCD, encontra-se esses arquivos (ficheiros):

- .DS_Store

- com.apple.Boot.plist

- Extensions.mkext

- legacy_kernel

- mach_kernel

- modbin_kernel

- postBoot.img

- smbios.plist



Obervação # 3 - O "com.apple.Boot.plist" dentro da pasta EXTRA está assim:


<?xml version="1.0" encoding="UTF-8"?>




Kernel

rd(0,0)/Extra/legacy_kernel

Kernel Flags

-v maxmem=2048 cpus=1 arch=i386

Legacy Logo

No

DSDT

rd(0,0)/Extra/DSDT.aml

Wait

Yes

GraphicsEnabler

No

SMBIOS

rd(0,0)/Extra/smbios.plist





Grato.


Digitalizer.

Link to comment
Share on other sites

olá


Kernel

legacy_kernel

Kernel Flags

-v maxmem=2048 cpus=1 arch=i386

Legacy Logo

No

DSDT

/Extra/DSDT.aml

Wait

Yes

GraphicsEnabler

No

SMBIOS

/Extra/smbios.plist


o legacy_kernel n está na root do hd / ?

tens dsdt na extra do hd ?

tens smbios.plist na extra do hd ?


se assim for edita o file e mete como está ai


bom hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

Funcionou!!!!!


O arquivo (file) org.chameleon.boot.plist precisava das "kernel Flags" -force64 e arch=i386.



Kernel

legacy_kernel

Kernel Flags

-force64 arch=i386

busratio

17

GraphicsEnabler

No

Hide Partition

hd(0,2) hd(1,1)

Rename Partition

"Reservado pelo Sistema" "Windows 7 Ultimate"


Obrigado mais uma vez pelas GRANDES dicas e pela paciência que teve, sempre que preciso de ajuda, as maiores e mais precisas vem de você.


Muito grato!


Digitalizer.

Link to comment
Share on other sites

olá


estamos aki para isso


mac os x é 99% de paciência, persistência, pesquisa e leitura, e 1% de sorte k teu hardware seja compativel


o ideal era usares o mach_kernel, mas se n consegues.. tens de ficar mesmo por esse.


e agora é disfrutar do sistema


bom hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...