Jump to content

Olarila HackBeast GA Z590 Vision D with Thunderbolt - Full DSDT patches - Guide and Discussion


Recommended Posts

  • Replies 93
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Donation with Paypal https://tinyurl.com/r7fchn9 Donation with Stripe https://tinyurl.com/2ssnydn6 Donation with BuyMeaCoffee https://tinyurl.com/bvsbpf6e Donation with BTC 33HeGCuCSh4t

Enjoy!

Hi MaLd0n This Run me Dumping on Big Sur 11.4 with ioreg

In the past with error I ran on Catalina OS

but it same problem in 11.4

the Thunderbolt Hard Drive not blinking when boot (I think bios setting wrong)

Wifi found but not find any SSID

Bluetooth show but not connect magic mouse2

My external hdd via USB C not found too

Please Help

Thanks

 

Send me Meens-Hackintosh.zip

15 minutes ago, bramon said:

Hi MaLd0n This Run me Dumping on Big Sur 11.4 with ioreg

In the past with error I ran on Catalina OS

I put you new EFI  so magic mouse 2 working correctly

but it same problem in 11.4

the Thunderbolt Hard Drive not blinking when boot (I think bios setting wrong I will try in Window 10)

Wifi found but not find any SSID

My external hdd via USB C not found

And Airport display not found (it work in Catalina)

Please Help

Thanks

 

https://drive.google.com/file/d/1AP4uGOQfqcv9mb9SpK1GcL4fam7F1IBR/view?usp=sharing

 

https://drive.google.com/drive/folders/14P9qgFg132a9oxRgjji8j8sgxPcA8YsT?usp=sharing

Link to post
Share on other sites
  • Administrators
1 hour ago, bramon said:

Wifi found but not find any SSID

for bigsur need this version, replace

https://github.com/OpenIntelWireless/itlwm/releases/download/v1.3.0/AirportItlwm_v1.3.0_stable_BigSur.kext.zip

1 hour ago, bramon said:

Bluetooth show but not connect magic mouse2

in bigsur 11.3+ xhci patch stop work. we need remap usb.

first step is disable xhciportlimit in config.plist, reboot and start remap usb2

Link to post
Share on other sites
On 7/24/2021 at 4:16 AM, bramon said:

H

 

Hi MaLd0n  ACPI Eater

So now every thing is working. Thank a lot!!

But I try to use intel JHL8540 Maple Ridge Thunderbolt 3 NHI but Driver is said NO

I just follow from this link

https://www.insanelymac.com/forum/topic/347917-gigabyte-z590-vision-d-i7-10700k-32gb-ddr4-3000-sapphire-pulse-rx580-8gb-gc-alpineridge-thunderbolt/

I think my USB C drive is all active But real Thunderbolt hard drive not found the driver to actives

Or I can FLASH TB4?

because I have flash my alpine ridge and it working well on real mac.

THIS IS RUN ME FILES

https://drive.google.com/drive/folders/1B0gSTl7X9PV59U8AXzRkpYcYe49mXqLO?usp=sharing

AND PICTURE

https://drive.google.com/file/d/1NddNssH_F17lmlnkVp7plFNFsBeS5dR7/view?usp=sharing

 

Hope you can find solution

Thanks 

Bramon

 

Link to post
Share on other sites
  • 2 weeks later...

I made a donation via paypal...I would really appreciate some help.

I have macOS 11.5 installed.

Need help getting my Thunderbolt/USB to work and my GPU's

VM is running in Proxmox 7

Corsair Vengeance RGB Pro 32GB (4x8GB) DDR4 3200MHz C16 LED Desktop Memory CMW32GX4M4C3200C16

GIGABYTE Z590 VISION D LGA 1200

Intel Core i9-11900K 

WD_BLACK 1TB SN850 NVMe

Corsair iCUE H150i Elite Capellix Liquid CPU Cooler

NVIDIA GeForce RTX 2060

Sapphire Pulse Radeon RX 580 8GB GDDR5

RunMe-Output.txt.zip

Link to post
Share on other sites

I installed hackintosh catalina, on my gigabyte z590 Vision D with i9 10900K, but now

USB 3 devices not detecting

Thunderbolt not working

and network preferance pane error.

Please help...Thanks in advance..

 

Link to post
Share on other sites

Donated! Having some issues with my TB3, I run UAD hardware for my audio profession. Upgraded to the z590 for some increased stability, so far not the case YET

 

Here's that dump = https://www.dropbox.com/sh/jfyu0whg10nqg5r/AAARVWWfAN-RkcvK0opebrh4a?dl=0

Link to post
Share on other sites
  • Administrators
1 hour ago, Brendan McDonnell said:

Having some issues with my TB3

DSDT.aml.zip

hot plug don't work in this case

in som e cases need enable virtualization for some audio cards

Link to post
Share on other sites
  • Administrators
2 hours ago, Brendan McDonnell said:

Curious, do we have iGPU abilities? Selling my 5700xt and was going to use iGPU while I wait for my new one to ship

11th gen igpu dont work. we need one dgpu

Link to post
Share on other sites
  • Administrators
7 hours ago, Brendan McDonnell said:

I'm actually on 10th gen - know if there has been success there with the z590?

many people report problem with 10gen igpu with chipset serie 500

Link to post
Share on other sites
On 8/12/2021 at 8:24 PM, MaLd0n said:

many people report problem with 10gen igpu with chipset serie 500

My 6900xt showed up so I'm all set, though I don't think I have full GPU acceleration - going to keep investigating there. But other then that I'm rock solid. Thank you for the DSDT

Link to post
Share on other sites

Hi MaLd0n! Thanks for all your guides! I have sent you a donation. Can I please get a patched DSDT? I have tried to do everything to get ethernet (i225-V) working, but it just won't work. It shows connected and I get an ip from my router as well, but there is no internet connection. I need to use ethernet rather than wireless. Thanks for your help!

Z590 Vision D

Core i9 10850K

64GB Crucial Ballistix 3600

Sabrent 2TB Rocket NVMe

macOS 11.5.2

 

Generated file: https://www.dropbox.com/s/8gjn62k4d886kju/Send me iMac-Pro.zip?dl=0

 

 

5 minutes ago, hotboi said:

Hi MaLd0n! Thanks for all your guides! I have sent you a donation. Can I please get a patched DSDT? I have tried to do everything to get ethernet (i225-V) working, but it just won't work. It shows connected and I get an ip from my router as well, but there is no internet connection. I need to use ethernet rather than wireless. Thanks for your help!

Z590 Vision D

Core i9 10850K

64GB Crucial Ballistix 3600

Sabrent 2TB Rocket NVMe

macOS 11.5.2

 

Generated file: https://www.dropbox.com/s/8gjn62k4d886kju/Send me iMac-Pro.zip?dl=0

 

 

In case you need it, dGPU XFX Radeon 580 GTS XXX Edition 8 GB

Link to post
Share on other sites

What ACPI Quirks do I need? Anything in Booter or Kernel? Also, do I need to delete all other Device Properties since I am using DSDT?

Edited by hotboi
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

:cap-Please Disable Your ADBlocker-:cap