Jump to content
jonatanosx

Still waiting for root device

Recommended Posts

Boa noite Pessoal,


Tenho um PC com o Lion 10.7.3 rodando perfeito, tentei instalar o 10.8 Versao final, app store.

Tinha testado o DP1 e DP2 e funcionava melhor que o lion, mas com a versao final usando o mesmo procedimento que usei com os outros ele instala normal, mas na hora de iniciar ele fica em Still waiting for root device e a cada minuto vai aumentando uma linha de Still waiting for root device, ja tentei com -f e nao vai, -x nao vai.


A unica flag que necessito para iniciar era npci=0x2000, uso npci=0x2000 -f, npci=0x2000 -x e para no mesmo problem.


Alguma solucao??


Obrigado

Link to comment
Share on other sites

Desta forma deu erro


eu fiz assim, aplicando linha por linha no terminal:

 

kext_dir=/Volumes/ML/System/Library/Extensions
cd $kext_dir/IOAHCIFamily.kext/Contents/PlugIns/IOAHCIBlockStorage.kext/Contents/MacOS
sudo mv IOAHCIBlockStorage IOAHCIBlockStorage.orig
sudo cp IOAHCIBlockStorage.orig IOAHCIBlockStorage
sudo /Volumes/ML/usr/bin/perl -pi -e 's|\xeb\x4c\x00\x00\xea\x03|\xeb\x4c\x00\x00\xe8\x01|g' IOAHCIBlockStorage
sudo /Volumes/ML/usr/bin/perl -pi -e 's|\x74\x0e\x48\x8d\x3d\xa5\x90\x00\x00|\xbf\xc8\x00\x00\x00\x90\x90\x90\x90|g' IOAHCIBlockStorage
sudo touch $kext_dir

 

Reiniciei e tentei e nao funcionou, teste USBBusFix=Yes e passou

porem ele vai ate uma parte e na parte de iniciar a parte grafica, apaga o monitor e nao aparece mais nada, consegui duas vezes usando USBBusFix=Yes passar desta parte, porem agora mesmo com essa flag nao passa dessa parte.

Link to comment
Share on other sites

Não era pra rodar linha por linha no terminal, era pra editar o script, salvar e executar.


No Lion, recupere o backup da kext

cd /System/Library/Extensions/IOAHCIFamily.kext/Contents/PlugIns/IOAHCIBlockStorage.kext/Contents/MacOS
sudo mv IOAHCIBlockStorage.orig IOAHCIBlockStorage
sudo touch /System/Library/Extensions

 

Sobre o vídeo no ML, mova as kexts pra fora de /S/L/E pra fazer os ajustes http://Olarila.com/forum/viewtopic.php?f=27&t=1677

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

eu editei e ai aparece isso:

Last login: Wed Aug 1 22:36:02 on ttys000

/Users/jonatanrinckus/Downloads/patch-ahci-mlion\ 2 ; exit;

MacBook-Pro-de-Jonatan:~ jonatanrinckus$ /Users/jonatanrinckus/Downloads/patch-ahci-mlion\ 2 ; exit;

/Users/jonatanrinckus/Downloads/patch-ahci-mlion 2: line 11: do ML/System/Library/Extensions: No such file or directory

/Users/jonatanrinckus/Downloads/patch-ahci-mlion 2: line 12: cd: /IOAHCIFamily.kext/Contents/PlugIns/IOAHCIBlockStorage.kext/Contents/MacOS: No such file or directory

mv: rename IOAHCIBlockStorage to IOAHCIBlockStorage.orig: No such file or directory

cp: IOAHCIBlockStorage.orig: No such file or directory

Can't open IOAHCIBlockStorage: No such file or directory.

Can't open IOAHCIBlockStorage: No such file or directory.

usage:

touch [-A [-][[hh]mm]SS] [-acfhm] [-r file] [-t [[CC]YY]MMDDhhmm[.SS]] file ...

logout


[Processo concluído]

 

Vou ver sobre isso o video, nem iniciando com -x o video vai

Link to comment
Share on other sites

Ola galera, tenho Snow Leopard rodando liso no meu PC, mas to querendo rodar o lion, ja li varios topicos neste e em outros sites, sempre sigo tutoriais do oldnapalm, mas esta impossivel subir o lion em meu pc, gostaria de uma ajuda, segue a foto do boot com -v com pendrive restaurado. com kernel legacy modificado tambem e com finder DP2.


Placa Mae ECS GForce 8200a

Processador AMD Phenom X4 945

4 gb memoria ddr2

zotac gts 250 1gb ddr2

img0007tn.jpg

Link to comment
Share on other sites

No Snow você precisa de algum fix pras USB (DSDT ou kexts modificadas)?


Provavelmente vai precisar também no Lion, além da kext pra controladora SATA (se não tiver modo AHCI).

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

No Snow você precisa de algum fix pras USB (DSDT ou kexts modificadas)?


Provavelmente vai precisar também no Lion, além da kext pra controladora SATA (se não tiver modo AHCI).

 

Ola Cassio, eu instalei o snow 10.6.3 retail, e atualizei pro 10.6.8, uso dsdt e algumas kexts, mas ja copiei elas pra pasta extra do lion, mas nao sobe de jeito nenhum, vc viu a foto?? o que pode ser??

Link to comment
Share on other sites

A foto tá muito pequena, não consigo ler.


Se é o erro do título, no boot por pen drive, só pode ser algum problema de USB.


Tentou usar uma partição do HD ao invés de pen drive?

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...