Jump to content

#[EB|LOG:EXITBS:START] error OpenCore Big Sur 11.1


Recommended Posts

hi,

I have a Asus TUF Gaming FX506LI with an i5-10300H processor and UHD / GTX1650 graphics.
Whatever I try with things as described here:

https://forum.amd-osx.com/index.php?threads/asus-bios-upgrade-stuck-eb-log-exitbs-start.546/

does not work.
I tried the OpenCore folder for cometlake from here:

without success, I keep getting the error in the title.
I have BIOS 3.06, there is not much to configure, secure boot and vt-d are off.

Did anyone get beyond this or has any tips?

Thank you

I tried EFI OpenCore Serie 300.400.zip which is for desktop, but at least that gets it to boot further.

Not sure why this works and the laptop ones don't?

Now I have the next error:

boot-tuf15.zip

Error Domain = NSPosixErrorDomain 30 .

at least a step further... tips welcome :)

Link to post
Share on other sites

Progress :). I added the pci device under DeviceProperties - add:

PciRoot(0x0)/Pci(0x2,0x0)

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>framebuffer-unifiedmem</key>
    <data>AAAAgA==</data>
    <key>disable-external-gpu</key>
    <data>AQAAAA==</data>
    <key>framebuffer-stolenmem</key>
    <data>AAAwAQ==</data>
    <key>framebuffer-fbmem</key>
    <data>AACQAA==</data>
    <key>AAPL,slot-name</key>
    <string>Internal</string>
    <key>device_type</key>
    <string>VGA compatible controller</string>
    <key>model</key>
    <string>Intel UHD Graphics 630</string>
    <key>hda-gfx</key>
    <string>onboard-1</string>
    <key>device-id</key>
    <data>mz4AAA==</data>
    <key>framebuffer-patch-enable</key>
    <data>AQAAAA==</data>
    <key>AAPL,ig-platform-id</key>
    <data>AACbPg==</data>
</dict>
</plist>

Then I changed PlatformInfo to use MacBookPRo16,1 and used GenSMBbios to generate the proer fields.
After that it booted.
After first reboot the fans went high but it all went well ( had to use external keyboard and mouse ).

I was able to finish it and boot into the OS. on to fixing everything now :).
Thanks to everyone in the community making this possible, you know who you are :)

Link to post
Share on other sites

Thanks for that, I saw them. I started from scratch with the opencore guide and kept walking into that issue.
Haven't followed those, but might take a look when stuck. Gonna work on elimination now, boot is quite slow with current setup, when booted it's fine, recognises screen and everything, also network card. 
Will try and post results when reasonable, might take a while..

I hope others will share too if they succeed before me!

 

Link to post
Share on other sites

Wowsers, I just see this now, thanks so much :)!

It seems almost everything works!

I have some issues with the mouse buttons sometimes not responding but the touchpad works great.
The keyboard works, but the hotkeys for brightness do not, although there is a slider and that works.
Sound is not working.
Sleep works, as does the battery indicator.

I'm impressed and very happy, can you explain how you did that and how I can go from here?

I'm really happy because not much time free at the moment to try it myself.
This is a great start!

Bluetooth device does not show up, I think it did before but it didn't work, this laptop has the intel AX201 or something.
Thanks for the help and happy to supply more info. 
Thank you for your help en doing this! 

I have bluetooth and wifi working with intel kexts, heliport and itwlm.
One other issue I noticed that sometimes it takes really long for the login screen to appear.
I thought it was something with the keyboard driver or memory, but not sure.

For example, when I used your folder from USB the first time I got the apple logo after debug output and the load bar, but after that (from disk) it always stays black long, no apple logo and then the login screen appears.

I'll try some ALC layout id's for audio if I have time again. Thanks so much so far!

Link to post
Share on other sites

hi, thanks, that DSDT fixed the brightness keys.
It's the super key that is mapped to apple now, I think that changed in VoodooPS2 or IC2? 
On my other laptop I use an older version to have the alt keys mapped, is there a way to do that with the newer driver?

I have sound with alcid=5 without mic, but it works with 11, so fixed :).

So fixed since start : bluetooth, wifi, sound, brightness keys.

Remaining:
 - long black screen at boot
 - touchpad buttons flaky/not responding

Nice to haves:

 - more mappings for special keys - touchpad off, fan control, but mostly keyboard light control / aura and remapping super key - gonna try the other driver

 - undervolting / temp control / cpu support for optimal temps

Otherwise, this seems perfect!

Thank you so much for your help, I will post if I make progress. Especially the boot wait is a mystery, any ideas on that?

[update, small addition] - I noticed the touchpad buttons are not doing anything at the moment, as opposed to occasionally. it looked like this timing issue in the driver before that I read about long ago

The attached VoodooPS2Controller kext gives me the mapping for ALT I want.

Interestingly, the first time I installed it/used it, I did not get the black screen wait at boot.
Then after another boot, again the black screen.
It seems OpenCore does something when a file is changed in the driver folder, or it waits when  not?

I basically would only have that issue fixed, then I'm very happy and the computer is usable as I want it to.
Could you attach a DSDT with the buttons enabled and brightness working or perhaps attached the last source and the patch so I can try?
I'm happy to do some of the work ;).

thanks a lot!

VoodooPS2Controller.kext.zip

Edited by openminded
Link to post
Share on other sites

another small update: it seems the left touchpad button works as a 'drag support' button only, meaning when clicked on a bar and moving it works, but when just clicked it does not work as a normal click (no focus change). The right button does not work.

Link to post
Share on other sites
  • Administrators

right button is two fingers tap

left is one tap

 

drag

Go to System Preferences/Accessibility/PointerControl/Trackpad Options and "Enable dragging"

45AXPIX.png

Link to post
Share on other sites

I, yes I am aware of the options to use the touchpad like that, what would really make me happy is if the left and right button work properly too. Currently I can usually use the left button to drag and occasionally it works as normal click (one finger) , but not always. The left button does not do anything at all.
In general, there are some slight tears with the trackpad every now and then.
It would be great if this would work including normal buttons, I might try the ELAN plugin but read bad things about it.
Did you put an OSI->XOSI patch in the DSDT to make it work?

Regarding the black screen I know a bit more: the issue is not delayed boot, it's the backlight going to the lowest value and then after some time going back to normal.
I had this on my Dell when I upgraded to OpenCore 0.6.5. and when going back to 0.6.4 it was solved.
I tried that on this machine without success.
Do you have an idea to why this happens?
brightness controls don't afffect the brightness until that time of say a few minutes is past).

And again, if some driver is changed in the EFI folder, this issue does not occur after first boot.
Seems like some delay in reading values?

I'm gonna make a small donation for your work, thanks a lot. Would be great to have these last things sorted, then I might spend some time getting more keys to work (and for example switch function keys, which is not available now).

thanks!

 

 

 

Link to post
Share on other sites

I created a git repo for it and gave you credit:

https://github.com/VGerris/asus-tuf-15-opencore

I made a small donation as a token of appreciation for your help.

For everyone needing a fully working setup with the above, please go there.

Todo as of now:
 - fix delayed brightness setting at boot ( screen black for a few minutes )
 - fix minor trackpad issues
 - map more fn keys / add fn switch for keyboard
 - make USB-c dock work for video ( audio seems to work )

If I get to it, I will try to fix these, please contribute if you have any fixes to add, thanks.
I made a small donation as a token of appreciation for your help

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

:cap-Please Disable Your ADBlocker and Support Our Forum-:cap