Jump to content
Sign in to follow this  

Acer Aspire 5 514-51-58TL

Recommended Posts

Thanks to MaLd0n for all his help and patience for over more than a week of work with DSDT and SSDT patching.


Acer Aspire 5 series laptop

Model 514-51-58TL


CPU: Intel Core i5-8265U

Graphics: Intel UHD 620

Memory: 8GB DDR4



256Gb PCIe NVMe SSD (macOS Catalina)

480Gb SATA SSD (Windows 10)


OpenCore Catalina installed following OpenCore website guide.


Initial results:


Video (lilu and whatevergreen kext)

Audio (lilu, applealc kext and bootloader argument alcid=3)

Keyboard (with VoodooPS2 kext)

Ethernet (with RealtekRTL8111 kext, but older version)


Not Working:


Battery meter



At first MaLd0n tried to fix by patching DSDT. This fixed the trackpad (after also installing older versions of VoodooI2C and VoodooI2CHID kexts), and sleep, but keyboard stopped working, apparently because of buggy ACPI.


So next it was tried to fix with SSDTs. This way battery meter would work (after proper kext was installed), as well keyboard, and trackpad. Finally sleep also was fixed with bootloader patch _PRW to ZPRW.


Only minor issues remaining:


Can’t turn off bluetooth (probably due to incompatible wifi/BT card, I’m not sure if I can change it in this machine).

iMessage not working (don’t know how to call Apple from Uruguay so they fix my iCloud user)


Screenshots and benchmark:

(wallpaper for trolling purposes)





Edited by cuartetoraro

Share this post

Link to post
Share on other sites
25 minutes ago, cuartetoraro said:

(wallpaper for trolling purposes)


  • Haha 1

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...