Jump to content
BoomR

DSDT patch request: ASRock H77M-ITX

Recommended Posts

I flashed my new board to the latest BIOS ROM - 1.10, then did successful unishit (v1.3) install of 10.7.4. No problems thus far, except I didn't have any Ethernet support once I got to the desktop. No biggie - had DSDT Editor on a USB flash drive as well as Java Runtime installer.


Ran DSDT Editor & extracted DSDT, then I followed the instructions in DSDT 101 posting and applied all the usual/customary patches plus my specific audio patch. When I went to compile, then fix errors, I still get this one lingering error:

compile_err1.png


When I click the error message to see the detail, here's what is displayed:

compile_err2a.png


It appears that, until I correct this error, I cannot get to the "Save as AML..." command (grayed out).


I'm attaching the original DSDT that I saved before all my mucking about. Any assistance with creating a proper patch which I can then apply would be much appreciated!

H77M-ITX_1.10ROM_extract.zip

Link to comment
Share on other sites

I don't know the correct fix for this error.


If you just remove the non-hex digits you'll be able to compile, but I don't know if it will have any side effect.


Replace "ABCDEFGH" by "ABCDEFFF" (instead of FF it could be any digit 0-9, A-F).

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

UGH... trying this again:


Based on re-reading DSDT 101 a bit more thoroughly, I've applied the following patches:


Power Management:

LPC Sandy Bridge

HPET


USB:

EHCI

ICH9 USB sleep


Others from DSDT 101:

RTC

ACL892

DTGP

IRQs

SMBUS


IF I try to apply HDEF, I get a bazillion more errors :-(

...but if I omit applying HDEF, then compile & "fix errors," and fix the hex error per your suggestion, I'm down to 1 error: "Object does not exist (ATT3)" - see attached screen grab.


I'm attaching a "fresh" extract of the baseline DSDT (I re-flashed the bios, then used DSDT Editor to extract after initial 10.7.3 unishit install), as well as the patched version with the 1 remaining error. I welcome any insights or suggestions. THANKS!

199544005_CompileErrors.png.c4c0ade5ac6130e6ffbb69d01a7c07f5.png

H77MITX1.10_extracted.dsl.zip

H77MITX1.10_patched.dsl.zip

Link to comment
Share on other sites

adapt _CRS to return the ResourceTemplate right above

You need to replace ATT3 by BUF0

                    Method (_CRS, 0, NotSerialized)
                   {
                       Return (BUF0)
                   }

 

You don't need HDEF patch, the device already exists.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Thanks very much!! I'll try that first thing in the a.m.


I'm really excited to get this build working - I'm doing a G4 Cube hack ;). Unlike the gigabyte mini-ITX board, this one has a few extra mm's between the edge of the circuit board & the outside DIMM slot, leaving room for me to still use the original touch-sensor power button!!

Link to comment
Share on other sites

ERP... I didn't even think to select a profile like Mini or iMac at this state... and no, I didn't do the patch. Crap. Just to confirm: I extract the .zip file on my Hack once I've completed my initial lion install - and run it as instructed either before or after I run multishit & use my DSDT (but before I reboot after running MB)?


This is definitely a steeper learning curve than I thought. I appreciate your patience and assistance!! :D

Link to comment
Share on other sites

In Lion Edition multishit, there's now an option in the Kexts/Enablers section for the AICPM - see attached. Selecting the option for 10.7.3 (which is what I'm using) as well as the iMac 12,2 option via MB should give me the equivalent of what you were suggesting via the patcher + the Chameleon Wizard screen grab you included, correct?

7887260_MBoptions.jpg.72ffe3908f4ac0e14141c5bf09b75765.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...