Jump to content
urosn

Can't install OS X Lion on Gigabyte EP43-DS3L

Recommended Posts

Hello,


I'm trying to install OS X Lion for a few days without a success. I have already installed Windows7 and planned to have a dual-boot (Win7 x64 and OS X Lion 10.7.3).


I have:

- Gigabyte GA EP43-DS3L (bios version F8)

- Intel quad-core Q9300

- DDR2 Muskin XP2-8000 2×2GB

- Sapphire Radeon 5870 Vapor-X 1GB

- WD 500GB WD5000AAKS (1× Primary NTFS 100GB (Win7 x64), 1× Primary NTFS 100GB, 1× Extended unpartitioned space (from what is left))


With the help of DSDTParser (under Win7 on the same machine) and this thread (viewtopic.php?t=35559), I created a DSDT.aml using two patches:

1. GA EP43-DS3L (http://Olarila.com/Packs/Gigabyte/GA%20EP43-DS3L.txt)

2. ALC888 (http://Olarila.com/Patches/HDEF%20Gigab ... %20888.txt)


Three erros was auto-fixed (i attached the exported DSDT.aml file in DSDT.zip). I copied the file later on on the bootable Lion USB under /Extra folder.


I followed the instructions on the following link and created a bootable Lion USB with my working Lion VMware machine:

http://themacmob.com/how-to-create-a-bo ... usb-drive/


My last try was creating a bootable Lion USB with the Lion 10.7.3 Retail (dmg) (the install result is the same using version 10.7 and 10.7.1).


When I boot the Lion bootable USB (without any boot parameters), I get to the line ** Device in slot: SLOT--1 ** and then a black screen blinks (I waited for more then 30minutes - every now and then there was a welcome screen just for a very short period of time <0.5s).


When I use flags -v -x before booting, there is a "BootCacheControl: Unable to open /var/db/BootCache.playlist: 2 No such file or directory" followed by one &Bug (see the "Boot Log.jpg" in the attached Error Logs 3-4.zip"), then I get the same flashing screen which eventually (after a few seconds) shows a welcome screen without any further flashing. When I click Next, there is a message that the error occured and the log is shown. I attached the log in four pieces in "Error Logs 1-2.zip" and Error "Logs 3-4.zip" (sorry for the bad quality).


I don't know what to do next. Is there anything helpful in the log?


Please for help.


Regards,

Uros

Error Logs 1-2.zip

Error Logs 3-4.zip

DSDT.zip

Link to comment
Share on other sites

Thank you for your reply.


I tried LionDvd from this forum without a success. I get to the same flashing black screen. Is there any other thing that I can try out.


It seems as my motherboard is the only one in the world (with the intel chipset) that has problems with os x lion :) .


Regards

Link to comment
Share on other sites

Hi,


Thank you for your help.


For now it seems that this time there is nothing to attach :) .


When I tested the OS X Lion DVD from this forum, I overlooked the F8 key. With the use of F8 (Install) I managed to proceed with the installation (without any additional parameters). My installation now stopped because of an old PS/2 keyboard :) and I could get an USB keyboard not before Monday. Do you perhaps know if there is an other way to set the correct parameters (maybe before burning a DVD from ISO)?


I suppose I could meanwhile repair the MBR for Win7. I could proceed the installation later on using the DVD to get to the Chameleon and select the OSX on my newly installed partition.


I noticed a strange behavior in BIOS (at least for my humble knowledge). I have now this inaccessible keyboard screen shown. When I restart the computer, it shuts off and after second or two it turns back on. It seems that this procedure resets the BIOS (there is SATA AHCI Mode Disabled, HPET mode 32bit, ram latency and speed resets to default values). I suppose this is due to the default DSDT.aml used (I leave the DVD ISO untouched). Will the BIOS persists its state after I install patched DSDT.am, right after the installation finishes?


Thank you again for all your help.


Regards,

Uros

Link to comment
Share on other sites

Hi,


Thanks man. I'm getting closer and closer to the working Lion.


I used the disk utility in the beginning of the installation process to format my partition to "Mac OS Extended (Journaled)" and proceed with the installation.


During the installation process Lion restarted itself (I needed to manually restore my BIOS settings mentioned in my previous post) and use boot loader from the DVD to proceed. In single user mode (-s) I fixed my PS/2 keyboard, reboot again, restore BIOS settings and use boot loader from the DVD.


Then, after a few steps, my Lion successfully launched for the first time.


In the post installation process did the following:

- launched Chamelleon Wizard (from the link you provided) and installed "Built-In - v2.1svn r1819" Chameleon with method "Boot0hfs" to my Lion OS partition. At this point there is no org.chameleon.Boot.

- I launched multishit 4.4.0 (Lion Edition) and checked/installed the following packages:

- UserDSDT Install (I copied my DSDT.aml file to the desktop)

- System Utilites (inside is just Repair Permission)

- Drivers & Bootloaders -> Kexts & Enablers -> Audio -> Realtek ALC8xx

- Drivers & Bootloaders -> Kexts & Enablers -> Miscellaneous -> FakeSMC

- Drivers & Bootloaders -> Kexts & Enablers -> Miscellaneous -> NullCPUPowerManagement

- Drivers & Bootloaders -> Kexts & Enablers -> Miscellaneous -> PS/2 Keyboard/Mice and Trackpads

- Drivers & Bootloaders -> Kexts & Enablers -> Network -> Realtek Gigabit Ethernet 2.0.6 for 10.7


After that my network started to work (with the DHCP).

There is still no sound out of the Lion. Under system report I have Audio (Built In) and two rows:

- Intel High Definition Audio -> Audio ID: 898

- Intel High Definition Audio -> Audio ID: 898 and then bunch of other rows: "Line Output", "External Microphone",....


What is the best procedure now to fix the audio. Is it better to update to 10.3.7 (or 10.7.4) and then fix the audio.


Then I restarted the machine. I noticed that machine turned off for a second or two and the bios resets its parameters. I then manually set all the BIOS parameters again and loading grey apple logo appeared and then after a while my display shuts off.


Then I reset the machine (BIOS preserve the settings this time), I've successfully booted up my Lion using the Loader from the DVD. This time disk utility works.


Please for your help. What have I missed? It seems that I have problems installing a boot loader (Chameleon).


Regards,

Uros

Link to comment
Share on other sites

hello


if u use a custom dsdt


don't need to use nullcpupowermanagement


enter in org.chameleon.boot.plist


generate p and c-states


any doubts, enter in chat


good hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

Hi,


Thanks again for your help. I have finally found out what was wrong with all my Lion Bootable USB drives I created before posting questions on this site. I should use boot flag GraphicsEnabler=No. Welcome screen shows without flashing when I use my USB. I understand that that flag would disable graphics acceleration, but at least I would be able to install the OS.


After you left the chat I played a little bit and did some reading on the forums. Suddenly my screens ended flashing with the help of the boot flag AtiConfig=Uakari. I would appreciate it, if someone explains what that flag does. For now I only know it's related to framebuffer whatever that is. What is the best way to know which AtiConfig works best for the graphic card used. My booting-up works perfectly now, also with dual displays.


Later on I remembered that before the AtiConfig flag, there was ATI Radeon HD 5000 shown in Graphics/Displays (under System Reports) and now I have the proper name: ATI Radeon HD 5870.


So I ended up with two (for now detected) minor problems:

- pressing the physical eject button on the dvd drive does nothing. Button starts working after eject the disk in osx. You mentioned that this is related to wrong frameset. I really have no clue how to correct that.

- there is no sound due to a wrong kext file installed with multishit. Is there any kext file you could recommend? My audio chipset is Realtek ALC888 (South bridge: ICH10).


It seems that there is a light at the end of the tunnel :).


Regards,

Uros

Link to comment
Share on other sites

Hi,


My problems are solved under 10.7. My audio started to work with the AppleHDA.kext and HDAEnabler.kext. My dvd eject button started to work after I remove Lion OS X Install DVD from the drive.


Update 14.5.2012: I have successfully updated my mac to 10.7.3. Everything worked perfectly for now :).

Update 15.5.2012: I have successfully updated to 10.7.4. Everything works.


Thanks for all the help. I wouldn't have done it without you.


Regards,

Uros

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...