Jump to content

USB Boot to Install Issue


Recommended Posts

Greetings Maldon!

 

I had a big problem while creating a USB Install Hackintosh. After booting into the bootloader I got this error message. Invalid device tree for kext injection. Can you help me get around this error?

 

My PC: 

Motherboard: Supermicro X9DRL-3F/fF

CPU: 2 x Intel(R) Xeon(R) CPU E5-2695 v2 @2.40GHz

Graphics: Radeon RX 580

RAM: 96GB

SSD: Crucial 512GB

 

I apologize for a bit of an error in your donation, so my account cannot upload the EFI.zip file. Would you please check back for me.

https://drive.google.com/file/d/16qgQDN1k43KcRIgkgFNW32jP10kZ9CoV/view?usp=sharing

 

Thanks & Best Regards!

Link to post
Share on other sites

I tried the EFI package for mobo x99, but I got 1 error like this:

119435393_1510712315782491_4721607033217

 

119145862_317166246228692_58492041028021

And finally the black screen.

EFI: https://drive.google.com/file/d/16qgQDN1k43KcRIgkgFNW32jP10kZ9CoV/view?usp=sharing

Please help me!

P/S: I got an error after donating to you, until now I still can't upload 10Mb file. I sent you a message with donate information. Can you check again for me?

Thanks & Best Regards!

 

Edited by Kyle Dang
Link to post
Share on other sites
25 minutes ago, MaLd0n said:

Done

it's work now. just need check about video

u use a uefi mode?

UEFI Settings
To access your BIOS/UEFI, press and hold Delete key on your Keyboard and then set the following.

Set Optimized Defaults.
Set Intel(R) VT-d to Disabled.
Set VGA Priority to Offboard.
Set Serial Port to Disabled.
Set SOL Serial Port to Disabled.
Set Boot Mode Select to UEFI.
Save & Exit Setup.


Yes, the system is running in UFEI mode. What should I do next?

Edited by Kyle Dang
Link to post
Share on other sites
15 hours ago, MaLd0n said:

csm is disable?

what video output u used?

I tried all the remaining ports and the result got 1 displayable. So now what can I do to display at HDMI port?

I am trying to install hackintosh onto my system via DP port.

I have trouble installing the network card. When I selected Local Ethernet the system crashed and rebooted. I had to ignore it but when it booted up my system failed to connect to the network.

What should I do next?

119182161_323019979024190_33209104914320

119192184_597543600915333_57876420764662

Edited by Kyle Dang
Link to post
Share on other sites
12 hours ago, MaLd0n said:

I copied your DSDT.aml to EFI/ACPI/patched instead of the current DSDT file, but my computer still doesn't have an ethernet card and my HDMI port still doesn't work.

How should I use the DSDT.aml file correctly?

Do I need to reinstall Hackintosh?

 

And sometimes I get this error when booting.

119514411_318400312589951_89578266084544

 

Thanks!

EFI.zip

Edited by Kyle Dang
Link to post
Share on other sites
14 hours ago, MaLd0n said:

Greetings Maldon!

I tried again with force kext and ssdt in the above instructions but still failed.

I noticed that the path of my device is a bit different from patches and I fixed it with the path on my device, but still failed.

Can you help me please?

PCI List Tab: 

120089692_355205282341919_40606907821406

And preboot log: 

120017704_376277963765911_67423307203447

 

Thanks!

EFI.zip ETHX.aml.zip

Link to post
Share on other sites

Hi MadL0n!


Everything seems perfect. There's just a little bit of a CPU missing. My system has 2 x Xeon E5-2695 v2, 2.4Ghz CPUs (12x2 = 24 Core, 48 Threads), but currently only get 8 Cores.

I tried again with VoodooTSCSync.kext but still with no success.

I also tried to follow some instructions to export to SSDT.aml but the same result.
Can you help me fix this problem?

119995134_744427209741074_87771112937684

120025692_685108342415166_57259417046816

120027064_1177296659307555_6278842488541

120012934_357401952053875_51902444650321

119941341_2096134060519048_8569761592765

Thanks & Best Regards!

EFI.zip pcidevices.zip ssdt-gen.zip

Link to post
Share on other sites

Greetings MadL0n!

Sorry for the inconvenience.
I am having a problem with the number of Core / Threads in the system.

Quote

14:876  0:001  Out of control with CPU numbers
14:876  0:000  ApicCPUNum=24
14:876  0:000  Maximum control=0x18
14:876  0:000  Turbo control=0x20
14:876  0:000  P-States: min 0xC, max 0x20
14:876  0:000  SSDT with plugin-type without P-States is generated
14:876  0:000  Cleanup XSDT: count=17, length=172
14:876  0:000  corrected XSDT count=17, length=172

Greetings MadL0n!

Sorry for the inconvenience.
I am having a problem with the number of Core / Threads in the system.
My system is limited in number of CPUs. I have tried to fix it following some instructions on internet. I tried to add SSDT-CpuPm.aml to patched folder and add boot args -xcpm_ipi, but still with no success.
Can you help me?

Quote

./ssdtPRGen.sh -mode custom -b Mac-7BA5B2D9E42DDD94 -p 'E5-2695 v2' -c 3 -x 1 -cpus 2 -l 48

120084363_364070907969230_28665971500759

Thanks & Best Regards!

EFI.zip SSDT-CpuPm.aml.zip

Edited by Kyle Dang
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

:cap-Please Disable Your ADBlocker-:cap