Jump to content

rob88v

Members
  • Content Count

    19
  • Joined

  • Last visited

Community Reputation

0 Neutral

Hackintosh Specs

  • CPU
    i7-8700K
  • Motherboard
    Z370 Aorus Gaming 7
  • GPU
    NVIDIA GTX 1080Ti

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Edit: I got the audio working by changing layout 12 patch in my DSDT to 13 and voila! My audio is working 100% now!
  2. I have done this in my config already and still no audio, I am using AppleALC and Lilu method the codec is IDT92HD87B2/4 which is in the supported list for AppleALC and I've used both ids mentioned, but I'm not getting sound injection, which worked with my clover config previously.
  3. Hey @MaLd0n, I recently got my HP Probook 4540s working with OpenCore, I'm having an issue getting the audio working properly as it will not show up at all on the laptop. I got everything else working from brightness to even the battery status with some DSDT patching. I wanted to know if there is any way to get the audio working through DSDT if possible. I am attaching my EFI and DSDT files for you to review when you have time and see what I could be doing incorrectly. My SD Card reader is working but I get a white icon when inserting a card instead of an external drive icon, not sure if that is fixable or not. PS: I am unable to do a send_me file as it messes up at the ioreg dump phase and keeps opening and closing ioregistryexplorer. I appreciate your great work and all that you do for the community. Thanks in advance for your help! HP Probook 4540s Intel Core i7 [email protected] 2.6 Ghz (Turbo Boost 3.6 Ghz)Broadcom Wifi/BT Card (BCM94352HMB)1TB Samsung QVO SSD500GB Time Machine Backup on Samsung 850 EVO SSD http://s000.tinyupload.com/?file_id=95276755548443125551 - EFI Folder with DSDT for OpenCore
  4. Is there a similar guide for this that works with older chipsets like Ivy Bridge, I would love to get this working on my HP probook 4540s if possible. I've put in all the proper renames and changes, but my usb bootloader fails to find my existing macOS Mojave install.
  5. Hi @MaLd0n I just did a recent bios update on my Z370 board to support a 9th gen processor if I decide to get one in the future. With this update I would need to have a new DSDT made for my OpenCore system configuration if you have the time to check out my files. Thanks again for all that you do for this great community! Send_Me Files: http://s000.tinyupload.com/?file_id=00176311356589656644 CPU: i7 8700K OC to 5Ghz GPU: NVIDIA GTX 1080Ti MOBO:Gigabyte Z370 Gaming 7 64 GB Corsair Vengeance LPX Ram
  6. Hi @MaLd0n I just did a recent bios update on my Z370 board to support a 9th gen processor if I decide to get one in the future. With this update I would need to have a new DSDT made for my system configuration if you have the time to check out my files. Thanks again for all that you do for this great community! Send_Me Files: http://s000.tinyupload.com/?file_id=00176311356589656644 CPU: i7 8700K OC to 5Ghz GPU: NVIDIA GTX 1080Ti MOBO:Gigabyte Z370 Gaming 7 64 GB Corsair Vengeance LPX Ram
  7. Thanks that worked for me! Does opencore need anything special in the folder to load windows 10 properly it sees the entry but when I click it the circle spins for a second and it reboots automatically. Any thoughts on what I could be doing wrong?
  8. Thanks @MaLd0n the DSDT works great! The only issue I have is that my iGPU still fails to load the driver, I must of done something incorrect on the framebuffer device properties as I keep getting the "failed to register to framebuffer driver" error, I have attached my config maybe there is an incorrect device id and platform id. I am using a GTX 1080Ti as the dGPU on 10.13.6 ( 17G8030) and my iGPU is the UHD 630 which I am trying to run as connectorless. With clover I used the Kaby Lake fake id, will I still need it with Opencore or should I be able to use the Coffee Lake id's? config.plist.zip
  9. @MaLd0n Here are my send me files for OpenCore for DSDT creation. I've been having trouble getting the iGPU to run connectorless for compute tasks, and I still get this error: [iGPU] Graphics driver failed to load: could not register with Framebuffer driver! I have tried putting in device properties for my iGPU but to no avail. I also have to use alcid=16 for my audio to work as it won't inject in OC normally. It's not a big issue, but I would like to keep the arguments as minimal as possible for my config. Thank you in advance for your outstanding work! PS: I am using 10.13.6 hopefully that won't pose an issue. Send me Seans-Hack-Pro.zip
  10. @MaLd0n Thank you for all your help it has been great! The only feature I am having trouble with is HDMI audio output on the Probook ,does a method need to be implemented in the DSDT to accomplish this?
  11. @MaLd0n The DSDT works great and everything is working great so far, the battery indicator works like a charm and my sd reader is working perfectly. The only question I have is if there is any way I am able to remap the buttons for the fn keys so I don't have to hold down the fn button on the keyboard before hitting the volume or brightness keys? Send me Seans-Hackbook-Pro.zip
  12. Hello @MaLd0n, I did a recent reinstall on my HP probook 4540s laptop and wanted to have a DSDT made for it if possible as I wanted to forego using an older patching method from an old forum that worked for years and was minimal in problems, but now I would rather have a more stable solution down the line for newer updates (ie. Catalina). I mainly need my battery status working, and if possible volume and brightness hotkeys if possible. I'm trying to avoid using third party tools for these small features and make this laptop as vanilla as possible. Thank you so much for all the amazing work that you do in the Hackintosh community! I have my send_me files attached as needed. Send me Seans-Hackbook-Pro.zip
  13. Thank you very much! You are the man as always!
  14. Hi MaLd0n, I am having a small cosmetic issue with my PCI entries in about this mac after making a small edit in the DSDT to fix an auto wake issue my board was having, I have attached my info if you have some time to take a look. Thank you for all that you do! PS: I seem to get an issue where my usb drives eject on sleep and remount on wake, is there any way to make the drives stay mounted on wake? I have heard this issue occurs when you have an XMP profile enabled in the bios, but I really don't want to sacrifice my ram speeds. Any advice you have to possibly solve this issue would be great! Hack Pro Specs: Intel Core i7-8700K @ 5 Ghz OC 32 GB DDR4 3200Mhz Corsair Vengeance LPX Ram Corsair H100i v2 Liquid Cooler Broadcom BCM943602CD Bluetooth/Wifi Combo Card Gigabyte NVIDIA GTX 1080Ti Aorus 11GB Intel UHD630 Active for QuickSync Gigabyte Aorus Z370 Gaming 5 Motherboard 1 TB Samsung 960 EVO M.2 NVME Drive for MacOS LG Bluray Burner/Reader 3 TB WD Black for Time Machine Backups 850W EVGA Supernova G3 PSU Gigabyte GC Alpine Ridge Thunderbolt 3 Card (Working with Hotplugging) Startech SD Card Reader with UHS-II Support https://www.dropbox.com/s/zzclmdfdkb7algj/Send%20me%20Seans-Hack-Pro.zip?dl=0 - SendMe information
  15. Hi MalDon, I just wanted you to check if any changes are needed in my DSDT as it has been a while since my DSDT patch was updated, I'm still running 10.13.6 without issue and with a pending move to Mojave once NVIDIA drivers are released, I want to make sure everything is still running solid. Send me Seans-Hack-Pro.zip
×
×
  • Create New...